[PATCH] gnu: Add fheroes2

  • Done
  • quality assurance status badge
Details
3 participants
  • Andrew Tropin
  • Leo Prikler
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Andrew Tropin
Severity
normal
A
A
Andrew Tropin wrote on 30 Jun 2021 07:49
(address . guix-patches@gnu.org)
87h7hf52c7.fsf@trop.in
* gnu/packages/games.scm (fheroes2): New variable.
---
There are no tests in the project, so they are disabled.

gnu/packages/games.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 83cb738b9c..7a87123df3 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -12511,3 +12511,33 @@ wreckage. You're stranded on a desert island and have to survive. In order to
do so you need to explore the island, find food, build a shelter and try to
get attention, so you get found.")
(license license:cc-by4.0))))
+
+(define-public fheroes2
+ (package
+ (name "fheroes2")
+ (version "0.9.4")
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f
+ #:make-flags '("FHEROES2_STRICT_COMPILATION=1"
+ "RELEASE=1")))
+ (native-inputs
+ `(("gettext" ,gettext-minimal)))
+ (inputs
+ `(("zlib" ,zlib)
+ ("libpng" ,libpng)
+ ("sdl" ,(sdl-union (list sdl2 sdl2-image sdl2-mixer sdl2-ttf)))))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ihhub/fheroes2")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0a3xi3k7ngp0byhmg7wq22l1hix3jwr68prk2y6frqhzbfskrvyg"))))
+ (home-page "https://ihhub.github.io/fheroes2/")
+ (synopsis "Turn-based strategy game engine")
+ (description "Free implementation of Heroes of Might and Magic II (aka
+HOMM2) game engine.")
+ (license license:gpl2)))
--
2.32.0
L
L
Leo Prikler wrote on 30 Jun 2021 11:03
215bf43c7f10fbca3dfe08f5b10c176662cd4798.camel@student.tugraz.at
Am Mittwoch, den 30.06.2021, 08:49 +0300 schrieb Andrew Tropin:
Toggle quote (3 lines)
> * gnu/packages/games.scm (fheroes2): New variable.
> ---
> There are no tests in the project, so they are disabled.
#:tests? #f should always be documented inside the code
Toggle quote (21 lines)
> gnu/packages/games.scm | 30 ++++++++++++++++++++++++++++++
> 1 file changed, 30 insertions(+)
>
> diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
> index 83cb738b9c..7a87123df3 100644
> --- a/gnu/packages/games.scm
> +++ b/gnu/packages/games.scm
> @@ -12511,3 +12511,33 @@ wreckage. You're stranded on a desert
> island and have to survive. In order to
> do so you need to explore the island, find food, build a shelter and
> try to
> get attention, so you get found.")
> (license license:cc-by4.0))))
> +
> +(define-public fheroes2
> + (package
> + (name "fheroes2")
> + (version "0.9.4")
> + (build-system cmake-build-system)
> + (arguments
> + `(#:tests? #f
Add a comment here along the lines of "no tests" or "no check target".
Toggle quote (25 lines)
> + #:make-flags '("FHEROES2_STRICT_COMPILATION=1"
> + "RELEASE=1")))
> + (native-inputs
> + `(("gettext" ,gettext-minimal)))
> + (inputs
> + `(("zlib" ,zlib)
> + ("libpng" ,libpng)
> + ("sdl" ,(sdl-union (list sdl2 sdl2-image sdl2-mixer sdl2-
> ttf)))))
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/ihhub/fheroes2")
> + (commit version)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "0a3xi3k7ngp0byhmg7wq22l1hix3jwr68prk2y6frqhzbfskrvy
> g"))))
> + (home-page "https://ihhub.github.io/fheroes2/")
> + (synopsis "Turn-based strategy game engine")
> + (description "Free implementation of Heroes of Might and Magic
> II (aka
> +HOMM2) game engine.")
> + (license license:gpl2)))
The description is a bit lacking in information. Is this engine
usable? If so, how? We ought not to steer users towards non-free
software.

Regards,
Leo
A
A
Andrew Tropin wrote on 30 Jun 2021 12:17
[PATCH v2] gnu: Add fheroes2
8735szveq6.fsf@trop.in
* gnu/packages/games.scm (fheroes2): New variable.
---
gnu/packages/games.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 83cb738b9c..82595b64b9 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -12511,3 +12511,34 @@ wreckage. You're stranded on a desert island and have to survive. In order to
do so you need to explore the island, find food, build a shelter and try to
get attention, so you get found.")
(license license:cc-by4.0))))
+
+(define-public fheroes2
+ (package
+ (name "fheroes2")
+ (version "0.9.4")
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ #:make-flags '("FHEROES2_STRICT_COMPILATION=1"
+ "RELEASE=1")))
+ (native-inputs
+ `(("gettext" ,gettext-minimal)))
+ (inputs
+ `(("zlib" ,zlib)
+ ("libpng" ,libpng)
+ ("sdl" ,(sdl-union (list sdl2 sdl2-image sdl2-mixer sdl2-ttf)))))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ihhub/fheroes2")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0a3xi3k7ngp0byhmg7wq22l1hix3jwr68prk2y6frqhzbfskrvyg"))))
+ (home-page "https://ihhub.github.io/fheroes2/")
+ (synopsis "Turn-based strategy game engine")
+ (description "Free implementation of Heroes of Might and Magic II (aka
+HOMM2) game engine. Requires assets/game resources to play, @file{fheroes2}
+is looking for them at @file{~/.local/share/fheroes2} folder.")
+ (license license:gpl2)))
--
2.32.0
A
A
Andrew Tropin wrote on 30 Jun 2021 12:20
Re: [PATCH] gnu: Add fheroes2
871r8jvekq.fsf@trop.in
Leo Prikler <leo.prikler@student.tugraz.at> writes:

Toggle quote (56 lines)
> Am Mittwoch, den 30.06.2021, 08:49 +0300 schrieb Andrew Tropin:
>> * gnu/packages/games.scm (fheroes2): New variable.
>> ---
>> There are no tests in the project, so they are disabled.
> #:tests? #f should always be documented inside the code
>> gnu/packages/games.scm | 30 ++++++++++++++++++++++++++++++
>> 1 file changed, 30 insertions(+)
>>
>> diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
>> index 83cb738b9c..7a87123df3 100644
>> --- a/gnu/packages/games.scm
>> +++ b/gnu/packages/games.scm
>> @@ -12511,3 +12511,33 @@ wreckage. You're stranded on a desert
>> island and have to survive. In order to
>> do so you need to explore the island, find food, build a shelter and
>> try to
>> get attention, so you get found.")
>> (license license:cc-by4.0))))
>> +
>> +(define-public fheroes2
>> + (package
>> + (name "fheroes2")
>> + (version "0.9.4")
>> + (build-system cmake-build-system)
>> + (arguments
>> + `(#:tests? #f
> Add a comment here along the lines of "no tests" or "no check target".
>> + #:make-flags '("FHEROES2_STRICT_COMPILATION=1"
>> + "RELEASE=1")))
>> + (native-inputs
>> + `(("gettext" ,gettext-minimal)))
>> + (inputs
>> + `(("zlib" ,zlib)
>> + ("libpng" ,libpng)
>> + ("sdl" ,(sdl-union (list sdl2 sdl2-image sdl2-mixer sdl2-
>> ttf)))))
>> + (source (origin
>> + (method git-fetch)
>> + (uri (git-reference
>> + (url "https://github.com/ihhub/fheroes2")
>> + (commit version)))
>> + (file-name (git-file-name name version))
>> + (sha256
>> + (base32
>> + "0a3xi3k7ngp0byhmg7wq22l1hix3jwr68prk2y6frqhzbfskrvy
>> g"))))
>> + (home-page "https://ihhub.github.io/fheroes2/")
>> + (synopsis "Turn-based strategy game engine")
>> + (description "Free implementation of Heroes of Might and Magic
>> II (aka
>> +HOMM2) game engine.")
>> + (license license:gpl2)))
> The description is a bit lacking in information. Is this engine
> usable? If so, how? We ought not to steer users towards non-free
> software.

Yep, it's usable. It requires game resources (assets like music, maps,
sprites), the assets from original game is not distributed with it
because of legal reasons I suppose, but AFAIK nothing stops people from
creating their own set of assets to use with this game engine. Also,
taking only assets from original game and using them with this engine
will help people not to use unfree software.

Added comment, updated description.
-----BEGIN PGP SIGNATURE-----

iQJDBAEBCgAtFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmDcRXUPHGFuZHJld0B0
cm9wLmluAAoJECII0glYwd6wfKUP/AxWoHVDDmWcLA+5NUqKbNvmFuUQ8GAtrK0a
hMHgih+6kQCPtyc4b5h6xcS7YbvfiCXEMbGes9RIHwVwmmB/SbAdDUvrtSMy9T1I
9+ckareSWVMMY+3NnDrg71YNj8VLa/rAVBPIPpsGi7y/mob9f9OF0O6nJMh3AaPk
3+7Ei6aSo3D+HCBn9p9PCFJMT/WoD6Qz3TfbXSyOaI5nNEJTdSgPs715PzHVwLdo
bg3XhMPO6vryp9ZBJLcfK9Hg40hdx74+WLgy84vi2Oufid5euFQvj0r04nTslEA2
TIB5BI8ZOm4YVNjIIMZi3TGWalfiRfEvdum9a9viRMjOnLECl9GxyQy5OKe1wepr
K/xAQV2MmNTlEdCSfMj7mNwKX4nKqwgN/L+DrPeey2QU1l6CwmBs9QPe8318myHg
WVs6t/sZdwUft9UDaCVkE0k+bhjv8kaQcjjPSmsoPPj2ktfdHPS/w5JYgYytGwBa
AdJnMWhzSUSpPAOGAgB7uR6RORXkeaquB92TYRxNlKdBx6SrXmPg/0ChTNX1bFrV
oNa8BRZiIqlNenj1/d+mKiDJ3N0HwB8mmYF+E+JdI9rsxLA2WhdgOAT+WTBY91+r
3jBTEWlubPTVy/N7NKocDHF41hZO4W/CUqMPaLFEXs5gIlrltH44THg2koOm5cwU
Qh2hG57T
=k0tx
-----END PGP SIGNATURE-----

L
L
Leo Prikler wrote on 30 Jun 2021 12:48
cbbb0df6c5d8b3a40c97c65347eab7c26d09a796.camel@student.tugraz.at
Am Mittwoch, den 30.06.2021, 13:20 +0300 schrieb Andrew Tropin:
Toggle quote (72 lines)
> Leo Prikler <leo.prikler@student.tugraz.at> writes:
>
> > Am Mittwoch, den 30.06.2021, 08:49 +0300 schrieb Andrew Tropin:
> > > * gnu/packages/games.scm (fheroes2): New variable.
> > > ---
> > > There are no tests in the project, so they are disabled.
> > #:tests? #f should always be documented inside the code
> > > gnu/packages/games.scm | 30 ++++++++++++++++++++++++++++++
> > > 1 file changed, 30 insertions(+)
> > >
> > > diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
> > > index 83cb738b9c..7a87123df3 100644
> > > --- a/gnu/packages/games.scm
> > > +++ b/gnu/packages/games.scm
> > > @@ -12511,3 +12511,33 @@ wreckage. You're stranded on a desert
> > > island and have to survive. In order to
> > > do so you need to explore the island, find food, build a shelter
> > > and
> > > try to
> > > get attention, so you get found.")
> > > (license license:cc-by4.0))))
> > > +
> > > +(define-public fheroes2
> > > + (package
> > > + (name "fheroes2")
> > > + (version "0.9.4")
> > > + (build-system cmake-build-system)
> > > + (arguments
> > > + `(#:tests? #f
> > Add a comment here along the lines of "no tests" or "no check
> > target".
> > > + #:make-flags '("FHEROES2_STRICT_COMPILATION=1"
> > > + "RELEASE=1")))
> > > + (native-inputs
> > > + `(("gettext" ,gettext-minimal)))
> > > + (inputs
> > > + `(("zlib" ,zlib)
> > > + ("libpng" ,libpng)
> > > + ("sdl" ,(sdl-union (list sdl2 sdl2-image sdl2-mixer sdl2-
> > > ttf)))))
> > > + (source (origin
> > > + (method git-fetch)
> > > + (uri (git-reference
> > > + (url "https://github.com/ihhub/fheroes2")
> > > + (commit version)))
> > > + (file-name (git-file-name name version))
> > > + (sha256
> > > + (base32
> > > + "0a3xi3k7ngp0byhmg7wq22l1hix3jwr68prk2y6frqhzbfs
> > > krvy
> > > g"))))
> > > + (home-page "https://ihhub.github.io/fheroes2/")
> > > + (synopsis "Turn-based strategy game engine")
> > > + (description "Free implementation of Heroes of Might and
> > > Magic
> > > II (aka
> > > +HOMM2) game engine.")
> > > + (license license:gpl2)))
> > The description is a bit lacking in information. Is this engine
> > usable? If so, how? We ought not to steer users towards non-free
> > software.
>
> Yep, it's usable. It requires game resources (assets like music,
> maps,
> sprites), the assets from original game is not distributed with it
> because of legal reasons I suppose, but AFAIK nothing stops people
> from
> creating their own set of assets to use with this game engine. Also,
> taking only assets from original game and using them with this engine
> will help people not to use unfree software.
>
> Added comment, updated description.
Without a package providing those assets, this is still pretty much
"here, go seek out this nonfree software thingy for assets". This is
not to say, that we can never ever ship fheroes2, but I'd personally
hold back on it until we can package some fheroes2-data to make it
useful without requiring people seek out these assets.

This is just my own opinion however, and it's certainly not reflected
all over guix source. For instance, both oshu and stepmania require
beatmaps and stepfiles respectively to be useful and ship without them
while most of what you'll find online will be somewhat dubious in terms
of copyright. However, both also offer the tools to create those using
your own (hopefully GPL-compatible) album collection, so it's not a big
problem. I don't think fheroes2 has that low of an entry barrier to
full playability, does it?
A
A
Andrew Tropin wrote on 30 Jun 2021 13:22
87pmw31ts6.fsf@trop.in
Leo Prikler <leo.prikler@student.tugraz.at> writes:

Toggle quote (88 lines)
> Am Mittwoch, den 30.06.2021, 13:20 +0300 schrieb Andrew Tropin:
>> Leo Prikler <leo.prikler@student.tugraz.at> writes:
>>
>> > Am Mittwoch, den 30.06.2021, 08:49 +0300 schrieb Andrew Tropin:
>> > > * gnu/packages/games.scm (fheroes2): New variable.
>> > > ---
>> > > There are no tests in the project, so they are disabled.
>> > #:tests? #f should always be documented inside the code
>> > > gnu/packages/games.scm | 30 ++++++++++++++++++++++++++++++
>> > > 1 file changed, 30 insertions(+)
>> > >
>> > > diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
>> > > index 83cb738b9c..7a87123df3 100644
>> > > --- a/gnu/packages/games.scm
>> > > +++ b/gnu/packages/games.scm
>> > > @@ -12511,3 +12511,33 @@ wreckage. You're stranded on a desert
>> > > island and have to survive. In order to
>> > > do so you need to explore the island, find food, build a shelter
>> > > and
>> > > try to
>> > > get attention, so you get found.")
>> > > (license license:cc-by4.0))))
>> > > +
>> > > +(define-public fheroes2
>> > > + (package
>> > > + (name "fheroes2")
>> > > + (version "0.9.4")
>> > > + (build-system cmake-build-system)
>> > > + (arguments
>> > > + `(#:tests? #f
>> > Add a comment here along the lines of "no tests" or "no check
>> > target".
>> > > + #:make-flags '("FHEROES2_STRICT_COMPILATION=1"
>> > > + "RELEASE=1")))
>> > > + (native-inputs
>> > > + `(("gettext" ,gettext-minimal)))
>> > > + (inputs
>> > > + `(("zlib" ,zlib)
>> > > + ("libpng" ,libpng)
>> > > + ("sdl" ,(sdl-union (list sdl2 sdl2-image sdl2-mixer sdl2-
>> > > ttf)))))
>> > > + (source (origin
>> > > + (method git-fetch)
>> > > + (uri (git-reference
>> > > + (url "https://github.com/ihhub/fheroes2")
>> > > + (commit version)))
>> > > + (file-name (git-file-name name version))
>> > > + (sha256
>> > > + (base32
>> > > + "0a3xi3k7ngp0byhmg7wq22l1hix3jwr68prk2y6frqhzbfs
>> > > krvy
>> > > g"))))
>> > > + (home-page "https://ihhub.github.io/fheroes2/")
>> > > + (synopsis "Turn-based strategy game engine")
>> > > + (description "Free implementation of Heroes of Might and
>> > > Magic
>> > > II (aka
>> > > +HOMM2) game engine.")
>> > > + (license license:gpl2)))
>> > The description is a bit lacking in information. Is this engine
>> > usable? If so, how? We ought not to steer users towards non-free
>> > software.
>>
>> Yep, it's usable. It requires game resources (assets like music,
>> maps,
>> sprites), the assets from original game is not distributed with it
>> because of legal reasons I suppose, but AFAIK nothing stops people
>> from
>> creating their own set of assets to use with this game engine. Also,
>> taking only assets from original game and using them with this engine
>> will help people not to use unfree software.
>>
>> Added comment, updated description.
> Without a package providing those assets, this is still pretty much
> "here, go seek out this nonfree software thingy for assets". This is
> not to say, that we can never ever ship fheroes2, but I'd personally
> hold back on it until we can package some fheroes2-data to make it
> useful without requiring people seek out these assets.
>
> This is just my own opinion however, and it's certainly not reflected
> all over guix source. For instance, both oshu and stepmania require
> beatmaps and stepfiles respectively to be useful and ship without them
> while most of what you'll find online will be somewhat dubious in terms
> of copyright. However, both also offer the tools to create those using
> your own (hopefully GPL-compatible) album collection, so it's not a big
> problem. I don't think fheroes2 has that low of an entry barrier to
> full playability, does it?

Y, probably it's not easy to find free assets. Still can be useful for
people, who already have a CD with the original game, but do not want to
use unfree software or even for people, who would buy it to get resource
from it.

Feels kinda on the edge:
On the one hand it can nudge someone to buy or obtain a bundle with
unfree software inside to extract resources from it. On the other hand
it helps not to use unfree software.

I think it's more towards steering people from unfree to free software,
but I can be wrong.

Anyway, I trust your expertise on this topic and will accept your
descision to hold it back if you think it's necessary to have
fheroes2-data created/packaged first.
N
N
Nicolas Goaziou wrote on 2 Jul 2021 11:11
Re: [bug#49284] [PATCH] gnu: Add fheroes2
(name . Andrew Tropin)(address . andrew@trop.in)
87czs1ullg.fsf@nicolasgoaziou.fr
Hello,

Andrew Tropin <andrew@trop.in> writes:

Toggle quote (34 lines)
> Leo Prikler <leo.prikler@student.tugraz.at> writes:

>> Without a package providing those assets, this is still pretty much
>> "here, go seek out this nonfree software thingy for assets". This is
>> not to say, that we can never ever ship fheroes2, but I'd personally
>> hold back on it until we can package some fheroes2-data to make it
>> useful without requiring people seek out these assets.
>>
>> This is just my own opinion however, and it's certainly not reflected
>> all over guix source. For instance, both oshu and stepmania require
>> beatmaps and stepfiles respectively to be useful and ship without them
>> while most of what you'll find online will be somewhat dubious in terms
>> of copyright. However, both also offer the tools to create those using
>> your own (hopefully GPL-compatible) album collection, so it's not a big
>> problem. I don't think fheroes2 has that low of an entry barrier to
>> full playability, does it?
>
> Y, probably it's not easy to find free assets. Still can be useful for
> people, who already have a CD with the original game, but do not want to
> use unfree software or even for people, who would buy it to get resource
> from it.
>
> Feels kinda on the edge:
> On the one hand it can nudge someone to buy or obtain a bundle with
> unfree software inside to extract resources from it. On the other hand
> it helps not to use unfree software.
>
> I think it's more towards steering people from unfree to free software,
> but I can be wrong.
>
> Anyway, I trust your expertise on this topic and will accept your
> descision to hold it back if you think it's necessary to have
> fheroes2-data created/packaged first.

I agree that's it is already very easy to play this game without the
package: it has platinum support on Wine. Therefore, I don't think
adding it to Guix would force people to use non-free software.

I don't think developers of this engine created it just to play this
game, either. It is first and foremost an opportunity to learn, and to
share knowledge. As such, it belongs to Guix, IMO.

More pragmatically, it is free, and it requires little maintenance. I'm
in favor of including it.

Regards,
--
Nicolas Goaziou
A
A
Andrew Tropin wrote on 8 Sep 2021 11:34
[PATCH v3] gnu: Add fheroes2
(address . 49284@debbugs.gnu.org)
87lf474dia.fsf@trop.in
Updated to 0.9.7.
From eca57a5dfb8327df9cc6dacee5db5d2693b43fa2 Mon Sep 17 00:00:00 2001
From: Andrew Tropin <andrew@trop.in>
Date: Wed, 30 Jun 2021 13:17:21 +0300
Subject: [PATCH v3] gnu: Add fheroes2

* gnu/packages/games.scm (fheroes2): New variable.
---
gnu/packages/games.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 79754d3185..8ad02be794 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -12470,3 +12470,34 @@ wreckage. You're stranded on a desert island and have to survive. In order to
do so you need to explore the island, find food, build a shelter and try to
get attention, so you get found.")
(license license:cc-by4.0))))
+
+(define-public fheroes2
+ (package
+ (name "fheroes2")
+ (version "0.9.7")
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ #:make-flags '("FHEROES2_STRICT_COMPILATION=1"
+ "RELEASE=1")))
+ (native-inputs
+ `(("gettext" ,gettext-minimal)))
+ (inputs
+ `(("zlib" ,zlib)
+ ("libpng" ,libpng)
+ ("sdl" ,(sdl-union (list sdl2 sdl2-image sdl2-mixer sdl2-ttf)))))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ihhub/fheroes2")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0v3zh8a8yxfikcr5vkmy36c57l4nmwisz13mjavn5f7yrirf86fn"))))
+ (home-page "https://ihhub.github.io/fheroes2/")
+ (synopsis "Turn-based strategy game engine")
+ (description "Free implementation of Heroes of Might and Magic II (aka
+HOMM2) game engine. Requires assets/game resources to play, @file{fheroes2}
+is looking for them at @file{~/.local/share/fheroes2} folder.")
+ (license license:gpl2)))
--
2.33.0
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmE4g50ACgkQIgjSCVjB
3rCmJw/+PIr9eQQ+rXHBr0Gj02xvAVFpexB7FeklislEbig9sCJ16Yq6Qiw0ALVD
VBNRRROFnEPURi/nbQxu8axGG16fHDT5nD43mLZtgsNMeK+PILm7ZD8FzZWhCXcC
pccRlj7qMw6w98QGPXwzYOf6cDLu8Khr1PDMmmLwqWOGjvksQZX87bHcH3D/iKkD
/nIX2ItYVrtWAPrWNcNY6c3ktAKJMUpOAlqPQ7tf9T4/KFpye0ZbguCXR93tHFfm
WaEIRi++jAUoCMrqilO1s/Qyg43JzORKT2k68Uew7JN8kpK0u+apdOrA6niCAZg0
fdmm53NzU8jpEwycmegE8v1749bWmosnYrOfc0shtfn2Szw4jQUAKw4SJQMYNZvh
9BJenDWlpLY/m1LX7Ng5wMyHxm9vXGGCbV8aGPDpPCvXN60j8hvY0kuNkGRB5jOV
VCwXA6NU0v2RU8WVLDGw9oSwPgQW3ijwk+8NJc+Frvn4c977qz63b7LTT1hLxVDA
+pHv3TY/0s94UWV+aTRElOYoRPxBpfxPrlqHPF6qDgSVdlki9U2o3YyOD81pmGbJ
W6D0M4ODoJ0JTmw10iI3OWz73j39KKia+iLuXvn1bOLLIHU3/FzK5YIcEmDgVoLA
WLjCnCa+iKLGpQMWteU4CfJUJOc8+MtRCWco422CGekwNMidciY=
=4BnB
-----END PGP SIGNATURE-----

N
N
Nicolas Goaziou wrote on 13 Sep 2021 22:25
(name . Andrew Tropin)(address . andrew@trop.in)
874kao6x4q.fsf@nicolasgoaziou.fr
Hello,

Andrew Tropin <andrew@trop.in> writes:

Toggle quote (2 lines)
> * gnu/packages/games.scm (fheroes2): New variable.

Applied. Thank you.

I slightly reworded description field so it would contain full
sentences.

Regards,
--
Nicolas Goaziou
Closed
A
A
Andrew Tropin wrote on 14 Sep 2021 08:27
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)
87ilz3n02q.fsf@trop.in
On 2021-09-13 22:25, Nicolas Goaziou wrote:

Toggle quote (12 lines)
> Hello,
>
> Andrew Tropin <andrew@trop.in> writes:
>
>> * gnu/packages/games.scm (fheroes2): New variable.
>
> Applied. Thank you.
>
> I slightly reworded description field so it would contain full
> sentences.
>

Thank you!)

Toggle quote (2 lines)
>
> Regards,
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmFAQN0ACgkQIgjSCVjB
3rCi1xAAlhdwpjZR8i8/XXcE10IaJkxksMF9QZg9Y0doZM8SXWNgJV2Op2kZsE/s
LnkpiKISAVGA4Os9kw/uiRbB5cAs8rqJ+RDtF8E6Z5s8fRHGI97QeSSoKfJUXAnd
IvTWfIu5z8rz8ZvRTp22Rt47myMAOIz+TjmPwxfI4DHsmWyj1miuBPkFvJdvcLUh
J8EgWLaMedrd9/j2+hSoUNcNohMgZQFAfn4wp7J3wzi/PlmqTE9GkpWdZEGkXeLm
Df19YgHXktwQOua/4G6Cc0ULTco5H3E8kpw9YM/P1YaLuHaZZuHM6eCxY7wrLwCX
NAwJXhzK81XEWbwX2YYHFHbVTDbCP8UAccHyH2PF2GIhosTslvUNQKQZyQtiWyn+
4Lrg0V4+DN3IOi+ROv8ayK4aQB2ir6lP41PUDOObZp69yihh/YI/KFSXcu0IhH/c
A5v08UZWC9xGEv/L28K3owQmx3RUKhcTY+ePLCec892y0G6QVtXZ+t25QzA7WWKi
OXNO07+KIojM72hKHg75iGF+yhH3PXJcLjtt5U2186Vu3pvdTZcNlGsnS6W/bC7K
sZXC7rOcq3eBzxzWQkx5UN5nqGkpyz1UL+OmFvLLc1Gm9HDed34Fdj8eqcgkHuAd
dMyr6vPtzcXWXrS6x01FyFXCL/YZ0L6skeCHiwwCenY55dSm4L0=
=hRZ/
-----END PGP SIGNATURE-----

Closed
?