Christopher Baines wrote 4 years ago
(address . guix-patches@gnu.org)
Follow up to 018f95094153660e3041ec160718f0bda286a3dc, as gcc on aarch64-linux
doesn't seem to support -mstack-protector-guard=global.
* gnu/packages/bootloaders.scm (grub-efi)[arguments]: Only add
"--enable-stack-protector" to #:configure-flags when system is x86_64-linux.
---
gnu/packages/bootloaders.scm | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)
Toggle diff (18 lines)
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index e83f21ea63..1ff0348ac7 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -303,7 +303,10 @@ menu to select one of the installed operating systems.")
((#:tests? _ #f) #f)
((#:configure-flags flags ''())
`(cons* "--with-platform=efi"
- "--enable-stack-protector" ; EFI-only for now
+ ,@(if (string=? (%current-system)
+ "x86_64-linux")
+ '("--enable-stack-protector") ; EFI-only for now
+ '())
,flags))
((#:phases phases)
`(modify-phases ,phases
--
2.32.0