(address . guix-patches@gnu.org)(name . Thorsten Wilms)(address . t_w_@freenet.de)
* gnu/packages/audio.scm (distrho-ports-lv2): New variable.
---
gnu/packages/audio.scm | 43 +++++++++++++++++++++++++++++++++++++++++-
1 file changed, 42 insertions(+), 1 deletion(-)
Toggle diff (60 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 038452a582..bd5c3934a0 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -15,7 +15,7 @@
;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2018 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2018, 2019 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2018 Thorsten Wilms <t_w_@freenet.de>
+;;; Copyright © 2018, 2021 Thorsten Wilms <t_w_@freenet.de>
;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2018 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2019, 2021 Pierre Langlois <pierre.langlois@gmx.com>
@@ -5369,3 +5369,44 @@ Icecast server.")
generator, generating audio signals out of Linux's /dev/dsp audio
device. There is support for mono and/or stereo and 8 or 16 bit samples.")
(license license:gpl2)))
+
+(define-public distrho-ports-lv2
+ (package
+ (name "distrho-ports-lv2")
+ (version "2021-03-15")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://github.com/DISTRHO/DISTRHO-Ports/archive/refs/tags/"
+ version ".tar.gz"))
+ (sha256
+ (base32 "0cl10zvmg4zkiapza8aqj8p0brsfacvrxsr1fc7yy0b521q40xbj"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:configure-flags
+ (list
+ "-Dbuild-vst2=false"
+ "-Dbuild-vst3=false"
+ (string-append "--prefix=" (assoc-ref %outputs "out")))))
+ (inputs
+ `(("alsa" ,alsa-lib)
+ ("fftwf" ,fftwf)
+ ("freetype" ,freetype)
+ ("libx11" ,libx11)
+ ("libxcursor" ,libxcursor)
+ ("libxext" ,libxext)
+ ("lv2" ,lv2)
+ ("mesa" ,mesa)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (native-search-paths
+ (list (search-path-specification
+ (variable "LV2_PATH")
+ (files '("lib/lv2")))))
+ (home-page "https://distrho.sourceforge.io/ports.php")
+ (synopsis "Audio plug-in pack for LV2")
+ (description
+ "DISTHRO Ports is a collection of LV2-versions of audio plugins that have
+been made with the JUCE-framework.")
+ (license (list license:gpl2 license:gpl2+ license:gpl3+ license:agpl3 license:non-copyleft))))
--
2.32.0