[PATCH] gnu: Add distrho-ports-lv2.

  • Open
  • quality assurance status badge
Details
One participant
  • Thorsten Wilms
Owner
unassigned
Submitted by
Thorsten Wilms
Severity
normal
T
T
Thorsten Wilms wrote on 25 Jun 2021 15:11
(address . guix-patches@gnu.org)(name . Thorsten Wilms)(address . t_w_@freenet.de)
20210625131118.2657-1-t_w_@freenet.de
* gnu/packages/audio.scm (distrho-ports-lv2): New variable.
---
gnu/packages/audio.scm | 43 +++++++++++++++++++++++++++++++++++++++++-
1 file changed, 42 insertions(+), 1 deletion(-)

Toggle diff (60 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 038452a582..bd5c3934a0 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -15,7 +15,7 @@
;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2018 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2018, 2019 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2018 Thorsten Wilms <t_w_@freenet.de>
+;;; Copyright © 2018, 2021 Thorsten Wilms <t_w_@freenet.de>
;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2018 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2019, 2021 Pierre Langlois <pierre.langlois@gmx.com>
@@ -5369,3 +5369,44 @@ Icecast server.")
generator, generating audio signals out of Linux's /dev/dsp audio
device. There is support for mono and/or stereo and 8 or 16 bit samples.")
(license license:gpl2)))
+
+(define-public distrho-ports-lv2
+ (package
+ (name "distrho-ports-lv2")
+ (version "2021-03-15")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://github.com/DISTRHO/DISTRHO-Ports/archive/refs/tags/"
+ version ".tar.gz"))
+ (sha256
+ (base32 "0cl10zvmg4zkiapza8aqj8p0brsfacvrxsr1fc7yy0b521q40xbj"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:configure-flags
+ (list
+ "-Dbuild-vst2=false"
+ "-Dbuild-vst3=false"
+ (string-append "--prefix=" (assoc-ref %outputs "out")))))
+ (inputs
+ `(("alsa" ,alsa-lib)
+ ("fftwf" ,fftwf)
+ ("freetype" ,freetype)
+ ("libx11" ,libx11)
+ ("libxcursor" ,libxcursor)
+ ("libxext" ,libxext)
+ ("lv2" ,lv2)
+ ("mesa" ,mesa)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (native-search-paths
+ (list (search-path-specification
+ (variable "LV2_PATH")
+ (files '("lib/lv2")))))
+ (home-page "https://distrho.sourceforge.io/ports.php")
+ (synopsis "Audio plug-in pack for LV2")
+ (description
+ "DISTHRO Ports is a collection of LV2-versions of audio plugins that have
+been made with the JUCE-framework.")
+ (license (list license:gpl2 license:gpl2+ license:gpl3+ license:agpl3 license:non-copyleft))))
--
2.32.0
T
T
Thorsten Wilms wrote on 26 Oct 2021 10:18
[PATCH v2] gnu: Add distrho-ports-lv2.
(address . 49224@debbugs.gnu.org)(name . Thorsten Wilms)(address . t_w_@freenet.de)
20211026081831.7438-1-t_w_@freenet.de
* gnu/packages/audio.scm (distrho-ports-lv2): New variable.
---
This time without superfluous search-path-specification and with proper
indentation.

gnu/packages/audio.scm | 40 +++++++++++++++++++++++++++++++++++++++-
1 file changed, 39 insertions(+), 1 deletion(-)

Toggle diff (57 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index faf106fc68..d6ed470435 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -15,7 +15,7 @@
;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2018 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2018, 2019 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2018 Thorsten Wilms <t_w_@freenet.de>
+;;; Copyright © 2018, 2021 Thorsten Wilms <t_w_@freenet.de>
;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2018 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2019, 2021 Pierre Langlois <pierre.langlois@gmx.com>
@@ -5566,3 +5566,41 @@ (define-public mda-lv2
"MDA-LV2 is an LV2 port of the MDA plugins. It includes effects and a few
instrument plugins.")
(license license:gpl3+)))
+
+(define-public distrho-ports-lv2
+ (package
+ (name "distrho-ports-lv2")
+ (version "2021-03-15")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://github.com/DISTRHO/DISTRHO-Ports/archive/refs/tags/"
+ version ".tar.gz"))
+ (sha256
+ (base32 "0cl10zvmg4zkiapza8aqj8p0brsfacvrxsr1fc7yy0b521q40xbj"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:configure-flags
+ (list
+ "-Dbuild-vst2=false"
+ "-Dbuild-vst3=false"
+ (string-append "--prefix=" (assoc-ref %outputs "out")))))
+ (inputs
+ `(("alsa" ,alsa-lib)
+ ("fftwf" ,fftwf)
+ ("freetype" ,freetype)
+ ("libx11" ,libx11)
+ ("libxcursor" ,libxcursor)
+ ("libxext" ,libxext)
+ ("lv2" ,lv2)
+ ("mesa" ,mesa)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://distrho.sourceforge.io/ports.php")
+ (synopsis "Audio plug-in pack for LV2")
+ (description
+ "DISTHRO Ports is a collection of LV2-versions of audio plugins that have
+been made with the JUCE-framework.")
+ ;; non-copyleft for drow (MIT). agpl3 for HiReSam.
+ (license (list license:gpl2 license:gpl2+ license:gpl3+ license:agpl3 license:non-copyleft))))
--
2.33.1
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 49224@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 49224
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch