(name . bug-guix@gnu.org)(address . bug-guix@gnu.org)
Hi!
Today I tried to reconfigure my system, which involves building the nix
derivation, and i got the following error:
```
failed to download "/tmp/guix-file.uteXdE" from "https://nixos.org/releases/nix/nix-2.3.12/nix-2.3.12.tar.xz"
guix download: error: https://nixos.org/releases/nix/nix-2.3.12/nix-2.3.12.tar.xz:download failed
```
when trying to get the file using `guix download
in the same way:
```
Starting download of /tmp/guix-file.fhLzo0
Throw to key `gnutls-error' with args `(#<gnutls-error-enum Resource temporarily unavailable, try again.> handshake)'.
```
Using wget worked (also using GNUtls) but it gave me 3 times the
`Resource temporarily unavailable` error.
```
GnuTLS: Resource temporarily unavailable, try again.
GnuTLS: Resource temporarily unavailable, try again.
GnuTLS: Resource temporarily unavailable, try again.
HTTP request sent, awaiting response... 302 Found
Location: https://releases.nixos.org/nix/nix-2.3.12/nix-2.3.12.tar.xz[following]
[...]
Saving to: ‘nix-2.3.12.tar.xz.1’
```
Seems that the original URL does a redirection into
running guix download against the final url it works.
I guess that guix download is not dealing properly with the redirection
or with the GNUtls error GNUTLS_E_AGAIN which seems the be the one
causing that error message.
Greets, Aitor.