[PATCH core-updates] add package-db to runhaskell (haskell-build-system)

  • Done
  • quality assurance status badge
Details
3 participants
  • John Kehayias
  • Philip Munksgaard
  • Ricardo Wurmus
Owner
unassigned
Submitted by
John Kehayias
Severity
normal
J
J
John Kehayias wrote on 24 Jun 2021 00:09
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
GMVhpmT-cIIS8fxdoEunZXx-wTfXa1TvInI4206RxKZrrdyYkv4bhgg7qt502kNulYAbvZdRcnpA7ft-zq88cOzBga-leAkk_Bzc8msPZ54=@protonmail.com
Hello,

This is a patch to fix issue #48944 as well as more broadly an issue of Haskell packages that need modules at the configure step. Currently the package database is not passed to runhaskell directly, which means runhaskell Setup.hs configure does not have outside modules available. This blocks packages that need things like cabal-doctest or gtk2hs-buildtools like ghc-cairo (which has a custom build process in the package currently, for this reason). Comments in ghc-cairo and for other packages with this need, suggest the change made in this patch.

The simplest change I saw was to make the package database passed to runhaskell on any command; not sure if this would be better for just configure. It may be possible to do this just passing the actual needed packages with -package-id, as suggested in https://github.com/tweag/rules_haskell/issues/1314However, I have not tried that and seemed more complicated than needed. Also, I did not modify the message printed as it already has the package-db in params, but perhaps better to be clear the exact command being run?

I have built many Haskell packages with this change and it works well for me, fixing the reported issue and packages I'm building not yet in guix. Given this changes the build command for all Haskell packages, would be happy for other tests to be run.

John
Toggle diff (23 lines)
diff --git a/guix/build/haskell-build-system.scm b/guix/build/haskell-build-system.scm
index 28253ce2f0..be20f13e10 100644
--- a/guix/build/haskell-build-system.scm
+++ b/guix/build/haskell-build-system.scm
@@ -63,13 +63,14 @@
((file-exists? "Setup.lhs")
"Setup.lhs")
(else
- #f))))
+ #f)))
+ (pkgdb (string-append "-package-db=" %tmp-db-dir)))
(if setup-file
(begin
(format #t "running \"runhaskell Setup.hs\" with command ~s \
and parameters ~s~%"
command params)
- (apply invoke "runhaskell" setup-file command params))
+ (apply invoke "runhaskell" pkgdb setup-file command params))
(error "no Setup.hs nor Setup.lhs found"))))
(define* (configure #:key outputs inputs tests? (configure-flags '())
--
2.32.0
P
P
Philip Munksgaard wrote on 2 Jul 2021 09:38
(address . 49199@debbugs.gnu.org)
4f8c3366-edbf-4d3a-be89-4d012fca1f8d@www.fastmail.com
This works for me. How can we get it merged?
J
J
John Kehayias wrote on 4 Jul 2021 02:47
(name . 49199@debbugs.gnu.org)(address . 49199@debbugs.gnu.org)
mie5S2mDg8BAAfnbQmJu49AGbAw28_havEVb0jfEwxFGnTDOC6PY49gWk1T8QH52x4pm3R2yuyv86zUUyfYeJITaZQ7XglaSQBrtlvpXSG4=@protonmail.com
I don't know, I'm rather new here :-) We'll need one of the main devs I guess to do it? The patch I submitted was actually from the master branch, but haskell-build-system is identical in core-updates if I'm reading the git log correctly. But I'm happy to do more testing on the core-updates branch.
J
J
John Kehayias wrote on 5 Jul 2021 18:17
(name . 49199@debbugs.gnu.org)(address . 49199@debbugs.gnu.org)
1r1sgPl4271Vsgu7xP8l2K-OzcPNJSXodvApw6-GmJYfzwewT07S4q0U2qV5B47iLBySpTXCzI1qHvH4RS0kKzBHBJYOEkWCl9UJyVKLHNk=@protonmail.com
Looks like you (and me) have run into several of these problems that could be revised with some fixes to haskell-build-system and the hackage importer. On #guix it was discussed having a branch to try out these changes and leverage the CI to see what breaks on making changes to the build system, ghc version, etc.

We'll need someone to create and let us push there, not sure who to ask or how to get started on that...
R
R
Ricardo Wurmus wrote on 21 Jul 2021 00:22
(address . 49199-done@debbugs.gnu.org)(name . John Kehayias)(address . john.kehayias@protonmail.com)
87y2a04ocq.fsf@elephly.net
Hi,

I made a commit out of the diff and pushed it to wip-haskell,
which is based on core-updates.

--
Ricardo
Closed
?