[PATCH 0/1] Fixing passmenu (password-store) command substitutions

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • David Dashyan
Owner
unassigned
Submitted by
David Dashyan
Severity
normal

Debbugs page

David Dashyan wrote 4 years ago
(address . guix-patches@gnu.org)(name . David Dashyan)(address . mail@davie.li)
20210623152644.30909-1-mail@davie.li
Hello! There was an update to password-stre contrib scripts adding Wayland
support. This left some of substite* invocations producing incorrect scripts.

Breackage introduced in upstream commit
3d36829ce7a203f97e84723e1dc02fef1e0d06cc

But! I ignored the wailand support -- it requires dmenu-wl and ydotool
packages, I only made the passmenu command work with xorg again.

What do guix do in such case make new output for wayland?

Peace and love

David Dashyan (1):
gnu: password-store: Fix passmenu paths substitution

gnu/packages/password-utils.scm | 15 +++++++++++----
1 file changed, 11 insertions(+), 4 deletions(-)


base-commit: d027858e70c4a37aca90b1d4ecb2f0421a95d987
--
2.32.0
David Dashyan wrote 4 years ago
[PATCH 1/1] gnu: password-store: Fix passmenu paths substitution
(address . 49188@debbugs.gnu.org)(name . David Dashyan)(address . mail@davie.li)
20210623152959.31046-1-mail@davie.li
* gnu/packages/password-utils.scm (password-store)
[arguments]: Fix dmenu and xdotool path substitution in patch-passmenu-path
phase.
---
gnu/packages/password-utils.scm | 15 +++++++++++----
1 file changed, 11 insertions(+), 4 deletions(-)

Toggle diff (37 lines)
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 9c8912c5e8..460193c72d 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -31,6 +31,7 @@
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
+;;; Copyright © 2021 David Dashyan <mail@davie.li>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -517,12 +518,18 @@ any X11 window.")
"}\"\n"))))
#t))
(add-before 'install 'patch-passmenu-path
+ ;; FIXME Wayland support requires ydotool and dmenu-wl packages
+ ;; We are ignoring part of the script that gets executed if
+ ;; WAYLAND_DISPLAY env variable is set, leaving dmenu-wl and ydotool
+ ;; commands as is.
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "contrib/dmenu/passmenu"
- (("dmenu") (string-append (assoc-ref inputs "dmenu")
- "/bin/dmenu"))
- (("xdotool") (string-append (assoc-ref inputs "xdotool")
- "/bin/xdotool")))
+ (("dmenu=dmenu\n") (string-append "dmenu="
+ (assoc-ref inputs "dmenu")
+ "/bin/dmenu\n"))
+ (("xdotool=\"xdotool") (string-append "xdotool=\""
+ (assoc-ref inputs "xdotool")
+ "/bin/xdotool")))
#t))
(add-after 'install 'install-passmenu
(lambda* (#:key outputs #:allow-other-keys)
--
2.32.0
Efraim Flashner wrote 4 years ago
(name . David Dashyan)(address . mail@davie.li)(address . 49188-done@debbugs.gnu.org)
YO2QNdgPJFTPj5a9@3900XT
Thanks. Patch pushed.

--
Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmDtkDUACgkQQarn3Mo9
g1EdgxAAvX1IPwHPyKfx0yJD2mdrITO7ax24dD7I3w/wa+dVHAi91c0siBmcIaAh
Yj7ncy6SMlfXCvuwuX7v5hnopgJPejKN1hAabhyXUUi5eRxPpqu7eKWGK/FvHOja
e6IL9gq3iltWaaqGUzQku+bj9/X0DN8AYjlYw0odk5eh2NVAbNER0V4VXJ4MdUYj
fL5rh2nKvT8g/882J2DnMe9iXz9sjIZGS6QmeXfi7mKGOERi4rYix/a55LUC4u/X
CHR2Y53RX9W5gfeDZJsbdsrGmFaUoA5wHOHfIgwBMevhYWpfbhQh7XndPvPWuabk
9aTaixj3qv7/IxnIzkXc0ioMHzLMPZQcAW6ca+FhD/UEKOnr1eoTQG/ySeLXu+vf
5LKRojluGmNzdiCtp0sGAnMkQf7UPnC6pKi0FplKyCvojhDxnOM48VU/25LpbALP
epOeNQLgysNtuL7p2Ui/W9kMOrvePjohX4AmmyayunZ/4JuNFB9rE0La1E2yU2Mp
8CTiXgc5qXHEnfHQcUKLobvtS5MJX4EGkV1axeu2jxj6+roQbT3Mlo3RzbphIDEp
09XEQtXJfvtI1rST4M6Qu6kSI4j8rlgtaYviq8yqxoL0kAdI6/DwKB4LBkWfRcpB
/sDArAi8aYm9yOHjfy1alK/s8dnaFWcxb/gdu2jdjpMQGJLB+SQ=
=GvxT
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 49188@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 49188
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help