[PATCH] gnu: tmux-themepack: Update to 1.1.0.

  • Done
  • quality assurance status badge
Details
3 participants
  • Brice Waegeneire
  • Matthew James Kraai
  • Ludovic Courtès
Owner
unassigned
Submitted by
Matthew James Kraai
Severity
normal
M
M
Matthew James Kraai wrote on 21 Jun 2021 01:15
(address . guix-patches@gnu.org)(name . Matthew James Kraai)(address . kraai@ftbfs.org)
20210620231509.5882-1-kraai@ftbfs.org
* gnu/packages/tmux.scm (tmux-themepack): Update to 1.1.0.
---
gnu/packages/tmux.scm | 58 +++++++++++++++++++++----------------------
1 file changed, 28 insertions(+), 30 deletions(-)

Toggle diff (71 lines)
diff --git a/gnu/packages/tmux.scm b/gnu/packages/tmux.scm
index f208fbfd93..aa409d316c 100644
--- a/gnu/packages/tmux.scm
+++ b/gnu/packages/tmux.scm
@@ -66,36 +66,34 @@ continue running in the background, then later reattached.")
(license license:isc)))
(define-public tmux-themepack
- (let ((commit "03a372866f7677f7fe63bcee140b48b9fd372c48")
- (revision "1"))
- (package
- (name "tmux-themepack")
- (version (git-version "0.0.0" revision commit)) ; no version tags
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/jimeh/tmux-themepack")
- (commit commit)))
- (sha256
- (base32
- "1d3k87mq5lca042jbap5kxskjy3kg79wjhhpnm6jacbn3anc67zl"))
- (file-name (git-file-name name version))))
- (build-system gnu-build-system)
- (arguments
- `(#:tests? #f ; no test suite
- #:phases (modify-phases %standard-phases
- (delete 'configure)
- (delete 'build)
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (string-append
- (assoc-ref outputs "out")
- "/share/" ,name "-" ,version)))
- (copy-recursively "." out)))))))
- (home-page "https://github.com/jimeh/tmux-themepack")
- (synopsis "Collection of themes for Tmux")
- (description "A collection of various themes for Tmux.")
- (license license:wtfpl2))))
+ (package
+ (name "tmux-themepack")
+ (version "1.1.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jimeh/tmux-themepack")
+ (commit version)))
+ (sha256
+ (base32
+ "00dmd16ngyag3n46rbnl9vy82ih6g0y02yfwkid32a1c8vdbvb3z"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no test suite
+ #:phases (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'build)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (string-append
+ (assoc-ref outputs "out")
+ "/share/" ,name "-" ,version)))
+ (copy-recursively "." out)))))))
+ (home-page "https://github.com/jimeh/tmux-themepack")
+ (synopsis "Collection of themes for Tmux")
+ (description "A collection of various themes for Tmux.")
+ (license license:wtfpl2)))
(define-public tmuxifier
(package
--
2.32.0
M
M
Matthew James Kraai wrote on 21 Jun 2021 02:12
(address . 49147@debbugs.gnu.org)(name . Matthew James Kraai)(address . kraai@ftbfs.org)
20210621001241.8732-1-kraai@ftbfs.org
* gnu/packages/tmux.scm (tmux-themepack): Update to 1.1.0.
---
gnu/packages/tmux.scm | 59 +++++++++++++++++++++----------------------
1 file changed, 29 insertions(+), 30 deletions(-)

Toggle diff (79 lines)
diff --git a/gnu/packages/tmux.scm b/gnu/packages/tmux.scm
index f208fbfd93..41f8b948ca 100644
--- a/gnu/packages/tmux.scm
+++ b/gnu/packages/tmux.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2019 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2020 Edouard Klein <edk@beaver-labs.com>
+;;; Copyright © 2021 Matthew James Kraai <kraai@ftbfs.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -66,36 +67,34 @@ continue running in the background, then later reattached.")
(license license:isc)))
(define-public tmux-themepack
- (let ((commit "03a372866f7677f7fe63bcee140b48b9fd372c48")
- (revision "1"))
- (package
- (name "tmux-themepack")
- (version (git-version "0.0.0" revision commit)) ; no version tags
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/jimeh/tmux-themepack")
- (commit commit)))
- (sha256
- (base32
- "1d3k87mq5lca042jbap5kxskjy3kg79wjhhpnm6jacbn3anc67zl"))
- (file-name (git-file-name name version))))
- (build-system gnu-build-system)
- (arguments
- `(#:tests? #f ; no test suite
- #:phases (modify-phases %standard-phases
- (delete 'configure)
- (delete 'build)
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (string-append
- (assoc-ref outputs "out")
- "/share/" ,name "-" ,version)))
- (copy-recursively "." out)))))))
- (home-page "https://github.com/jimeh/tmux-themepack")
- (synopsis "Collection of themes for Tmux")
- (description "A collection of various themes for Tmux.")
- (license license:wtfpl2))))
+ (package
+ (name "tmux-themepack")
+ (version "1.1.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jimeh/tmux-themepack")
+ (commit version)))
+ (sha256
+ (base32
+ "00dmd16ngyag3n46rbnl9vy82ih6g0y02yfwkid32a1c8vdbvb3z"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no test suite
+ #:phases (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'build)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (string-append
+ (assoc-ref outputs "out")
+ "/share/" ,name "-" ,version)))
+ (copy-recursively "." out)))))))
+ (home-page "https://github.com/jimeh/tmux-themepack")
+ (synopsis "Collection of themes for Tmux")
+ (description "A collection of various themes for Tmux.")
+ (license license:wtfpl2)))
(define-public tmuxifier
(package
--
2.32.0
B
B
Brice Waegeneire wrote on 22 Jun 2021 09:02
(name . Matthew James Kraai)(address . kraai@ftbfs.org)(address . 49147@debbugs.gnu.org)
878s32wff0.fsf_-_@waegenei.re
Hello Matthew,

Matthew James Kraai <kraai@ftbfs.org> writes:

Toggle quote (2 lines)
> * gnu/packages/tmux.scm (tmux-themepack): Update to 1.1.0.

Thank you for your patch. Comparing the output with the previous
version shows additional files which shouldn't be in a package such as
"share/tmux-themepack-1.1.0/Makefile" or
"share/tmux-themepack-1.1.0/.github/workflows/ci.yml". Can you remove
such files from the output?

Cheers,
- Brice
M
M
Matthew James Kraai wrote on 5 Jul 2021 12:22
[PATCH] gnu: tmux-themepack: Update to 1.1.0.
(address . 49147@debbugs.gnu.org)(name . Matthew James Kraai)(address . kraai@ftbfs.org)
20210705102232.21532-1-kraai@ftbfs.org
* gnu/packages/tmux.scm (tmux-themepack): Update to 1.1.0.
[arguments]: Install only selected files.
---
gnu/packages/tmux.scm | 62 ++++++++++++++++++++++---------------------
1 file changed, 32 insertions(+), 30 deletions(-)

Toggle diff (75 lines)
diff --git a/gnu/packages/tmux.scm b/gnu/packages/tmux.scm
index 09040e106d..7dc977d820 100644
--- a/gnu/packages/tmux.scm
+++ b/gnu/packages/tmux.scm
@@ -67,36 +67,38 @@ continue running in the background, then later reattached.")
(license license:isc)))
(define-public tmux-themepack
- (let ((commit "03a372866f7677f7fe63bcee140b48b9fd372c48")
- (revision "1"))
- (package
- (name "tmux-themepack")
- (version (git-version "0.0.0" revision commit)) ; no version tags
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/jimeh/tmux-themepack")
- (commit commit)))
- (sha256
- (base32
- "1d3k87mq5lca042jbap5kxskjy3kg79wjhhpnm6jacbn3anc67zl"))
- (file-name (git-file-name name version))))
- (build-system gnu-build-system)
- (arguments
- `(#:tests? #f ; no test suite
- #:phases (modify-phases %standard-phases
- (delete 'configure)
- (delete 'build)
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (string-append
- (assoc-ref outputs "out")
- "/share/" ,name "-" ,version)))
- (copy-recursively "." out)))))))
- (home-page "https://github.com/jimeh/tmux-themepack")
- (synopsis "Collection of themes for Tmux")
- (description "A collection of various themes for Tmux.")
- (license license:wtfpl2))))
+ (package
+ (name "tmux-themepack")
+ (version "1.1.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jimeh/tmux-themepack")
+ (commit version)))
+ (sha256
+ (base32
+ "00dmd16ngyag3n46rbnl9vy82ih6g0y02yfwkid32a1c8vdbvb3z"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no test suite
+ #:phases (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'build)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (string-append
+ (assoc-ref outputs "out")
+ "/share/" ,name)))
+ (copy-recursively "powerline" (string-append out "/powerline"))
+ (for-each (lambda (file) (copy-file file (string-append out "/" file)))
+ '("basic.tmuxtheme"
+ "default.tmuxtheme"
+ "themepack.tmux"))))))))
+ (home-page "https://github.com/jimeh/tmux-themepack")
+ (synopsis "Collection of themes for Tmux")
+ (description "A collection of various themes for Tmux.")
+ (license license:wtfpl2)))
(define-public tmuxifier
(package
--
2.32.0
L
L
Ludovic Courtès wrote on 23 Jul 2021 16:40
(name . Matthew James Kraai)(address . kraai@ftbfs.org)(address . 49147-done@debbugs.gnu.org)
87pmv9aybg.fsf_-_@gnu.org
Hi,

Matthew James Kraai <kraai@ftbfs.org> skribis:

Toggle quote (3 lines)
> * gnu/packages/tmux.scm (tmux-themepack): Update to 1.1.0.
> [arguments]: Install only selected files.

Looks like it fell through the cracks. Now applied, thanks!

Ludo’.
Closed
?