[PATCH 0/1] Add pcl (Guix packaging meetup)

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • David Dashyan
Owner
unassigned
Submitted by
David Dashyan
Severity
normal

Debbugs page

David Dashyan wrote 4 years ago
(address . guix-patches@gnu.org)
20210620174417.11513-1-mail@davie.li
As part of crystal lang bootstrapping effort I packaged one of dependencies:
Portable Coroutine Library (PCL) during last LibreMiami guix packaging meetup.

This was literally the easiet package of this kind I ever did :)

My little patch below. Not sure wheter I chose a good place for the package.

David Dashyan (1):
gnu: Add pcl.

gnu/packages/c.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)


base-commit: 6086e6ed1a038793e358becddded50d97593f691
--
2.31.1
David Dashyan wrote 4 years ago
[PATCH 1/1] gnu: Add pcl.
(address . 49142@debbugs.gnu.org)
20210620175022.11763-1-mail@davie.li
* gnu/packages/c.scm (pcl): New variable.
---
gnu/packages/c.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index 931eb2bf3f..a17bf22f04 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2020 Katherine Cox-Buday <cox.katherine.e@gmail.com>
;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2020, 2021 Greg Hogan <code@greghogan.com>
+;;; Copyright © 2021 David Dashyan <mail@davie.li>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -693,3 +694,22 @@ event-driven, asynchronous network application protocols.")
cryptographic primitives for the @acronym{AWS,Amazon Web Services} SDK.")
(home-page "https://github.com/awslabs/aws-c-cal")
(license license:asl2.0)))
+
+(define-public pcl
+ (package
+ (name "pcl")
+ (version "1.12")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://www.xmailserver.org/pcl-" version ".tar.gz"))
+ (sha256
+ (base32
+ "06ly65rq4iyj2p4704i215c8y4rgspwl8sxfaifmf4ahfr30bcz7"))))
+ (build-system gnu-build-system)
+ (home-page "http://www.xmailserver.org/libpcl.html")
+ (synopsis "Portable Coroutine Library")
+ (description "The Portable Coroutine Library (PCL) implements the
+low level functionality for coroutines.")
+ (license license:gpl2+)))
--
2.31.1
Efraim Flashner wrote 4 years ago
(name . David Dashyan)(address . mail@davie.li)
YNrIv1I+xp9SlHbP@3900XT
Looks good. I made one change before pushing it.

On Sun, Jun 20, 2021 at 08:50:22PM +0300, David Dashyan wrote:
Toggle quote (39 lines)
> * gnu/packages/c.scm (pcl): New variable.
> ---
> gnu/packages/c.scm | 20 ++++++++++++++++++++
> 1 file changed, 20 insertions(+)
>
> diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
> index 931eb2bf3f..a17bf22f04 100644
> --- a/gnu/packages/c.scm
> +++ b/gnu/packages/c.scm
> @@ -11,6 +11,7 @@
> ;;; Copyright © 2020 Katherine Cox-Buday <cox.katherine.e@gmail.com>
> ;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
> ;;; Copyright © 2020, 2021 Greg Hogan <code@greghogan.com>
> +;;; Copyright © 2021 David Dashyan <mail@davie.li>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -693,3 +694,22 @@ event-driven, asynchronous network application protocols.")
> cryptographic primitives for the @acronym{AWS,Amazon Web Services} SDK.")
> (home-page "https://github.com/awslabs/aws-c-cal")
> (license license:asl2.0)))
> +
> +(define-public pcl
> + (package
> + (name "pcl")
> + (version "1.12")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append
> + "http://www.xmailserver.org/pcl-" version ".tar.gz"))
> + (sha256
> + (base32
> + "06ly65rq4iyj2p4704i215c8y4rgspwl8sxfaifmf4ahfr30bcz7"))))
> + (build-system gnu-build-system)
> + (home-page "http://www.xmailserver.org/libpcl.html")
> + (synopsis "Portable Coroutine Library")
> + (description "The Portable Coroutine Library (PCL) implements the

@acronym{PCL, Portable Coroutine Library}

Toggle quote (9 lines)
> +low level functionality for coroutines.")
> + (license license:gpl2+)))
> --
> 2.31.1
>
>
>
>

--
Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmDayL4ACgkQQarn3Mo9
g1GlPw//ftGiLkxSCtO9AXxv6FOGdW9nC6PFC5fR+ht9WeAeGI+o0wHG+ZtOg2iY
ypCAgW8msfORietuj4gbs6W47HIjJh8cIQhiIqyIbDnfe5yn0w7BE7Z5u2f4lPrQ
O8RWYWxBpSajoKhAFcO3v7WyLu7jq3sZ1bMBwr5ZBoDDrz1gZp1RSTrpSuceNeei
rGhGTFy7nFjb61g4+zIuoFbbMkefBMZtnIxl2WPp/EV8sWQfjSuUXGLHkFyjeMX+
SjST8/zVS1UC5yLVBKHLNKiEOV3aWVQdHL7XXag7jdhfPT1EeZn3RJ9AOSD8Qtdz
gHYBLrxow22qpJCepL9XOfkkQZMpYpqiRCno9jHCUwe9ETASxhif9Cgt0LFCMChJ
UGzK+kLFNE/xj6KOjg36sLhW6EUENBem9nGWIDRrnJR2vM5bLA/UBjZKYyrmQewa
9PLbNwtFSI3idsrvYaG/MasZVhZjhvi1NvS/UuF5E+wT8uqVYhC8fDNsgNunO9xr
QvMObmnviqQKiECE74qXtbcfw1wzsEgsiH01OlgoI1Ee+Hlb8FUPsf3dbRICcmVo
tNiFbG5fmwQMnILBIzwBWbH5HpdVFrLefBR1duJMGZguquQvzwfd8GAEXCm4s0/3
CSBxstYKAls3TPFoxouZbzxDbXUKTk/0EyHY9tPMvz7cJEMhoeI=
=eAUf
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 49142@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 49142
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help