[PATCH] import: launchpad: Use repository to retrieve releases.

  • Done
  • quality assurance status badge
Details
2 participants
  • Brice Waegeneire
  • Matthew James Kraai
Owner
unassigned
Submitted by
Matthew James Kraai
Severity
normal
M
M
Matthew James Kraai wrote on 19 Jun 2021 12:07
(address . guix-patches@gnu.org)(name . Matthew James Kraai)(address . kraai@ftbfs.org)
20210619100739.11713-1-kraai@ftbfs.org
* guix/import/launchpad.scm (latest-released-version): Use repository instead
of package name.
(latest-release): Pass repository to latest-released-version.
---
guix/import/launchpad.scm | 9 +++++----
1 file changed, 5 insertions(+), 4 deletions(-)

Toggle diff (36 lines)
diff --git a/guix/import/launchpad.scm b/guix/import/launchpad.scm
index a52b39a085..23ac6a3c7b 100644
--- a/guix/import/launchpad.scm
+++ b/guix/import/launchpad.scm
@@ -100,8 +100,8 @@ URL of the form
(match (string-split (uri-path (string->uri url)) #\/)
((_ repo . rest) repo)))
-(define (latest-released-version package-name)
- "Return a string of the newest released version name given the PACKAGE-NAME,
+(define (latest-released-version repository)
+ "Return a string of the newest released version name given the REPOSITORY,
for example, 'linuxdcpp'. Return #f if there is no releases."
(define (pre-release? x)
;; Versions containing anything other than digit characters and "." (for
@@ -112,7 +112,7 @@ for example, 'linuxdcpp'. Return #f if there is no releases."
(match (json-fetch
(string-append "https://api.launchpad.net/1.0/"
- package-name "/releases"))
+ repository "/releases"))
(#f #f) ;404 or similar
(json
(assoc-ref
@@ -129,7 +129,8 @@ for example, 'linuxdcpp'. Return #f if there is no releases."
(let* ((source-uri (origin-github-uri (package-source pkg)))
(name (package-name pkg))
- (newest-version (latest-released-version name)))
+ (repository (launchpad-repository source-uri))
+ (newest-version (latest-released-version repository)))
(if newest-version
(upstream-source
(package name)
--
2.32.0
B
B
Brice Waegeneire wrote on 19 Jun 2021 22:38
(name . Matthew James Kraai)(address . kraai@ftbfs.org)(address . 49112@debbugs.gnu.org)
87k0mpy4gy.fsf@waegenei.re
Hello Matthew,

Thank you for the patch!

Matthew James Kraai <kraai@ftbfs.org> writes:

Toggle quote (4 lines)
> * guix/import/launchpad.scm (latest-released-version): Use repository instead
> of package name.
> (latest-release): Pass repository to latest-released-version.

I had a patch for this, but yours is cleaner, using
'launchpad-directory'. I have added a copyright line and pushed as 9171079e515289120405c70c143445df2a35db1c.

Cheers,
- Brice
B
B
Brice Waegeneire wrote on 19 Jun 2021 22:39
control message for bug #49112
(address . control@debbugs.gnu.org)
E1luhkS-0001Sx-0D@debbugs.gnu.org
close 49112
quit
?