Hello Guix,
I am able to reproduce this with guix c3c003b and GNOME Music 3.34.5. I also
get some GDBus errors, but perhaps that's because my desktop is XFCE?
Toggle snippet (28 lines)
$ gnome-music
removed, grl-bookmarks
invoking IsSupported() failed for remote volume monitor with dbus name org.gtk.vfs.UDisks2VolumeMonitor:: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gtk.vfs.UDisks2VolumeMonitor was not provided by any .service files (g-dbus-error-quark, 2)
invoking IsSupported() failed for remote volume monitor with dbus name org.gtk.vfs.AfcVolumeMonitor:: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gtk.vfs.AfcVolumeMonitor was not provided by any .service files (g-dbus-error-quark, 2)
invoking IsSupported() failed for remote volume monitor with dbus name org.gtk.vfs.GPhoto2VolumeMonitor:: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gtk.vfs.GPhoto2VolumeMonitor was not provided by any .service files (g-dbus-error-quark, 2)
invoking IsSupported() failed for remote volume monitor with dbus name org.gtk.vfs.MTPVolumeMonitor:: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gtk.vfs.MTPVolumeMonitor was not provided by any .service files (g-dbus-error-quark, 2)
invoking IsSupported() failed for remote volume monitor with dbus name org.gtk.vfs.GoaVolumeMonitor:: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gtk.vfs.GoaVolumeMonitor was not provided by any .service files (g-dbus-error-quark, 2)
removed, grl-metadata-store
removed, grl-filesystem
removed, grl-podcasts
Traceback (most recent call last):
File "/gnu/store/rkhkqv9lvww40nqs25i8fmwf4870xsvw-gnome-music-3.34.5/bin/..gnome-music-real-real", line 153, in <module>
sys.exit(main())
File "/gnu/store/rkhkqv9lvww40nqs25i8fmwf4870xsvw-gnome-music-3.34.5/bin/..gnome-music-real-real", line 148, in main
return run_application()
File "/gnu/store/rkhkqv9lvww40nqs25i8fmwf4870xsvw-gnome-music-3.34.5/bin/..gnome-music-real-real", line 135, in run_application
app = Application('org.gnome.Music')
File "/gnu/store/rkhkqv9lvww40nqs25i8fmwf4870xsvw-gnome-music-3.34.5/lib/python3.8/site-packages/gnomemusic/application.py", line 70, in __init__
self._player = Player(self)
File "/gnu/store/rkhkqv9lvww40nqs25i8fmwf4870xsvw-gnome-music-3.34.5/lib/python3.8/site-packages/gnomemusic/player.py", line 397, in __init__
self._gst_player = GstPlayer(application)
File "/gnu/store/rkhkqv9lvww40nqs25i8fmwf4870xsvw-gnome-music-3.34.5/lib/python3.8/site-packages/gnomemusic/gstplayer.py", line 86, in __init__
self._setup_replaygain()
File "/gnu/store/rkhkqv9lvww40nqs25i8fmwf4870xsvw-gnome-music-3.34.5/lib/python3.8/site-packages/gnomemusic/gstplayer.py", line 111, in _setup_replaygain
self._filter_bin.add(self._rg_volume)
TypeError: Argument 1 does not allow None as a value
Luis Felipe <luis.felipe.la@protonmail.com> writes:
Toggle quote (48 lines)
> Hi, this happens on Guix System, using Guix 154a4e0 and GNOME Music 3.34.5.
>
> STEPS TO REPRODUCE
>
> 1. Click on Activities
> 2. Click on Show Apps button (nine dots button)
> 3. Click on the Music app
>
> EXPECTED RESULT
>
> The application starts.
>
> UNEXPECTED RESULT
>
> You can see the application icon displayed next to the GNOME Activities button with a loading indicator. But, after some seconds, it disappears and the application never starts.
>
> ADDITIONAL INFO
>
> Running the application from a terminal results in the following error:
>
> ????????????????????
> $ gnome-music
> removed, grl-bookmarks
> removed, grl-metadata-store
> removed, grl-filesystem
> Traceback (most recent call last):
> File "/gnu/store/v9vs6yai5dlyf5avly5ni3xxpk7xhfv0-gnome-music-3.34.5/bin/..gnome-music-real-real", line 153, in <module>
> sys.exit(main())
> File "/gnu/store/v9vs6yai5dlyf5avly5ni3xxpk7xhfv0-gnome-music-3.34.5/bin/..gnome-music-real-real", line 148, in main
> return run_application()
> File "/gnu/store/v9vs6yai5dlyf5avly5ni3xxpk7xhfv0-gnome-music-3.34.5/bin/..gnome-music-real-real", line 135, in run_application
> app = Application('org.gnome.Music')
> File "/gnu/store/v9vs6yai5dlyf5avly5ni3xxpk7xhfv0-gnome-music-3.34.5/lib/python3.8/site-packages/gnomemusic/application.py", line 70, in __init__
> self._player = Player(self)
> File "/gnu/store/v9vs6yai5dlyf5avly5ni3xxpk7xhfv0-gnome-music-3.34.5/lib/python3.8/site-packages/gnomemusic/player.py", line 397, in __init__
> self._gst_player = GstPlayer(application)
> File "/gnu/store/v9vs6yai5dlyf5avly5ni3xxpk7xhfv0-gnome-music-3.34.5/lib/python3.8/site-packages/gnomemusic/gstplayer.py", line 86, in __init__
> self._setup_replaygain()
> File "/gnu/store/v9vs6yai5dlyf5avly5ni3xxpk7xhfv0-gnome-music-3.34.5/lib/python3.8/site-packages/gnomemusic/gstplayer.py", line 111, in _setup_replaygain
> self._filter_bin.add(self._rg_volume)
> TypeError: Argument 1 does not allow None as a value
> ????????????????????
>
>
> ---
> Luis Felipe López Acevedo
> https://luis-felipe.gitlab.io/