[PATCH] gnu: Add mda-lv2

  • Done
  • quality assurance status badge
Details
3 participants
  • Efraim Flashner
  • Xinglu Chen
  • Thorsten Wilms
Owner
unassigned
Submitted by
Thorsten Wilms
Severity
normal

Debbugs page

Thorsten Wilms wrote 4 years ago
(address . guix-patches@gnu.org)(name . Thorsten Wilms)(address . t_w_@freenet.de)
20210614193224.9902-1-t_w_@freenet.de
* gnu/packages/audio.scm (mda-lv2): New variable.
---
gnu/packages/audio.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 3885a22e10..e352f797da 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -5275,3 +5275,38 @@ Icecast server.")
generator, generating audio signals out of Linux's /dev/dsp audio
device. There is support for mono and/or stereo and 8 or 16 bit samples.")
(license license:gpl2)))
+
+(define-public mda-lv2
+ (package
+ (name "mda-lv2")
+ (version "1.2.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ ;; Tarball from gitlab lacks waflib directory content, so take it from
+ ;; drobilla.net.
+ (string-append "http://download.drobilla.net/mda-lv2-"
+ version ".tar.bz2"))
+ (sha256
+ (base32 "1nspk2j11l65m5r9z5isw8j749vh9a89wgx8mkrrq15f4iq12rnd"))))
+ (build-system waf-build-system)
+ (arguments
+ `(#:tests? #f ; There are no tests.
+ #:configure-flags
+ (list (string-append "--prefix="
+ (assoc-ref %outputs "out")))))
+ (inputs
+ `(("lv2" ,lv2)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (native-search-paths
+ (list (search-path-specification
+ (variable "LV2_PATH")
+ (files '("lib/lv2")))))
+ (home-page "https://drobilla.net/software/mda-lv2")
+ (synopsis "Audio plug-in pack for LV2")
+ (description
+ "A port of the MDA VST plugins to LV2. Includes effects and a few
+instruments.")
+ (license (list license:gpl3+ license:gpl3+))))
--
2.32.0
Xinglu Chen wrote 4 years ago
(name . Thorsten Wilms)(address . t_w_@freenet.de)
875yyb6xzx.fsf@yoctocell.xyz
On Mon, Jun 14 2021, Thorsten Wilms wrote:

Toggle quote (13 lines)
> +(define-public mda-lv2
> + (package
> + (name "mda-lv2")
> + (version "1.2.6")
> + (source
> + (origin
> + (method url-fetch)
> + (uri
> + ;; Tarball from gitlab lacks waflib directory content, so take it from
> + ;; drobilla.net.
> + (string-append "http://download.drobilla.net/mda-lv2-"
> + version ".tar.bz2"))

The waflib directory is a submodule in the Git repo, something like this
should work (untested):

(git-reference
(commit (string-append "v" version))
(recursive? #t))
Toggle quote (22 lines)
> + (sha256
> + (base32 "1nspk2j11l65m5r9z5isw8j749vh9a89wgx8mkrrq15f4iq12rnd"))))
> + (build-system waf-build-system)
> + (arguments
> + `(#:tests? #f ; There are no tests.
> + #:configure-flags
> + (list (string-append "--prefix="
> + (assoc-ref %outputs "out")))))
> + (inputs
> + `(("lv2" ,lv2)))
> + (native-inputs
> + `(("pkg-config" ,pkg-config)))
> + (native-search-paths
> + (list (search-path-specification
> + (variable "LV2_PATH")
> + (files '("lib/lv2")))))
> + (home-page "https://drobilla.net/software/mda-lv2")
> + (synopsis "Audio plug-in pack for LV2")
> + (description
> + "A port of the MDA VST plugins to LV2. Includes effects and a few
> +instruments.")

The description should consist of one or more full sentences, and use
double spaces between sentences. Maybe something like this:

MDA-LV2 is an LV2 port of the MDA plugins. It includes effects and
a few instrument plugins.
Toggle quote (2 lines)
> + (license (list license:gpl3+ license:gpl3+))))

The two licenses are the same, simply ‘license:gpl3+’ would do.

Could you send an updated patch?
-----BEGIN PGP SIGNATURE-----

iQJJBAEBCAAzFiEEAVhh4yyK5+SEykIzrPUJmaL7XHkFAmDMr2IVHHB1YmxpY0B5
b2N0b2NlbGwueHl6AAoJEKz1CZmi+1x5xqMP/153O8JCQ1nx/w1PI8b3jt0RZFhT
WGHV5tTZiTjrkrmivWx9J1eRZa4eZ9EsRaIFbVQpZ7/7dW8CWt7X2ll0kJOoOYQv
2r/WnhW1M2AlPXljeSlKt7Lze9px+vD1UYMC5edALuFy/LO7ut5s0oHKLu7L8pLs
0AFXEMLEXbs2jrJ8Y3OeEe9Kcbf9aOZn9x/q7su0ZlaA/FMqmWFPRXGN8DGBSGIE
KWlltftTr/t8z5MPBOf1as/AMe/mc38cRd3r7Dk1BiLuybE1uORQn0y1livFoS71
aYrfj/YPhoPf0jWVnwwVyaHXnVzi6SDC2cSjq3LH3wkRu9VeEdmKunoUuZRLMbRk
sDkNO1AMOuqDEU9bb2FgaGXv4DC/DQ9YwMRIO6JsvzaEj/m5Oa3XA+HYJOOXLq2w
BrRg3Yi7h/ZMjr8Az1OS6qV7aKKJz0usSxZC5N2/mUURdAU7Vfw+3Yf/Rd2uaYgm
85D83M7o/CDVC3BzwE7yBaR5Xgn0zxymd4aZJOKiVGzzKbqSLGHX3GejD0EXNJIC
vpPQpKw95QPsA+8wMuAOubHIgNFkc+NPcpsed0xEnYqiPBJNJ3nw/pTN0chhItzm
2Skqb9SJX+VErvCVrbwlh5Ws0WEF6ycpUmaimBkYll5ONd1H4MXXHXsbYtAux0Qs
vfDhofn0DARfeRtp
=Rx2q
-----END PGP SIGNATURE-----

Thorsten Wilms wrote 4 years ago
(address . 49028@debbugs.gnu.org)(name . Xinglu Chen)(address . public@yoctocell.xyz)
20210620162612.7f6f58f837925c8abfd2d840@freenet.de
I fixed the description and license. I think there’s no need to change
away from the tarball, as it’s actually an official release on the code
author’s domain.

Thanks, Xinglu Chen!


* gnu/packages/audio.scm (mda-lv2): New variable.
---
gnu/packages/audio.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 3885a22e10..e352f797da 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -5275,3 +5275,38 @@ Icecast server.")
generator, generating audio signals out of Linux's /dev/dsp audio
device. There is support for mono and/or stereo and 8 or 16 bit
samples.") (license license:gpl2)))
+
+(define-public mda-lv2
+ (package
+ (name "mda-lv2")
+ (version "1.2.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ ;; Tarball from gitlab lacks waflib directory content, so take
it from
+ ;; drobilla.net.
+ (string-append "http://download.drobilla.net/mda-lv2-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
"1nspk2j11l65m5r9z5isw8j749vh9a89wgx8mkrrq15f4iq12rnd"))))
+ (build-system waf-build-system)
+ (arguments
+ `(#:tests? #f ; There are no tests.
+ #:configure-flags
+ (list (string-append "--prefix="
+ (assoc-ref %outputs "out")))))
+ (inputs
+ `(("lv2" ,lv2)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (native-search-paths
+ (list (search-path-specification
+ (variable "LV2_PATH")
+ (files '("lib/lv2")))))
+ (home-page "https://drobilla.net/software/mda-lv2")
+ (synopsis "Audio plug-in pack for LV2")
+ (description
+ MDA-LV2 is an LV2 port of the MDA plugins. It includes effects and
+a few instrument plugins.
+ (license license:gpl3+)))
--
2.32.0
Xinglu Chen wrote 4 years ago
87v966s5rt.fsf@yoctocell.xyz
On Sun, Jun 20 2021, Thorsten Wilms wrote:

Toggle quote (4 lines)
> I fixed the description and license. I think there’s no need to change
> away from the tarball, as it’s actually an official release on the code
> author’s domain.

Fair enough.

Toggle quote (2 lines)
> Thanks, Xinglu Chen!

You are welcome!

Note that things that shouldn’t be part of the commit message should be
put below the ‘---’ line. The subject should also contain “[PATCH v2]”
to reflect that this is the second version of the patch, you can pass
the ‘--reroll-count=2’ to ‘git send-email’.

Also, I am not able to apply the patch, ‘git am’ reports:

Applying: gnu: Add mda-lv2
error: corrupt patch at line 12
error: could not build fake ancestor
hint: Use 'git am --show-current-patch=diff' to see the failed patch
Patch failed at 0001 gnu: Add mda-lv2
When you have resolved this problem, run "git am --continue".
If you prefer to skip this patch, run "git am --skip" instead.
To restore the original branch and stop patching, run "git am --abort".

Your previous patch did apply cleanly, did you do anything differently?

Toggle quote (12 lines)
> +(define-public mda-lv2
> + (package
> + (name "mda-lv2")
> + (version "1.2.6")
> + (source
> + (origin
> + (method url-fetch)
> + (uri
> + ;; Tarball from gitlab lacks waflib directory content, so take
> it from
> + ;; drobilla.net.

This comment isn’t accurate anymore, so there is probably no need for
it.

Toggle quote (25 lines)
> + version ".tar.bz2"))
> + (sha256
> + (base32
> "1nspk2j11l65m5r9z5isw8j749vh9a89wgx8mkrrq15f4iq12rnd"))))
> + (build-system waf-build-system)
> + (arguments
> + `(#:tests? #f ; There are no tests.
> + #:configure-flags
> + (list (string-append "--prefix="
> + (assoc-ref %outputs "out")))))
> + (inputs
> + `(("lv2" ,lv2)))
> + (native-inputs
> + `(("pkg-config" ,pkg-config)))
> + (native-search-paths
> + (list (search-path-specification
> + (variable "LV2_PATH")
> + (files '("lib/lv2")))))
> + (home-page "https://drobilla.net/software/mda-lv2")
> + (synopsis "Audio plug-in pack for LV2")
> + (description
> + MDA-LV2 is an LV2 port of the MDA plugins. It includes effects and
> +a few instrument plugins.

The description should be put inside double quotes :)

Could you send a v3?
-----BEGIN PGP SIGNATURE-----

iQJJBAEBCAAzFiEEAVhh4yyK5+SEykIzrPUJmaL7XHkFAmDRlMYVHHB1YmxpY0B5
b2N0b2NlbGwueHl6AAoJEKz1CZmi+1x5PmAQAJQ0dnyB/r97QfkH8pBCb4oNrCZg
SyxUBNdLJNU1MgDuYZSXC6G8g+vRTF4DT4r31P8glZ4usprHFw1RS4IvtdpkXjIl
6Bkqz+rsgE8EfVUoBt9JetucCYL6QHCXGe5wez+v+ZmJfdOIBFOvJEFHjK3+Ak9z
hxW9d2/Gn7Ny8lb3kNoYF6MlA5PPB99olVu5hCvIiOKl+2hWqYT5yvSWzyUUOXPK
Sxz1upa78OR3HGMeMnyHYcMawbkiwRQK50qFyGZCGfcNGe7u5eHxst+VjGMEESwe
Y+obbGziHfzx9f8z6XgW/HUCbZQfIS6rBZB6wP+grJDbxRuLLqrNovVkO5QZOJDV
TPC4DzqeQ91mEtwn9yycPnHQZorp+SLB8ohx9LVxUL9f9Lfu/v7Ndbyw/LEbIKht
Fqx48vB5WBefqWZADM4Tnqt3ZV1Ys1xDNTt5zNwriRoG8PU4C/5ODrMEtTTOxnR7
xpOIRtRsnBWLNfNuWTuerMC92OYy0h0TElu5m5Ct+M6HJ+wFuNi6rhWHGwRgbYxj
EpWkflsljTC7Z0CI7dvo2LQaQRhelW1Vf45hGXenIoOu53fZXz8UqcMGM9bqP6hp
Zatxjswy6DVU4JUAAKRHjRdRhVi7usrVYGBqrJ1969gPGocLRJqtbrrmUNQVOFTL
qc5yuYuC/xRecDV3
=bbhh
-----END PGP SIGNATURE-----

Thorsten Wilms wrote 4 years ago
[PATCH v3] Add mda-lv2. * gnu/packages/audio.scm (mda-lv2): New variable.
(address . 49028@debbugs.gnu.org)
20210622110054.12438-1-t_w_@freenet.de
---
gnu/packages/audio.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 3885a22e10..22dc71fe50 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -5275,3 +5275,36 @@ Icecast server.")
generator, generating audio signals out of Linux's /dev/dsp audio
device. There is support for mono and/or stereo and 8 or 16 bit samples.")
(license license:gpl2)))
+
+(define-public mda-lv2
+ (package
+ (name "mda-lv2")
+ (version "1.2.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "http://download.drobilla.net/mda-lv2-"
+ version ".tar.bz2"))
+ (sha256
+ (base32 "1nspk2j11l65m5r9z5isw8j749vh9a89wgx8mkrrq15f4iq12rnd"))))
+ (build-system waf-build-system)
+ (arguments
+ `(#:tests? #f ; There are no tests.
+ #:configure-flags
+ (list (string-append "--prefix="
+ (assoc-ref %outputs "out")))))
+ (inputs
+ `(("lv2" ,lv2)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (native-search-paths
+ (list (search-path-specification
+ (variable "LV2_PATH")
+ (files '("lib/lv2")))))
+ (home-page "https://drobilla.net/software/mda-lv2")
+ (synopsis "Audio plug-in pack for LV2")
+ (description
+ "MDA-LV2 is an LV2 port of the MDA plugins. It includes effects and a few
+instrument plugins.")
+ (license license:gpl3+)))
--
2.32.0
Xinglu Chen wrote 4 years ago
(name . Thorsten Wilms)(address . t_w_@freenet.de)
878s31rmrx.fsf@yoctocell.xyz
On Tue, Jun 22 2021, Thorsten Wilms wrote:

Toggle quote (4 lines)
> ---
> gnu/packages/audio.scm | 33 +++++++++++++++++++++++++++++++++
> 1 file changed, 33 insertions(+)

LGTM, apart from the commit summary being a little messed up. :)

I don’t have commit access though, so you will have to wait for someone
else to merge it.
-----BEGIN PGP SIGNATURE-----

iQJJBAEBCAAzFiEEAVhh4yyK5+SEykIzrPUJmaL7XHkFAmDS9PMVHHB1YmxpY0B5
b2N0b2NlbGwueHl6AAoJEKz1CZmi+1x5N5gP/AgAzB3HcJ59PUMqZ3vncwB1CZbt
7Cp3idnTmqr9v9ZpCW43Bl1QIfqwy0O9XlWBIcLjaIx9CCgrFny6FmPk+ujLN7Q1
ytSZ5+UeDyyRjXEcV7taf6hPmx7td3TxP7yaWnkXJaeMrooMxSjQrAQXvX476pLT
+YshFDWdf3gelIIKwnzlZuzQqIDszOl0bq5rFHstOTrYtXmgDJnAIj2lvm9v6OOh
r1IntsWOC2PzsifJbI2+eReKTm7nU3nT3RLH72BoC5FYG075Q/T9EdrV3hw8B4o4
IfGAb3Xhui3WIeW+qwX3sxBNP9ClbEF87XPiW8vANKlvHggM3aNZNdJwSBpWwKdF
h/QqKpUPOYTv0pwrRVq8S1wSBb2dm70ZxFrr6cY1gaaJVT1gILqqROI8CzA86wzP
jnYZswxNbXoLJntDpWMRoMDmGOaunPrnQzS9br6h/9a4esceFYekk5ViHXEV7Iac
NCp0L3guYt7naobPp/78Nz5BXjW702Re6Pic8weDFv6arrjCfN+Fqq36A1oBauiW
gSLmDPfUmPRh9PBn2DPcEynW6iwDITHx0IgyM1vaVUYgiKWZKuhx5zrIzk6wF3uk
CCHnWijaXziWGBBw/UB3Rgbw4lr+RKncDJwtd74X8u3gkFcDR041Yap2Cc+84K23
P6y+5fCo+WfJQH9M
=Jevt
-----END PGP SIGNATURE-----

Efraim Flashner wrote 4 years ago
(name . Thorsten Wilms)(address . t_w_@freenet.de)
YNnhevaSsHgug2ki@3900XT
Thanks. Patch pushed!

--
Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmDZ4XoACgkQQarn3Mo9
g1G7RxAAqK7dgVUT1QoZVT54+2Jj7B9i5/k0rRKs+wsHODohcndb3ax9QuLq21zd
4gUw5hCYm39ZKyizUJJtI9LAItfMopjRtJ7frJfuyj4kFxaL8ffXjpJH6Ch/Gcdq
moT2+RDdpZxFjwYeSPtshMggx2YrGkw1sCedv9v9ujj/IHF4wY5EP3Kq6+beE8Mq
R3ykDpfkxTZem8Pb8d27Wc4U4Ns3yrdF0HZO9N00rx/RaAiZOJL068OESBiicoNf
1G3YGMUFMWhVscWCTBJ7zHOBvKstLj5hO+qNPhPnvEWx2R107ROvHCDUqyKZRkn9
szbN0ugTTwaF3jBfr8Cool3jQIEtvImt1bEygOboQppFnfOmOHvFxddEKrlApERD
G/BydqmRCzLk4dv+eUBMhz0N8peMAyykDRVju8fNQ1VhpyMrkhGKIsyEwDKrUXr9
SDzH++WriJOGdp4lotqVpngKm+tkOIGjaJuj7sIZF7VWe0cOuqDXlWr3YkuVGcUo
M4V8IF3mxwCU5sIpecUAZenoUwqFaJE70WC/FU1j7LHmbWmjoRF6yBcYrTpA2Mva
fKXImKNrZuajsE36Jfy4cbLvge+kcAi08dLvkNywSk5Xte9B1aw72gZey7+nTLyL
rwW0/1RAryIIF0CePWbqkOQjktVcN3HMYL22wdliNpNNEPYecOM=
=fn3b
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 49028@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 49028
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help