[PATCH core-updates] gnu: custom-gcc: Update regex for removing executables.

  • Done
  • quality assurance status badge
Details
2 participants
  • Sarah Morgensen
  • Ludovic Courtès
Owner
unassigned
Submitted by
Sarah Morgensen
Severity
normal
S
S
Sarah Morgensen wrote on 13 Jun 2021 23:01
(address . guix-patches@gnu.org)(name . Sarah Morgensen)(address . iskarian@mgsn.dev)
20210613210125.24907-1-iskarian@mgsn.dev
Do not match "gccgo". Match "gcov-dump" and "gcov-tool", as well as
"lto-dump" (which was introduced in GCC 10).

* gnu/packages/gcc.scm (custom-gcc)[arguments]: Update regex used for
matching broken or conflicting executables.
---
gnu/packages/gcc.scm | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)

Toggle diff (20 lines)
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 5d114dca87..621b4a1200 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -716,9 +716,10 @@ as the 'native-search-paths' field."
`(modify-phases ,phases
(add-after 'install 'remove-broken-or-conflicting-files
(lambda* (#:key outputs #:allow-other-keys)
- (for-each delete-file
- (find-files (string-append (assoc-ref outputs "out") "/bin")
- ".*(c\\+\\+|cpp|g\\+\\+|gcov|gcc|gcc-.*)"))))))))))
+ (for-each
+ delete-file
+ (find-files (string-append (assoc-ref outputs "out") "/bin")
+ ".*(c\\+\\+|cpp|g\\+\\+|gcov|gcc|lto)(-.*)?$"))))))))))
(define %generic-search-paths
;; This is the language-neutral search path for GCC. Entries in $CPATH are
--
2.31.1
L
L
Ludovic Courtès wrote on 5 Jul 2021 13:12
(name . Sarah Morgensen)(address . iskarian@mgsn.dev)(address . 49010-done@debbugs.gnu.org)
87wnq5t3oc.fsf@gnu.org
Hi,

Sarah Morgensen <iskarian@mgsn.dev> skribis:

Toggle quote (6 lines)
> Do not match "gccgo". Match "gcov-dump" and "gcov-tool", as well as
> "lto-dump" (which was introduced in GCC 10).
>
> * gnu/packages/gcc.scm (custom-gcc)[arguments]: Update regex used for
> matching broken or conflicting executables.

Applied to ‘core-updates’.

Thanks, and sorry for the delay!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 49010@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 49010
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch