[PATCH] gnu: Add ausweisapp2.

  • Done
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • Maxime Devos
  • Sergey Trofimov
Owner
unassigned
Submitted by
Sergey Trofimov
Severity
normal

Debbugs page

Sergey Trofimov wrote 4 years ago
(address . guix-patches@gnu.org)(name . Sergey Trofimov)(address . sarg@sarg.org.ru)
20210613071837.12152-1-sarg@sarg.org.ru
---
gnu/packages/security-token.scm | 55 +++++++++++++++++++++++++++++++++
guix/licenses.scm | 6 ++++
2 files changed, 61 insertions(+)

Toggle diff (103 lines)
diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index 89783de965..da1334f1bf 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -34,6 +34,7 @@
#:use-module (guix gexp)
#:use-module (guix git-download)
#:use-module (guix build-system cargo)
+ #:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system python)
@@ -56,6 +57,7 @@
#:use-module (gnu packages cyrus-sasl)
#:use-module (gnu packages popt)
#:use-module (gnu packages readline)
+ #:use-module (gnu packages qt)
#:use-module (gnu packages tls)
#:use-module (gnu packages tex)
#:use-module (gnu packages perl)
@@ -720,3 +722,56 @@ an unprivileged user.")
for interaction with Nitrokey Pro, Nitrokey Storage, and Librem Key
devices.")
(license license:gpl3+)))
+
+(define-public ausweisapp2
+ (package
+ (name "ausweisapp2")
+ (version "1.22.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/Governikus/AusweisApp2/releases"
+ "/download/" version "/AusweisApp2-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1qh1m057va7njs3yk0s31kwsvv44fjlsdac6lhiw5npcwssgjn8l"))))
+
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("qttools" ,qttools)))
+ (inputs `(("qtbase" ,qtbase)
+ ("qtsvg" ,qtsvg)
+ ("qtdeclarative" ,qtdeclarative)
+ ("qtwebsockets" ,qtwebsockets)
+ ("qtgraphicaleffects" ,qtgraphicaleffects)
+ ("qtquickcontrols2" ,qtquickcontrols2)
+ ("pcsc-lite" ,pcsc-lite)
+ ("openssl" ,openssl)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'wrap-executable
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (wrap-program (string-append out "/bin/AusweisApp2")
+ `("QT_PLUGIN_PATH" ":" prefix
+ ,(map (lambda (label)
+ (string-append (assoc-ref inputs label)
+ "/lib/qt5/plugins"))
+ '("qtbase" "qtdeclarative"
+ "qtsvg" "qtwebsockets")))
+ `("QML2_IMPORT_PATH" ":" prefix
+ ,(map (lambda (label)
+ (string-append (assoc-ref inputs label)
+ "/lib/qt5/qml"))
+ '("qtdeclarative" "qtgraphicaleffects"
+ "qtquickcontrols2" "qtsvg"))))
+ #t))))))
+ (home-page "https://github.com/Governikus/AusweisApp2")
+ (synopsis
+ "Official authentication app for German ID cards and residence permits")
+ (description
+ "This app is developed and issued by the German government to be used for online
+authentication with electronic German ID cards and residence titles. To use this app,
+a supported RFID card reader or NFC-enabled smart phone is required.")
+ (license license:eupl1.2)))
diff --git a/guix/licenses.scm b/guix/licenses.scm
index e7457799ce..c455cc8c39 100644
--- a/guix/licenses.scm
+++ b/guix/licenses.scm
@@ -56,6 +56,7 @@
edl1.0
epl1.0
epl2.0
+ eupl1.2
expat
freetype
freebsd-doc
@@ -307,6 +308,11 @@ at URI, which may be a file:// URI pointing the package's tree."
"https://www.eclipse.org/legal/epl-2.0/"
"https://www.gnu.org/licenses/license-list#EPL2"))
+(define eupl1.2
+ (license "EUPL 1.2"
+ "https://directory.fsf.org/wiki/License:EUPL-1.2"
+ "https://www.gnu.org/licenses/license-list#EPL2"))
+
(define expat
(license "Expat"
"http://directory.fsf.org/wiki/License:Expat"
--
2.32.0
Maxime Devos wrote 4 years ago
694b0156fe5becf86e967eaf20a4df2c746f5190.camel@telenet.be
Hi,

Toggle quote (14 lines)
> + (wrap-program (string-append out "/bin/AusweisApp2")
> + `("QT_PLUGIN_PATH" ":" prefix
> + ,(map (lambda (label)
> + (string-append (assoc-ref inputs label)
> + "/lib/qt5/plugins"))
> + '("qtbase" "qtdeclarative"
> + "qtsvg" "qtwebsockets")))
> + `("QML2_IMPORT_PATH" ":" prefix
> + ,(map (lambda (label)
> + (string-append (assoc-ref inputs label)
> + "/lib/qt5/qml"))
> + '("qtdeclarative" "qtgraphicaleffects"
> + "qtquickcontrols2" "qtsvg"))))

There is procedure 'wrap-qt-program' in (guix build qt-utils).
It should set QML2_IMPORT_PATH, QT_PLUGIN_PATH, XDG_DATA_DIRS and
XDG_CONFIG_DIRS appropriately. (Actually, wrap-qt-program's usage
of 'getenv' when cross-compiling looks incorrect to me, but that's a
separate issue.)

Perhaps you could use 'wrap-qt-program' instead of 'wrap-program'?
See, e.g., the package definition of qbittorrent.

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYMik7xccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7noQAQChfuNsf1R/gwW9Fmzr5Gmz+PAn
7gcqTlB53KvEuMWvJgEApoVR2z+Jd/RsqCOlfv4nRzacdoIELu9A5c8MyZ3XiAA=
=zZT1
-----END PGP SIGNATURE-----


Sergey Trofimov wrote 4 years ago
[PATCH] gnu: Add ausweisapp2.
(address . 48997@debbugs.gnu.org)(name . Sergey Trofimov)(address . sarg@sarg.org.ru)
20210615153721.4608-1-sarg@sarg.org.ru
* gnu/packages/security-token.scm (ausweisapp2): New variable.
* guix/licenses.scm (eupl1.2): New variable.
---
gnu/packages/security-token.scm | 47 +++++++++++++++++++++++++++++++++
guix/licenses.scm | 6 +++++
2 files changed, 53 insertions(+)

Toggle diff (95 lines)
diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index 89783de965..555b8216a2 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -34,6 +34,7 @@
#:use-module (guix gexp)
#:use-module (guix git-download)
#:use-module (guix build-system cargo)
+ #:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system python)
@@ -56,6 +57,7 @@
#:use-module (gnu packages cyrus-sasl)
#:use-module (gnu packages popt)
#:use-module (gnu packages readline)
+ #:use-module (gnu packages qt)
#:use-module (gnu packages tls)
#:use-module (gnu packages tex)
#:use-module (gnu packages perl)
@@ -720,3 +722,48 @@ an unprivileged user.")
for interaction with Nitrokey Pro, Nitrokey Storage, and Librem Key
devices.")
(license license:gpl3+)))
+
+(define-public ausweisapp2
+ (package
+ (name "ausweisapp2")
+ (version "1.22.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/Governikus/AusweisApp2/releases"
+ "/download/" version "/AusweisApp2-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1qh1m057va7njs3yk0s31kwsvv44fjlsdac6lhiw5npcwssgjn8l"))))
+
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("qttools" ,qttools)))
+ (inputs `(("qtbase" ,qtbase)
+ ("qtsvg" ,qtsvg)
+ ("qtdeclarative" ,qtdeclarative)
+ ("qtwebsockets" ,qtwebsockets)
+ ("qtgraphicaleffects" ,qtgraphicaleffects)
+ ("qtquickcontrols2" ,qtquickcontrols2)
+ ("pcsc-lite" ,pcsc-lite)
+ ("openssl" ,openssl)))
+ (arguments
+ `(#:modules ((guix build cmake-build-system)
+ (guix build qt-utils)
+ (guix build utils))
+ #:imported-modules (,@%cmake-build-system-modules
+ (guix build qt-utils))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'wrap-qt
+ (lambda* (#:key outputs #:allow-other-keys)
+ (wrap-qt-program (assoc-ref outputs "out") "AusweisApp2")
+ #t)))))
+ (home-page "https://github.com/Governikus/AusweisApp2")
+ (synopsis
+ "Official authentication app for German ID cards and residence permits")
+ (description
+ "This app is developed and issued by the German government to be used for online
+authentication with electronic German ID cards and residence titles. To use this app,
+a supported RFID card reader or NFC-enabled smart phone is required.")
+ (license license:eupl1.2)))
diff --git a/guix/licenses.scm b/guix/licenses.scm
index e7457799ce..c455cc8c39 100644
--- a/guix/licenses.scm
+++ b/guix/licenses.scm
@@ -56,6 +56,7 @@
edl1.0
epl1.0
epl2.0
+ eupl1.2
expat
freetype
freebsd-doc
@@ -307,6 +308,11 @@ at URI, which may be a file:// URI pointing the package's tree."
"https://www.eclipse.org/legal/epl-2.0/"
"https://www.gnu.org/licenses/license-list#EPL2"))
+(define eupl1.2
+ (license "EUPL 1.2"
+ "https://directory.fsf.org/wiki/License:EUPL-1.2"
+ "https://www.gnu.org/licenses/license-list#EPL2"))
+
(define expat
(license "Expat"
"http://directory.fsf.org/wiki/License:Expat"
--
2.32.0
Ludovic Courtès wrote 4 years ago
(name . Sergey Trofimov)(address . sarg@sarg.org.ru)(address . 48997-done@debbugs.gnu.org)
87fsx7rlhy.fsf_-_@gnu.org
Hi,

Sergey Trofimov <sarg@sarg.org.ru> skribis:

Toggle quote (3 lines)
> * gnu/packages/security-token.scm (ausweisapp2): New variable.
> * guix/licenses.scm (eupl1.2): New variable.

Applied with the changes below.

Thanks!

Ludo’.
Toggle diff (60 lines)
diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index 555b8216a2..49ca1dc01e 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2020 Raphaël Mélotte <raphael.melotte@mind.be>
;;; Copyright © 2021 Antero Mejr <antero@kodmin.com>
+;;; Copyright © 2021 Sergey Trofimov <sarg@sarg.org.ru>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -739,14 +740,15 @@ devices.")
(native-inputs
`(("pkg-config" ,pkg-config)
("qttools" ,qttools)))
- (inputs `(("qtbase" ,qtbase)
- ("qtsvg" ,qtsvg)
- ("qtdeclarative" ,qtdeclarative)
- ("qtwebsockets" ,qtwebsockets)
- ("qtgraphicaleffects" ,qtgraphicaleffects)
- ("qtquickcontrols2" ,qtquickcontrols2)
- ("pcsc-lite" ,pcsc-lite)
- ("openssl" ,openssl)))
+ (inputs
+ `(("qtbase" ,qtbase-5)
+ ("qtsvg" ,qtsvg)
+ ("qtdeclarative" ,qtdeclarative)
+ ("qtwebsockets" ,qtwebsockets)
+ ("qtgraphicaleffects" ,qtgraphicaleffects)
+ ("qtquickcontrols2" ,qtquickcontrols2)
+ ("pcsc-lite" ,pcsc-lite)
+ ("openssl" ,openssl)))
(arguments
`(#:modules ((guix build cmake-build-system)
(guix build qt-utils)
@@ -755,15 +757,15 @@ devices.")
(guix build qt-utils))
#:phases
(modify-phases %standard-phases
- (add-after 'install 'wrap-qt
- (lambda* (#:key outputs #:allow-other-keys)
- (wrap-qt-program (assoc-ref outputs "out") "AusweisApp2")
- #t)))))
+ (add-after 'install 'wrap-qt
+ (lambda* (#:key outputs #:allow-other-keys)
+ (wrap-qt-program (assoc-ref outputs "out") "AusweisApp2"))))))
(home-page "https://github.com/Governikus/AusweisApp2")
(synopsis
- "Official authentication app for German ID cards and residence permits")
+ "Authentication program for German ID cards and residence permits")
(description
- "This app is developed and issued by the German government to be used for online
-authentication with electronic German ID cards and residence titles. To use this app,
-a supported RFID card reader or NFC-enabled smart phone is required.")
+ "This application is developed and issued by the German government to be
+used for online authentication with electronic German ID cards and residence
+titles. To use this app, a supported RFID card reader or NFC-enabled smart
+phone is required.")
(license license:eupl1.2)))
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 48997@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 48997
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help