[PATCH 1/2] gnu: libngspice: Update to 34.

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Vinicius Monego
Owner
unassigned
Submitted by
Vinicius Monego
Severity
normal
V
V
Vinicius Monego wrote on 12 Jun 2021 23:10
(address . guix-patches@gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20210612211015.784359-1-monego@posteo.net
* gnu/packages/engineering.scm (libngspice): Update to 34.
[source]: Make some cosmetic changes.
[arguments]<#:phases>: Don't return #t.
(ngspice)[arguments]<#:phases>: Don't return #t. Remove 'delete-cmpp-dlmain
phase because these files are not installed anymore.
---
gnu/packages/engineering.scm | 67 +++++++++++++++---------------------
1 file changed, 28 insertions(+), 39 deletions(-)

Toggle diff (98 lines)
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 981dd9e5e3..228376480c 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -1683,31 +1683,31 @@ high-performance parallel differential evolution (DE) optimization algorithm.")
;; See <https://debbugs.gnu.org/cgi/bugreport.cgi?bug=27344#236>.
(package
(name "libngspice")
- (version "28")
- (source (origin
- (method url-fetch)
- (uri (list
- (string-append "mirror://sourceforge/ngspice/ng-spice-rework/"
- version "/ngspice-" version ".tar.gz")
- (string-append "mirror://sourceforge/ngspice/ng-spice-rework/"
- "old-releases/" version
- "/ngspice-" version ".tar.gz")))
- (sha256
- (base32
- "0rnz2rdgyav16w7wfn3sfrk2lwvvgz1fh0l9107zkcldijklz04l"))
- (modules '((guix build utils)))
- ;; We remove the non-free cider and build without it.
- (snippet
- '(begin
- (delete-file-recursively "src/ciderlib")
- (delete-file "src/ciderinit")
- (substitute* "configure"
- (("src/ciderlib/Makefile") "")
- (("src/ciderlib/input/Makefile") "")
- (("src/ciderlib/support/Makefile") "")
- (("src/ciderlib/oned/Makefile") "")
- (("src/ciderlib/twod/Makefile") ""))
- #t))))
+ (version "34")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (list
+ (string-append "mirror://sourceforge/ngspice/ng-spice-rework/"
+ version "/ngspice-" version ".tar.gz")
+ (string-append "mirror://sourceforge/ngspice/ng-spice-rework/"
+ "old-releases/" version
+ "/ngspice-" version ".tar.gz")))
+ (sha256
+ (base32 "1dfpkgkwmgwhq8dnbb8dh28cfap6rw0yywkhmxr4jxclcvygyqr2"))
+ (modules '((guix build utils)))
+ ;; We remove the non-free cider and build without it.
+ (snippet
+ '(begin
+ (delete-file-recursively "src/ciderlib")
+ (delete-file "src/ciderinit")
+ (substitute* "configure"
+ (("src/ciderlib/Makefile") "")
+ (("src/ciderlib/input/Makefile") "")
+ (("src/ciderlib/support/Makefile") "")
+ (("src/ciderlib/oned/Makefile") "")
+ (("src/ciderlib/twod/Makefile") ""))
+ #t))))
(build-system gnu-build-system)
(arguments
`(;; No tests for libngspice exist.
@@ -1718,14 +1718,12 @@ high-performance parallel differential evolution (DE) optimization algorithm.")
(add-after 'unpack 'patch-timestamps
(lambda _
(substitute* "configure"
- (("`date`") "Thu Jan 1 00:00:01 UTC 1970"))
- #t))
+ (("`date`") "Thu Jan 1 00:00:01 UTC 1970"))))
(add-after 'unpack 'delete-program-manuals
(lambda _
(substitute* "man/man1/Makefile.in"
(("^man_MANS = ngspice\\.1 ngnutmeg\\.1 ngsconvert\\.1 ngmultidec\\.1")
- "man_MANS = "))
- #t))
+ "man_MANS = "))))
(add-after 'install 'delete-script-files
(lambda* (#:key outputs #:allow-other-keys)
(delete-file-recursively
@@ -1768,16 +1766,7 @@ an embedded event driven algorithm.")
(lambda _
(substitute* "src/Makefile.in"
(("^SUBDIRS = misc maths frontend spicelib include/ngspice")
- "SUBDIRS = misc maths frontend spicelib"))
- #t))
- (add-after 'install 'delete-cmpp-dlmain
- (lambda* (#:key outputs #:allow-other-keys)
- (for-each (lambda (file)
- (delete-file
- (string-append (assoc-ref outputs "out")
- file)))
- '("/bin/cmpp" "/share/ngspice/dlmain.c"))
- #t))
+ "SUBDIRS = misc maths frontend spicelib"))))
(delete 'delete-program-manuals)
(delete 'delete-script-files)))))
(inputs
--
2.32.0
V
V
Vinicius Monego wrote on 12 Jun 2021 23:11
[PATCH 2/2] gnu: libngspice: Enable ciderlib.
(address . 48979@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20210612211140.784567-1-monego@posteo.net
* gnu/packages/engineering.scm (libngspice)[source]: Remove snippet that
deleted ciderlib.
[arguments]: Pass "--enable-ciderlib" to #:configure-flags.
[license]: Add license for ciderlib.
---
ngspice announced that it is DFSG-compatible since version 28 (June 1st 2018):
I had a look at the Debian copyright file and ciderlib is marked as bsd-3. I am adding this license to the list then:

gnu/packages/engineering.scm | 17 +++--------------
1 file changed, 3 insertions(+), 14 deletions(-)

Toggle diff (44 lines)
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 228376480c..0e9e647ec9 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -1694,20 +1694,7 @@ high-performance parallel differential evolution (DE) optimization algorithm.")
"old-releases/" version
"/ngspice-" version ".tar.gz")))
(sha256
- (base32 "1dfpkgkwmgwhq8dnbb8dh28cfap6rw0yywkhmxr4jxclcvygyqr2"))
- (modules '((guix build utils)))
- ;; We remove the non-free cider and build without it.
- (snippet
- '(begin
- (delete-file-recursively "src/ciderlib")
- (delete-file "src/ciderinit")
- (substitute* "configure"
- (("src/ciderlib/Makefile") "")
- (("src/ciderlib/input/Makefile") "")
- (("src/ciderlib/support/Makefile") "")
- (("src/ciderlib/oned/Makefile") "")
- (("src/ciderlib/twod/Makefile") ""))
- #t))))
+ (base32 "1dfpkgkwmgwhq8dnbb8dh28cfap6rw0yywkhmxr4jxclcvygyqr2"))))
(build-system gnu-build-system)
(arguments
`(;; No tests for libngspice exist.
@@ -1731,6 +1718,7 @@ high-performance parallel differential evolution (DE) optimization algorithm.")
"/share/ngspice/scripts")))))
#:configure-flags
(list "--enable-openmp"
+ "--enable-ciderlib"
"--enable-xspice"
"--with-ngshared"
"--with-readline=yes")))
@@ -1750,6 +1738,7 @@ provides code modeling support and simulation of digital components through
an embedded event driven algorithm.")
(license (list license:lgpl2.0+ ; code in frontend/numparam
(license:non-copyleft "file:///COPYING") ; spice3 bsd-style
+ license:bsd-3 ; ciderlib
license:public-domain)))) ; xspice
(define-public ngspice
--
2.32.0
E
E
Efraim Flashner wrote on 15 Jun 2021 20:19
Re: [bug#48979] [PATCH 1/2] gnu: libngspice: Update to 34.
(name . Vinicius Monego)(address . monego@posteo.net)(address . 48979-done@debbugs.gnu.org)
YMjvKiPNbQZE7mb7@3900XT
Good catch on the ciderlib. Patches pushed!

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmDI7yoACgkQQarn3Mo9
g1HSCg/+LUdibOr8MdbXXBMGDKPiK/0ctY52wqQ9zYpF+drRNay2elUO+sTV9cMV
Cl4wg1PLybGwgVHSlcDWYkW+o2oUoZIpw4a61wu/x9JYJMn5kTO8rKG8+8wL/2Rh
zr957I+9fFCNGMfVPlnBxaqjK8ajqQX4CEkJY+xTvlwRd/5JE4k07JO/s+he/zgX
MalNV+D0grFyLyDvw5NMWpgFQWgTAbvmJDeGcJD4313ICdNygoHUYgHsceLLVIH2
kkgtNJQh3/E1mtSoT9Hu+dWbEjw1UtNvlEWDNPvOE+Xysfjw9jDLkkg1l+lqh7Ks
nLU8Zwa1On9uc7XpvNlduVPqnOeulGRrLIgNiW/HGa1FqZAqFHmTyBhTqZANv9DS
8ovsgPK9x2Vv9FfEMUWM583hEvsJmjOVNzA7L0CK7Zi2liZnsrfyucgXP3P7oObM
lZxdVv7RjLVRXEAVEl15f9iFY6c8c75BSHK7dG+KtytA3AKov/Oz13pI6v7hwQ+k
pFxEXMxs4XrMKEY70vnxwQiTEmlWO8vjNtbcN8CUuEvRcIbYbo4I+X8SDT+44Og0
93da7OLPU5g7gU96dkpcKF2SbSOjffokwMlCFXg2PoU01Dvy0v8JMqZmxaikzJb9
z9JNiDkmGZhZhvnvIm2e8zob5df5IySGkEoEDDkOAerv0DrZZKk=
=ZKHN
-----END PGP SIGNATURE-----


Closed
?