No newline after substitution of ~a complete line.

  • Open
  • quality assurance status badge
Details
One participant
  • Brendan Tildesley
Owner
unassigned
Submitted by
Brendan Tildesley
Severity
normal

Debbugs page

Brendan Tildesley wrote 4 years ago
(name . bug-guix@gnu.org)(address . bug-guix@gnu.org)(name . ludo@gnu.org)(address . ludo@gnu.org)
1520066429.101148.1623478037139@office.mailbox.org
I get output that looks like this:

substitution of /gnu/store/g26z8hhqagcsiwz611jwhyj7rk6zywqg-python-pybigwig-0.3.17 completesubstituting /gnu/store/slxjk0sg8q85qk0l0dv5kv71z2l4pgv2-python-pybrowserid-0.14.0...

Also, could the value of (simultaneous-jobs status) change between invocations in the code? It's ok not to use let?
Adding a newline seems to fix it.
From a2628f0565e0428af55ada53ac3826e9a855b022 Mon Sep 17 00:00:00 2001
From: Brendan Tildesley <mail@brendan.scot>
Date: Sat, 12 Jun 2021 15:58:13 +1000
Subject: [PATCH] status: Add missing (newline).

* guix/status.scm: Add newline after substitution complete line.
---
guix/status.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (16 lines)
diff --git a/guix/status.scm b/guix/status.scm
index 1164c2a6e3..f351a56d92 100644
--- a/guix/status.scm
+++ b/guix/status.scm
@@ -558,7 +558,8 @@ substitutes being downloaded."
;; If there are no jobs running, we already reported download completion
;; so there's nothing left to do.
(unless (zero? (simultaneous-jobs status))
- (format port (success (G_ "substitution of ~a complete")) item))
+ (format port (success (G_ "substitution of ~a complete")) item)
+ (newline port))
(when (and print-urls? (zero? (simultaneous-jobs status)))
;; Leave a blank line after the "downloading ..." line and the
--
2.31.1
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 48967@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 48967
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help