[PATCH] hydra: bordeaux: Add a how to code snippet.

  • Done
  • quality assurance status badge
Details
2 participants
  • Joshua Branson
  • Christopher Baines
Owner
unassigned
Submitted by
Joshua Branson
Severity
normal
J
J
Joshua Branson wrote on 8 Jun 2021 10:10
(address . guix-patches@gnu.org)
20210608081002.26581-1-jbranso@dismail.de
* hydra/nginx/html/bordeaux/index.html: (Using These substitutes):
Fixed a typo, and added a how to code snippet for users of guix system.
---
hydra/nginx/html/bordeaux/index.html | 42 +++++++++++++++++++++++++++-
1 file changed, 41 insertions(+), 1 deletion(-)

Toggle diff (61 lines)
diff --git a/hydra/nginx/html/bordeaux/index.html b/hydra/nginx/html/bordeaux/index.html
index a74f2e2..89042af 100644
--- a/hydra/nginx/html/bordeaux/index.html
+++ b/hydra/nginx/html/bordeaux/index.html
@@ -36,7 +36,7 @@
<b>arm-linux-gnueabihf</b> availability is limited.
</p>
- <h2>Using these substiutes</h2>
+ <h2>Using these substitutes</h2>
<p>
The URL to use to fetch substitutes is <code>https://bordeaux.guix.gnu.org</code>,
and they're signed with the following key.
@@ -47,5 +47,45 @@
)
)</pre>
</p>
+ <p>
+ Users of Guix System can start using these substitutes with a
+ bit of scheme code that looks like:
+
+ <pre>
+(define %my-desktop-services
+ (modify-services
+ %desktop-services
+ (guix-service-type
+ config =>
+ (guix-configuration
+ (inherit config)
+ (substitute-urls
+ (append (list "https://bordeaux.guix.gnu.org/";)
+ %default-substitute-urls))
+ (authorized-keys
+ (append
+ (list
+ (plain-file
+ "bordeaux.guix.gnu.org.signing.key"
+ "
+(public-key
+ (ecc
+ (curve Ed25519)
+ (q #7D602902D3A2DBB83F8A0FB98602A754C5493B0B778C8D1DD4E0F41DE14DE34F#)
+ )
+ )"))
+ %default-authorized-guix-keys)))))))
+
+
+(operating-system
+ ...
+ (services (append (list (service dhcp-client-service-type)
+ (service openssh-service-type
+ (openssh-configuration
+ (openssh openssh-sans-x)
+ (port-number 2222))))
+ %my-desktop-services)))
+ </pre>
+ </p>
</body>
</html>
--
2.31.1
C
C
Christopher Baines wrote on 8 Jun 2021 17:14
(name . Joshua Branson)(address . jbranso@dismail.de)(address . 48912-done@debbugs.gnu.org)
875yyotmky.fsf@cbaines.net
Joshua Branson <jbranso@dismail.de> writes:

Toggle quote (3 lines)
> * hydra/nginx/html/bordeaux/index.html: (Using These substitutes):
> Fixed a typo, and added a how to code snippet for users of guix system.

Thanks, I've gone ahead, merged and deployed this.

I did consider trying to add something like this myself, but I'm still
focused on getting this in as a default, which should make things even
easier for users.

Thanks again,

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmC/iW1fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xf47g//RlZWuzzUC42klqHM+U1u7LK4b/h+51/+
Kdx/xVNJFMmV2PaNoLQ+3aqPIq5rRYwsuSRKL9ultYyp1lW0VCLXYtDslFLNN42Z
pV17X/jQhgahrEZskZtLuePPlTwLLS0uH+g6qFt4ewsRdHP1mzPo0hIwniL4CIKn
C5RBhqulONYAR2Mzl1l1Uwp8z920YrTuqOKmVlG2cPmDLWJQfA3R0mkvxiU+MSZU
HvOZF0I4qvJ+fKHO9+aL2Ubaw9mtRzxBJdSJCV4fIgM5QnRskH9Qxb/FZ+kRCzT1
JmbmthtJSLNajGquA1vIj3G18cDceHni4MaOwYbWZBJu4NGdtrgp5K9lrpM7GXvU
Z55sJ9RD/uyF+l/YYAzojqIa/vs0prHU4hxaSv5QPPggz60eOjLSmMndnAUGGEnv
SS5gKePyfXHKRonrxkVl212lu/wciXmFzbF2msMVXM+6Qa/iSzMMc1WjUuRu4Sd5
y/llcse0A506xTV/x9jnJ/8GpylyFHl7cDGYdHb8ndDP1oy27FbzWqYuSUvU59Wn
FXPhxrToA6j4iOfwkAOewTPQNfUSm/r1H1H6qsxZIVAfr1K/toDfAqscLy7kNXNz
sS+KxuZ8I1XfJow4X0sNdwxfXBC+cb1HW8owfIaF5ANkrdR/COiFegwASEPlHizO
CHOMxwOLX5o=
=d524
-----END PGP SIGNATURE-----

Closed
?