* gnu/packages/emacs-xyz.scm (emacs-ytel): New variable.
---
gnu/packages/emacs-xyz.scm | 43 ++++++++++++++++++++++++++++++++++++++
1 file changed, 43 insertions(+)
Toggle diff (56 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 1d954ec5bd..8ad6d1e119 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -21204,6 +21204,49 @@ youtube-dl backends are supported. It is possible to create download profiles
depending on the downloaded URL.")
(license license:gpl3+)))
+(define-public emacs-ytel
+ ;; No releases.
+ ;; Commit from 2020-11-28
+ (let ((commit "d40bc7ead8d4d7e4d16b03b66a93d63bef51cc5f")
+ (revision "0"))
+ (package
+ (name "emacs-ytel")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/grastello/ytel")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0pxzfsxzrpv59dssrgx2mmwkm6rzk49ffjkgsa3wks7rdyfil3kf"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-exec-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((curl (assoc-ref inputs "curl")))
+ (substitute* "ytel.el"
+ (("\"curl\"") (string-append "\"" curl "/bin/curl\"")))))))))
+ (inputs
+ `(("curl" ,curl)))
+ (home-page "https://github.com/grastello/ytel")
+ (synopsis "Query YouTube via Invidious")
+ (description
+ "This package provide a major mode to search YouTube videos via an
+Elfeed-like buffer. Information about videos displayed in this buffer can be
+extracted and manipulated by user-defined functions to do various things such
+as:
+
+@itemize
+@item playing them in some video player
+@item download them
+@end itemize")
+ (license license:gpl3+))))
+
(define-public emacs-org-web-tools
(package
(name "emacs-org-web-tools")
--
2.32.0