[PATCH 0/2] Add ‘emacs-ytel’ and ‘emacs-ytel-show’

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Xinglu Chen
Owner
unassigned
Submitted by
Xinglu Chen
Severity
normal
X
X
Xinglu Chen wrote on 7 Jun 2021 17:55
(address . guix-patches@gnu.org)
cover.1623081191.git.public@yoctocell.xyz
This patch series adds two Emacs packages, one for searching for YouTube
videos using the Invidious API (emacs-ytel), and one for browsing videos
and comments (emacs-ytel-show).

Xinglu Chen (2):
gnu: Add emacs-ytel.
gnu: Add emacs-ytel-show.

gnu/packages/emacs-xyz.scm | 69 ++++++++++++++++++++++++++++++++++++++
1 file changed, 69 insertions(+)


base-commit: e3611cc412e7b1c750a56d17fb1b7cde684baa3f
--
2.32.0
X
X
Xinglu Chen wrote on 7 Jun 2021 17:56
[PATCH 1/2] gnu: Add emacs-ytel.
(address . 48904@debbugs.gnu.org)
1f95f43ad23bf1cd567ced83d38fc31dcabd2e10.1623081191.git.public@yoctocell.xyz
* gnu/packages/emacs-xyz.scm (emacs-ytel): New variable.
---
gnu/packages/emacs-xyz.scm | 43 ++++++++++++++++++++++++++++++++++++++
1 file changed, 43 insertions(+)

Toggle diff (56 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 1d954ec5bd..8ad6d1e119 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -21204,6 +21204,49 @@ youtube-dl backends are supported. It is possible to create download profiles
depending on the downloaded URL.")
(license license:gpl3+)))
+(define-public emacs-ytel
+ ;; No releases.
+ ;; Commit from 2020-11-28
+ (let ((commit "d40bc7ead8d4d7e4d16b03b66a93d63bef51cc5f")
+ (revision "0"))
+ (package
+ (name "emacs-ytel")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/grastello/ytel")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0pxzfsxzrpv59dssrgx2mmwkm6rzk49ffjkgsa3wks7rdyfil3kf"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-exec-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((curl (assoc-ref inputs "curl")))
+ (substitute* "ytel.el"
+ (("\"curl\"") (string-append "\"" curl "/bin/curl\"")))))))))
+ (inputs
+ `(("curl" ,curl)))
+ (home-page "https://github.com/grastello/ytel")
+ (synopsis "Query YouTube via Invidious")
+ (description
+ "This package provide a major mode to search YouTube videos via an
+Elfeed-like buffer. Information about videos displayed in this buffer can be
+extracted and manipulated by user-defined functions to do various things such
+as:
+
+@itemize
+@item playing them in some video player
+@item download them
+@end itemize")
+ (license license:gpl3+))))
+
(define-public emacs-org-web-tools
(package
(name "emacs-org-web-tools")
--
2.32.0
X
X
Xinglu Chen wrote on 7 Jun 2021 17:56
[PATCH 2/2] gnu: Add emacs-ytel-show.
(address . 48904@debbugs.gnu.org)
f37d3ea0e7bea76bd208f3387d9531806b5cf656.1623081191.git.public@yoctocell.xyz
* gnu/packages/emacs-xyz.scm (emacs-ytel-show): New variable.
---
gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8ad6d1e119..5b9ddfff62 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -21247,6 +21247,32 @@ as:
@end itemize")
(license license:gpl3+))))
+(define-public emacs-ytel-show
+ ;; No releases.
+ ;; Commit from 2020-11-21.
+ (let ((commit "8b999484eb447ecdb741b24cbef2b5a7260a53e6")
+ (revision "0"))
+ (package
+ (name "emacs-ytel-show")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/xFA25E/ytel-show")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0nhgzfzq1bgpbdbljx5z2hzr8ia7ybsyvvr66yj4klz0zj97rghj"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-ytel" ,emacs-ytel)))
+ (home-page "https://github.com/xFA25E/ytel-show")
+ (synopsis "Browse YouTube in Emacs")
+ (description "This package provides an Emacs interface for browsing
+YouTube videos and comments.")
+ (license license:gpl3+))))
+
(define-public emacs-org-web-tools
(package
(name "emacs-org-web-tools")
--
2.32.0
N
N
Nicolas Goaziou wrote on 12 Jun 2021 22:31
Re: [bug#48904] [PATCH 1/2] gnu: Add emacs-ytel.
(name . Xinglu Chen)(address . public@yoctocell.xyz)(address . 48904-done@debbugs.gnu.org)
87o8casu2y.fsf@nicolasgoaziou.fr
Hello,

Xinglu Chen <public@yoctocell.xyz> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-ytel): New variable.

Applied. Thank you.

Toggle quote (2 lines)
> + (version (git-version "0.0.0" revision commit))

I made it "0.1.0" according to the main file. Same for the other package.

Toggle quote (2 lines)
> + (synopsis "Query YouTube via Invidious")

I rewrote the synopsis, since this one does not seem clearly related to
the project.

Toggle quote (11 lines)
> + (description
> + "This package provide a major mode to search YouTube videos via an
> +Elfeed-like buffer. Information about videos displayed in this buffer can be
> +extracted and manipulated by user-defined functions to do various things such
> +as:
> +
> +@itemize
> +@item playing them in some video player
> +@item download them
> +@end itemize")

The list wasn't strictly necessary so I appended it to the last
paragraph instead.

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 48904@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 48904
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch