(name . bug-guix)(address . bug-guix@gnu.org)
Hello,
Using Guix from the master branch at commit
b2122b07dc24007263b92247cc479713c2101390, with a system reconfigured on
the 2nd of June (Guix commit bb325c5611553a6db21ee7499ac07d5757d24fc3):
Toggle snippet (19 lines)
Generation 216 Jun 02 2021 10:14:19 (current)
file name: /var/guix/profiles/system-216-link
canonical file name: /gnu/store/apjg70083nc5xj816y0ff3r8ir9gh5py-system
label: GNU with Linux-Libre 5.11.20
bootloader: grub
root device: /dev/mapper/cryptroot
kernel: /gnu/store/ghijd80qabdyf0p6jcich9ggnpwrbwxw-linux-libre-5.11.20/bzImage
channels:
sfl-packages:
repository URL: https://gitlab.com/Apteryks/sfl-guix-channel
branch: master
commit: 37d017573350b64f8a8c992530153f42806b6a6f
guix:
repository URL: https://git.savannah.gnu.org/git/guix.git
branch: master
commit: bb325c5611553a6db21ee7499ac07d5757d24fc3
configuration file:
/gnu/store/qvhl7ya2xn4gr9mn29hg93p1dcbdlyfy-configuration.scm
with the guix-daemon running being:
Toggle snippet (6 lines)
/gnu/store/9zh3bg8d4y08jnkqyrk6xczahiahhcy4-guix-1.3.0-1.771b866/bin/guix-daemon
29920 guixbuild --max-silent-time 0 --timeout 0 --log-compression none
--discover=no --substitute-urls http://127.0.0.1:8080
https://ci.guix.gnu.org --max-jobs=4
Attempting to update my profile keeps failing with:
Toggle snippet (22 lines)
$ ./pre-inst-env guix package -m ~/stow/guix/manifest.scm -L ~/src/sfl-guix-channel/ --substitute-urls=https://ci.guix.gnu.org --no-offload
;;; note: source file /home/maxim/src/guix-master/gnu/packages/networking.scm
;;; newer than compiled /home/maxim/src/guix-master/gnu/packages/networking.go
;;; note: source file /home/maxim/src/guix-master/gnu/packages/networking.scm
;;; newer than compiled /run/current-system/profile/lib/guile/3.0/site-ccache/gnu/packages/networking.go
The following packages will be installed:
acpi 1.7
adb 7.1.2_r36
adwaita-icon-theme 3.34.3
alsa-utils 1.2.4
[...]
xrandr 1.5.1
xrdb 1.2.0
xsetroot 1.1.2
yelp 3.32.2
122.8 MB will be downloaded
libreoffice-6.4.7.2 117.1MiB 344KiB/s 03:04 [######### ] 52.7%guix substitute: error: TLS error in procedure 'read_from_session_record_port': Error decoding the received TLS packet.
substitution of /gnu/store/44h13hn5zssfppz67vydxcf95qsc8qfw-libreoffice-6.4.7.2 failed
guix package: error: some substitutes for the outputs of derivation `/gnu/store/9f8sffldy39mprihx6xgrs7hys9j75jm-libreoffice-6.4.7.2.drv' failed (usually happens due to networking issues); try `--fallback' to build derivation from source
I'm attaching my (large!) profile manifest. It depends on the
https://gitlab.com/Apteryks/sfl-guix-channelchannel, which just adds 3
Python packages. You could comment out the "sflvault-client" package
from the manifest to lift that requirement.
Thanks,
Maxim
(use-modules (gnu packages)
(gnu packages emacs)
(guix build-system emacs)
(guix profiles))
(concatenate-manifests
(list
;;; Emacs packages.
(specifications->manifest
'("emacs"
"emacs-auctex"
"emacs-bash-completion"
"emacs-bbdb"
"emacs-cmake-mode"
"emacs-company"
"emacs-company-quickhelp"
"emacs-counsel"
"emacs-counsel-bbdb"
"emacs-csv-mode"
"emacs-debbugs"
"emacs-diff-hl"
"emacs-el-mock"
"emacs-elpy"
"emacs-emms"
"emacs-ggtags"
"emacs-go-mode"
"emacs-grep-a-lot"
"emacs-groovy-modes"
"emacs-guix"
"emacs-htmlize"
"emacs-ivy"
"emacs-magit"
"emacs-markdown-mode"
"emacs-nix-mode"
"emacs-org"
"emacs-org-reveal"
"emacs-paredit"
"emacs-php-mode"
"emacs-pdf-tools"
"emacs-qml-mode"
"emacs-realgud"
"emacs-rpm-spec-mode"
"emacs-sr-speedbar"
"emacs-string-inflection"
"emacs-swiper"
"emacs-w3m"
"emacs-ws-butler"
"emacs-yaml-mode"
"emacs-yasnippet"
"emacs-yasnippet-snippets"))
;; Other software.
(specifications->manifest
'("adb"
"acpi"
"adwaita-icon-theme"
"alsa-utils"
"anthy"
"arc-icon-theme"
"arc-theme"
"aspell"
"aspell-dict-en"
"aspell-dict-fr"
"autoconf"
"automake"
"autossh"
"bash"
"bc"
"beep"
"bind:utils" ;for 'dig'
"bluez"
"bridge-utils"
"cheese"
"compsize"
"cqfd"
"cryptsetup"
"curl"
"dbus"
"dconf"
"ddcutil"
"diffoscope"
"docker-cli"
"dosfstools"
"evince"
"file"
"font-adobe-source-han-sans"
"font-dejavu"
"font-google-roboto"
"font-hack"
"gcc-toolchain"
"gdb"
"geeqie"
"ghostscript-with-x"
"gimp"
"git"
"git:send-email"
"glibc-locales"
"global"
"gnome-bluetooth"
"gnome-boxes"
"gnu-standards"
"gnucash"
"gnucash:doc"
"gnupg"
"graphviz"
"grub" ;for the manual
"gtk-engines"
"guile"
"guile-lib"
"guile-readline"
"guile-sqlite3"
"guile-ssh"
"hackneyed-x11-cursors"
"hicolor-icon-theme"
"hunspell"
"hunspell-dict-fr"
"ibus"
"ibus-anthy"
"icecat"
"imagemagick"
"inetutils"
"inkscape"
"iotop"
"jack"
"jami-gnome"
"jami-qt"
"nethogs" ;pre-process bandwith monitoring
"jnettop" ;bandwidth monitoring
"keepassxc"
"libjpeg"
"libmtp"
"libpcap"
"libreoffice"
"libssh"
"libx11"
"linphone-desktop"
"lm-sensors"
"lsof"
"ltrace"
"lvm2" ;for dmsetup
"maim" ;take screenshots
"make"
"man-pages"
"mesa-utils"
"moreutils"
"mpv"
"mtr"
"ncftp" ;for gnupload
"nmap"
"openssh"
"openvpn"
"parted"
"pavucontrol"
"perl"
"pinentry"
"pkg-config"
"poppler"
"pulseaudio"
"pv"
"python"
"python-wrapper"
"qemu"
"recutils"
"rofi"
"rsync"
"rtorrent"
"screen"
"setxkbmap"
"shepherd"
"sicp"
"smartmontools"
"spacefm"
"stow"
"strace"
"sysstat" ;for iostat
"tcpdump"
"the-silver-searcher" ;ag
"time" ;aliased to time+
"transmission"
"transmission:gui"
"tree"
"unzip"
"vinagre"
"vorbis-tools"
"weechat"
"wget"
"workrave"
"wpa-supplicant"
"xclip"
"xdpyinfo"
"xdg-utils"
"xev"
"xmodmap"
"xournal"
"xrandr"
"xrdb"
"xsetroot"
"yelp"
"gxtuner"
"shellcheck"
"wireguard-tools"
"wireshark"))
;; SFL stuff -- todo extract in separate manifest
(specifications->manifest
'("ansible"
"docker-compose"
"emacs-adoc-mode"
"emacs-clang-format"
"emacs-clang-rename"
"emacs-feature-mode"
"picocom"
"python-git-review"
"sflvault-client"
"sshpass"
"ungoogled-chromium"
"ddrescue"))))