[PATCH] New package: ack

  • Done
  • quality assurance status badge
Details
2 participants
  • Ryan Sundberg
  • zimoun
Owner
unassigned
Submitted by
Ryan Sundberg
Severity
normal

Debbugs page

Ryan Sundberg wrote 4 years ago
(address . guix-patches@gnu.org)(name . Ryan Sundberg)(address . ryan@arctype.co)
20210606194936.21986-1-ryan@arctype.co
ack is a grep-like source code search tool.

Signed-off-by: Ryan Sundberg <ryan@arctype.co>
---
gnu/packages/search.scm | 30 +++++++++++++++++++++++++++++-
1 file changed, 29 insertions(+), 1 deletion(-)

Toggle diff (61 lines)
diff --git a/gnu/packages/search.scm b/gnu/packages/search.scm
index 362eb0d95e..a131678936 100644
--- a/gnu/packages/search.scm
+++ b/gnu/packages/search.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2018, 2020, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Adam Massmann <massmannak@gmail.com>
;;; Copyright © 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;; Copyright © 2021 Ryan Sundberg <ryan@arctype.co>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -24,11 +25,12 @@
(define-module (gnu packages search)
#:use-module ((guix licenses)
- #:select (gpl2 gpl2+ gpl3+ lgpl2.1+ bsd-3 x11 perl-license))
+ #:select (gpl2 gpl2+ gpl3+ lgpl2.1+ bsd-3 x11 perl-license artistic2.0))
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix utils)
+ #:use-module (guix build-system copy)
#:use-module (guix build-system gnu)
#:use-module (guix build-system perl)
#:use-module (guix build-system python)
@@ -50,6 +52,32 @@
#:use-module (gnu packages xdisorg)
#:use-module (gnu packages xml))
+
+(define-public ack
+ (package
+ (name "ack")
+ (version "3.5.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://beyondgrep.com/ack-v" version))
+ (sha256 (base32 "17wq9c1pwisbg4mcmvmdaym8hlawx209iriaxjlw9hwi0v4x6w38"))))
+ (inputs `(("perl" ,perl)))
+ (build-system copy-build-system)
+ (arguments
+ `(#:install-plan '(("ack" "bin/ack"))
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'unpack
+ (lambda* (#:key source #:allow-other-keys)
+ (copy-file source "ack")
+ (chmod "ack" #o0755)
+ #t)))))
+ (home-page "https://github.com/protojure/protoc-plugin")
+ (synopsis "ack is a grep-like source code search tool.")
+ (description "Designed for programmers with large heterogeneous trees of source code, ack is written in portable Perl 5 and takes advantage of the power of Perl's regular expressions. ack is designed as an alternative to grep for programmers.")
+ (license artistic2.0)))
+
(define-public xapian
(package
(name "xapian")
--
2.31.1
zimoun wrote 4 years ago
(name . Ryan Sundberg)(address . ryan@arctype.co)(address . 48886-done@debbugs.gnu.org)
87bl7wobs1.fsf@gmail.com
Hi,

On Sun, 06 Jun 2021 at 12:49, Ryan Sundberg <ryan@arctype.co> wrote:
Toggle quote (12 lines)
> ack is a grep-like source code search tool.
>
> Signed-off-by: Ryan Sundberg <ryan@arctype.co>
> ---
> gnu/packages/search.scm | 30 +++++++++++++++++++++++++++++-
> 1 file changed, 29 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/search.scm b/gnu/packages/search.scm
> index 362eb0d95e..a131678936 100644
> --- a/gnu/packages/search.scm
> +++ b/gnu/packages/search.scm

Exactly the same as #48893; already commented. Therefore, closing this one.


All the best,
simon
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 48886@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 48886
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help