[PATCH] gnu: python-hicmatrix: Update to 15.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Mădălin Ionel Patrașcu
Severity
normal

Debbugs page

Mădălin Ionel Patrașcu wrote 4 years ago
(address . guix-patches@gnu.org)(address . rekado@elephly.net)(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)
20210606083144.25207-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioinformatics.scm (python-hicmatrix): Update to 15.
[source]: Changed from pypi to github, pypi sources do not contain tests.
[arguments]: Removed build phase "relax-requirements" and replaced the
pahse "check".
[native-inputs]: Add python-pytest.
---
gnu/packages/bioinformatics.scm | 37 ++++++++++++++++-----------------
1 file changed, 18 insertions(+), 19 deletions(-)

Toggle diff (61 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 2de8a59d3c..02da131fdf 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -11786,29 +11786,26 @@ such as Hi-C contact matrices.")
(define-public python-hicmatrix
(package
(name "python-hicmatrix")
- (version "12")
- (source
- (origin
- ;; Version 12 is not available on pypi.
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/deeptools/HiCMatrix")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1xhdyx16f3brgxgxybixdi64ki8nbbkq5vk4h9ahi11pzpjfn1pj"))))
+ (version "15")
+ (source
+ (origin
+ ;;Pypi sources do not contain any test
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/deeptools/HiCMatrix")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1dshjxgb16sdfg9k1bhw2yhyngac04k4ca7aqy8g3i3pprr068r5"))))
(build-system python-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'relax-requirements
- (lambda _
- (substitute* '("requirements.txt"
- "setup.py")
- (("cooler *=+ *0.8.5")
- "cooler==0.8.*"))
- #t)))))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "python" "-m" "pytest" "-v")))))))
(propagated-inputs
`(("python-cooler" ,python-cooler)
("python-intervaltree" ,python-intervaltree)
@@ -11816,6 +11813,8 @@ such as Hi-C contact matrices.")
("python-pandas" ,python-pandas)
("python-scipy" ,python-scipy)
("python-tables" ,python-tables)))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
(home-page "https://github.com/deeptools/HiCMatrix/")
(synopsis "HiCMatrix class for HiCExplorer and pyGenomeTracks")
(description
--
2.31.1
Mădălin Ionel Patrașcu wrote 4 years ago
[PATCH v2] gnu: python-hicmatrix: Update to 15.
(address . 48863@debbugs.gnu.org)(address . rekado@elephly.net)(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)
20210607115328.28208-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioinformatics.scm (python-hicmatrix): Update to 15.
[source]: Download via git-fetch.
[arguments]: Enabled tests. Remove 'relax-requirements phase.
[native-inputs]: Add python-pytest.
---
gnu/packages/bioinformatics.scm | 37 ++++++++++++++++-----------------
1 file changed, 18 insertions(+), 19 deletions(-)

Toggle diff (61 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 2de8a59d3c..02da131fdf 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -11786,29 +11786,26 @@ such as Hi-C contact matrices.")
(define-public python-hicmatrix
(package
(name "python-hicmatrix")
- (version "12")
- (source
- (origin
- ;; Version 12 is not available on pypi.
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/deeptools/HiCMatrix")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1xhdyx16f3brgxgxybixdi64ki8nbbkq5vk4h9ahi11pzpjfn1pj"))))
+ (version "15")
+ (source
+ (origin
+ ;;Pypi sources do not contain any test
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/deeptools/HiCMatrix")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1dshjxgb16sdfg9k1bhw2yhyngac04k4ca7aqy8g3i3pprr068r5"))))
(build-system python-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'relax-requirements
- (lambda _
- (substitute* '("requirements.txt"
- "setup.py")
- (("cooler *=+ *0.8.5")
- "cooler==0.8.*"))
- #t)))))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "python" "-m" "pytest" "-v")))))))
(propagated-inputs
`(("python-cooler" ,python-cooler)
("python-intervaltree" ,python-intervaltree)
@@ -11816,6 +11813,8 @@ such as Hi-C contact matrices.")
("python-pandas" ,python-pandas)
("python-scipy" ,python-scipy)
("python-tables" ,python-tables)))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
(home-page "https://github.com/deeptools/HiCMatrix/")
(synopsis "HiCMatrix class for HiCExplorer and pyGenomeTracks")
(description
--
2.31.1
Mădălin Ionel Patrașcu wrote 4 years ago
Re: [PATCH] gnu: python-hicmatrix: Update to 15.
(address . guix-patches@gnu.org)(address . rekado@elephly.net)
afcb51cc-ae4b-2539-a6e7-df0f8c3c71c0@mdc-berlin.de
Hi Guix!


I changed the commit message!


All the best!

On 06.06.2021 10:31, Mădălin Ionel Patrașcu wrote:
Toggle quote (69 lines)
> * gnu/packages/bioinformatics.scm (python-hicmatrix): Update to 15.
> [source]: Changed from pypi to github, pypi sources do not contain tests.
> [arguments]: Removed build phase "relax-requirements" and replaced the
> pahse "check".
> [native-inputs]: Add python-pytest.
> ---
> gnu/packages/bioinformatics.scm | 37 ++++++++++++++++-----------------
> 1 file changed, 18 insertions(+), 19 deletions(-)
>
> diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
> index 2de8a59d3c..02da131fdf 100644
> --- a/gnu/packages/bioinformatics.scm
> +++ b/gnu/packages/bioinformatics.scm
> @@ -11786,29 +11786,26 @@ such as Hi-C contact matrices.")
> (define-public python-hicmatrix
> (package
> (name "python-hicmatrix")
> - (version "12")
> - (source
> - (origin
> - ;; Version 12 is not available on pypi.
> - (method git-fetch)
> - (uri (git-reference
> - (url "https://github.com/deeptools/HiCMatrix")
> - (commit version)))
> - (file-name (git-file-name name version))
> - (sha256
> - (base32
> - "1xhdyx16f3brgxgxybixdi64ki8nbbkq5vk4h9ahi11pzpjfn1pj"))))
> + (version "15")
> + (source
> + (origin
> + ;;Pypi sources do not contain any test
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/deeptools/HiCMatrix")
> + (commit version)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "1dshjxgb16sdfg9k1bhw2yhyngac04k4ca7aqy8g3i3pprr068r5"))))
> (build-system python-build-system)
> (arguments
> `(#:phases
> (modify-phases %standard-phases
> - (add-after 'unpack 'relax-requirements
> - (lambda _
> - (substitute* '("requirements.txt"
> - "setup.py")
> - (("cooler *=+ *0.8.5")
> - "cooler==0.8.*"))
> - #t)))))
> + (replace 'check
> + (lambda* (#:key tests? #:allow-other-keys)
> + (when tests?
> + (invoke "python" "-m" "pytest" "-v")))))))
> (propagated-inputs
> `(("python-cooler" ,python-cooler)
> ("python-intervaltree" ,python-intervaltree)
> @@ -11816,6 +11813,8 @@ such as Hi-C contact matrices.")
> ("python-pandas" ,python-pandas)
> ("python-scipy" ,python-scipy)
> ("python-tables" ,python-tables)))
> + (native-inputs
> + `(("python-pytest" ,python-pytest)))
> (home-page "https://github.com/deeptools/HiCMatrix/")
> (synopsis "HiCMatrix class for HiCExplorer and pyGenomeTracks")
> (description

--
System Administrator
Bioinformatics and Omics Data Science
BIMSB - MDC
Ricardo Wurmus wrote 4 years ago
Re: [PATCH v2] gnu: python-hicmatrix: Update to 15.
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 48863-done@debbugs.gnu.org)
87bl8gspyc.fsf@elephly.net
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
writes:

Toggle quote (6 lines)
> * gnu/packages/bioinformatics.scm (python-hicmatrix): Update to
> 15.
> [source]: Download via git-fetch.
> [arguments]: Enabled tests. Remove 'relax-requirements phase.
> [native-inputs]: Add python-pytest.

Applied as commit 8d9652beca7e3fc5b445c5d51d954193a11999b2.
Thank you!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 48863@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 48863
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help