[PATCH] gnu: python-hic2cool: Update to 0.8.3.

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Mădălin Ionel Patrașcu
Owner
unassigned
Submitted by
Mădălin Ionel Patrașcu
Severity
normal

Debbugs page

Mădălin Ionel Patrașcu wrote 4 years ago
(address . guix-patches@gnu.org)(address . rekado@elephly.net)(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)
20210606051407.6535-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioinformatics.scm (python-hic2cool): Update to 0.8.3.
---
gnu/packages/bioinformatics.scm | 28 ++++++++++++++++++++++------
1 file changed, 22 insertions(+), 6 deletions(-)

Toggle diff (47 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index dab097381a..66e69ff2c8 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -11892,18 +11892,34 @@ pyGenomeTracks can make plots with or without Hi-C data.")
(define-public python-hic2cool
(package
(name "python-hic2cool")
- (version "0.4.2")
+ (version "0.8.3")
+ ;; pypi sources do not contain the test_data directory and no test can be
+ ;; run
(source
(origin
- (method url-fetch)
- (uri (pypi-uri "hic2cool" version))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/4dn-dcic/hic2cool")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0xy6mhfns2lzib1kcr6419jjp6pmh0qx8z8na55lmiwn0ds8q9cl"))))
+ "0dlnf0qfcp4jrc1nyya32a035c13xicyq16bwfnwhbb9s47mz7gl"))))
(build-system python-build-system)
- (arguments '(#:tests? #f)) ; no tests included
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;;two of the test-data files need to be writable
+ (add-after 'unpack 'patch-test-data
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (chmod "test_data/hic2cool_0.4.2_single_res.cool" #o600)
+ (chmod "test_data/hic2cool_0.7.0_multi_res.mcool" #o600))))))
(propagated-inputs
- `(("python-cooler" ,python-cooler)))
+ `(("python-cooler" ,python-cooler)
+ ("python-h5py" ,python-h5py)
+ ("python-numpy" ,python-numpy)
+ ("python-pandas" ,python-pandas)
+ ("python-scipy" ,python-scipy)))
(home-page "https://github.com/4dn-dcic/hic2cool")
(synopsis "Converter for .hic and .cool files")
(description
--
2.31.1
Mădălin Ionel Patrașcu wrote 4 years ago
Re: [ext] bug#48862: Acknowledgement ([PATCH] gnu: python-hic2cool: Update to 0.8.3.)
(address . 48862@debbugs.gnu.org)
cb9ebe8c-dd92-bbd7-bd89-9761a1c000cc@mdc-berlin.de
Hey Guix,


I made some changes to the commit message, I omitted some important
information.

I will send another patch. Sorry for this!


All the best,

     Mădălin!

On 06.06.2021 07:15, GNU bug Tracking System wrote:
Toggle quote (17 lines)
> Thank you for filing a new bug report with debbugs.gnu.org.
>
> This is an automatically generated reply to let you know your message
> has been received.
>
> Your message is being forwarded to the package maintainers and other
> interested parties for their attention; they will reply in due course.
>
> Your message has been sent to the package maintainer(s):
> guix-patches@gnu.org
>
> If you wish to submit further information on this problem, please
> send it to 48862@debbugs.gnu.org.
>
> Please do not send mail to help-debbugs@gnu.org unless you wish
> to report a problem with the Bug-tracking system.
>
--
System Administrator
Bioinformatics and Omics Data Science
BIMSB - MDC
Mădălin Ionel Patrașcu wrote 4 years ago
[PATCH v2] gnu: python-hic2cool: Update to 0.8.3.
(address . 48862@debbugs.gnu.org)(address . rekado@elephly.net)(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)
20210606073253.18811-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioinformatics.scm (python-hic2cool): Update to 0.8.3.
[source]: Changed from pypi to github, pypi sources do not contain tests.
[arguments]: Add build phase "patch-test-data" and removed #:tests? #f.
[propagated-inputs]: Add python-h5py, python-numpy, python-pandas and
python-scipy.
---
gnu/packages/bioinformatics.scm | 28 ++++++++++++++++++++++------
1 file changed, 22 insertions(+), 6 deletions(-)

Toggle diff (47 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index dab097381a..66e69ff2c8 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -11892,18 +11892,34 @@ pyGenomeTracks can make plots with or without Hi-C data.")
(define-public python-hic2cool
(package
(name "python-hic2cool")
- (version "0.4.2")
+ (version "0.8.3")
+ ;; pypi sources do not contain the test_data directory and no test can be
+ ;; run
(source
(origin
- (method url-fetch)
- (uri (pypi-uri "hic2cool" version))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/4dn-dcic/hic2cool")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0xy6mhfns2lzib1kcr6419jjp6pmh0qx8z8na55lmiwn0ds8q9cl"))))
+ "0dlnf0qfcp4jrc1nyya32a035c13xicyq16bwfnwhbb9s47mz7gl"))))
(build-system python-build-system)
- (arguments '(#:tests? #f)) ; no tests included
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;;two of the test-data files need to be writable
+ (add-after 'unpack 'patch-test-data
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (chmod "test_data/hic2cool_0.4.2_single_res.cool" #o600)
+ (chmod "test_data/hic2cool_0.7.0_multi_res.mcool" #o600))))))
(propagated-inputs
- `(("python-cooler" ,python-cooler)))
+ `(("python-cooler" ,python-cooler)
+ ("python-h5py" ,python-h5py)
+ ("python-numpy" ,python-numpy)
+ ("python-pandas" ,python-pandas)
+ ("python-scipy" ,python-scipy)))
(home-page "https://github.com/4dn-dcic/hic2cool")
(synopsis "Converter for .hic and .cool files")
(description
--
2.31.1
Efraim Flashner wrote 4 years ago
Re: [bug#48862] [PATCH] gnu: python-hic2cool: Update to 0.8.3.
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . rekado@elephly.net)(address . 48862-done@debbugs.gnu.org)
YL3NWLGIW7WewgjQ@3900XT
I made a few changes before pushing the patch.

On Sun, Jun 06, 2021 at 07:14:07AM +0200, Mădălin Ionel Patrașcu wrote:
Toggle quote (2 lines)
> * gnu/packages/bioinformatics.scm (python-hic2cool): Update to 0.8.3.

I mentioned that the download changed to use git-fetch, the added phase
and enabled tests, and the added inputs.

Toggle quote (40 lines)
> ---
> gnu/packages/bioinformatics.scm | 28 ++++++++++++++++++++++------
> 1 file changed, 22 insertions(+), 6 deletions(-)
>
> diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
> index dab097381a..66e69ff2c8 100644
> --- a/gnu/packages/bioinformatics.scm
> +++ b/gnu/packages/bioinformatics.scm
> @@ -11892,18 +11892,34 @@ pyGenomeTracks can make plots with or without Hi-C data.")
> (define-public python-hic2cool
> (package
> (name "python-hic2cool")
> - (version "0.4.2")
> + (version "0.8.3")
> + ;; pypi sources do not contain the test_data directory and no test can be
> + ;; run
> (source
> (origin
> - (method url-fetch)
> - (uri (pypi-uri "hic2cool" version))
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/4dn-dcic/hic2cool")
> + (commit version)))
> + (file-name (git-file-name name version))
> (sha256
> (base32
> - "0xy6mhfns2lzib1kcr6419jjp6pmh0qx8z8na55lmiwn0ds8q9cl"))))
> + "0dlnf0qfcp4jrc1nyya32a035c13xicyq16bwfnwhbb9s47mz7gl"))))
> (build-system python-build-system)
> - (arguments '(#:tests? #f)) ; no tests included
> + (arguments
> + `(#:phases
> + (modify-phases %standard-phases
> + ;;two of the test-data files need to be writable
> + (add-after 'unpack 'patch-test-data
> + (lambda* (#:key inputs outputs #:allow-other-keys)
> + (chmod "test_data/hic2cool_0.4.2_single_res.cool" #o600)
> + (chmod "test_data/hic2cool_0.7.0_multi_res.mcool" #o600))))))

I changed this one to be 'lambda _' and I changed the chmods to
make-file-writable.

Toggle quote (17 lines)
> (propagated-inputs
> - `(("python-cooler" ,python-cooler)))
> + `(("python-cooler" ,python-cooler)
> + ("python-h5py" ,python-h5py)
> + ("python-numpy" ,python-numpy)
> + ("python-pandas" ,python-pandas)
> + ("python-scipy" ,python-scipy)))
> (home-page "https://github.com/4dn-dcic/hic2cool")
> (synopsis "Converter for .hic and .cool files")
> (description
> --
> 2.31.1
>
>
>
>

--
Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmC9zVgACgkQQarn3Mo9
g1H8ZBAAmzLQ0055EzTDCZ5W6Sr9uMx2ufas5+r7HWpIlQHN38t9rpSxkK/mtnqH
yZvlC/ZPPMh2ZVAw6BJo8qw1nAZUuMU6LsCGOCYxMhPRn9xIRvfpWx8s3BQzY/2f
kNNoGG5TMAiCai867sTIQ13fsBQmiDV7vYS8RnqOOIUHp8AQbn4Dlwn15ndD4UTR
jRmt3DPkcrFhVB2T9ejuMbc788leu1YWgJS6unOaqKmGXPXK0CEDKx0rSzIZf0rC
16bItC41e1vZZlNy+6ptZOomuom8zfT1gLxeBQiPeHxhmuDuck3Z6VYwoExbgZy3
dnUjddGfKpRO5dejXmA6F5P8CTLuUk6DECkm+va7whsIwQe3SaEqI7zVyEpXcswF
dJhl4AdMq9LZVhfb6TsaekO8Z3A6PjWCCZ7NuGRuJVSNBqmNASknrLkRBbSIKkN1
aEJLB4ZL0wQj9GT26zUj0jY8qZtOuyRJJC3qNf5gj52L6M14xhJHyKsUWzlD4yt8
Wa9JwuDp7fa+CnG2RULSMUXjB7rk6W1Ppo471LUxvkewS64VbCrjP4oBKvPyAjO2
k2Nokth4Y9DKNtzdubhtTCF4OZjmHrP4GtlP8brhz+4UTIxzq7oYWQveok3aKOly
/FSXeHj6BjbyoMlLSVHIYVYCx12QjoN44NfK9IVFB8+Ix/YXzjM=
=DLfN
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 48862@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 48862
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help