[PATCH core-updates]: Add #:sh argument to wrap-qt-program

  • Done
  • quality assurance status badge
Details
2 participants
  • Maxim Cournoyer
  • Maxime Devos
Owner
unassigned
Submitted by
Maxime Devos
Severity
normal
M
M
Maxime Devos wrote on 5 Jun 2021 13:49
(address . guix-patches@gnu.org)
678f5b29c1b5e2100bfde5b5121c57a9d2d2f3d8.camel@telenet.be
Hi guix,

This patch series adds a #:sh keyword argument to wrap-qt-program
and adjusts callers to set this keyword argument appropriately.

Setting this argument appropriately is required for cross-compilation.
Otherwise, a bash for SYSTEM (as in --system=..) is used instead
of a bash for TARGET (as in --target=...).

I didn't test building some qt programs with this patch series yet,
as I'm currently waiting on the substitute servers to catch up
with recent changed to core-updates (to avoid building a tower
of rusts). I'll do that later.

Greetings,
Maxime
From 27d42f25f54b16f382e18b9ef0fb202fb00da90d Mon Sep 17 00:00:00 2001
From: Maxime Devos <maximedevos@telenet.be>
Date: Sat, 5 Jun 2021 11:02:16 +0200
Subject: [PATCH 1/8] qt-utils: Allow overriding the shell interpreter in
'wrap-qt-program'.

* guix/build/qt-utils.scm (wrap-qt-program): Introduce a #:sh keyword
argument and pass it to 'wrap-program'.
---
guix/build/qt-utils.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

Toggle diff (30 lines)
diff --git a/guix/build/qt-utils.scm b/guix/build/qt-utils.scm
index d2486ee86c..60e699fe39 100644
--- a/guix/build/qt-utils.scm
+++ b/guix/build/qt-utils.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 David Craven <david@craven.ch>
+;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -20,7 +21,7 @@
#:use-module (guix build utils)
#:export (wrap-qt-program))
-(define (wrap-qt-program out program)
+(define* (wrap-qt-program out program #:key (sh (which "bash")))
(define (suffix env-var path)
(let ((env-val (getenv env-var)))
(if env-val (string-append env-val ":" path) path)))
@@ -34,6 +35,7 @@
(xdg-config-path (suffix "XDG_CONFIG_DIRS"
(string-append out "/etc/xdg"))))
(wrap-program (string-append out "/bin/" program)
+ #:sh sh
`("QML2_IMPORT_PATH" = (,qml-path))
`("QT_PLUGIN_PATH" = (,plugin-path))
`("XDG_DATA_DIRS" = (,xdg-data-path))
--
2.31.1
From 8ed53a6840b1099c8ccc50a1779187e186dfb7af Mon Sep 17 00:00:00 2001
From: Maxime Devos <maximedevos@telenet.be>
Date: Sat, 5 Jun 2021 11:04:20 +0200
Subject: [PATCH 2/8] gnu: qbittorrent: Set #:sh argument of 'wrap-qt-program'.
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

* gnu/packages/bittorrent.scm
(qbittorrent)[arguments]<#:phases>{wrap-qt}:
Set #:sh argument of ‘wrap-qt-program’.
---
gnu/packages/bittorrent.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

Toggle diff (18 lines)
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index 29b0d62ad2..339248da94 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -448,8 +448,9 @@ desktops.")
#:phases
(modify-phases %standard-phases
(add-after 'install 'wrap-qt
- (lambda* (#:key outputs #:allow-other-keys)
- (wrap-qt-program (assoc-ref outputs "out") "qbittorrent")
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (wrap-qt-program (assoc-ref outputs "out") "qbittorrent"
+ #:sh (search-input-file inputs "bin/bash"))
#t)))))
(native-inputs
`(("pkg-config" ,pkg-config)
--
2.31.1
From b02b0ea202d5e3970e5df2a461b83990c9edfc81 Mon Sep 17 00:00:00 2001
From: Maxime Devos <maximedevos@telenet.be>
Date: Sat, 5 Jun 2021 11:04:20 +0200
Subject: [PATCH 3/8] gnu: electron-cash: Set #:sh argument of
'wrap-qt-program'.
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

* gnu/packages/finance.scm
(electron-cash)[arguments]<#:phases>{wrap-qt}:
Set #:sh argument of ‘wrap-qt-program’.
---
gnu/packages/finance.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

Toggle diff (18 lines)
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index fbd7df783c..029df4f934 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -618,8 +618,9 @@ other machines/servers. Electrum does not download the Bitcoin blockchain.")
(assoc-ref inputs "libsecp256k1")
"/lib/libsecp256k1.so.0'")))))
(add-after 'install 'wrap-qt
- (lambda* (#:key outputs #:allow-other-keys)
- (wrap-qt-program (assoc-ref outputs "out") "electron-cash"))))))
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (wrap-qt-program (assoc-ref outputs "out") "electron-cash"
+ #:sh (search-input-file inputs "bin/bash")))))))
(home-page "https://electroncash.org/")
(synopsis "Bitcoin Cash wallet")
(description
--
2.31.1
From eac4a9fbd09bde8d52bd38f00a23aa11cd24ffa0 Mon Sep 17 00:00:00 2001
From: Maxime Devos <maximedevos@telenet.be>
Date: Sat, 5 Jun 2021 11:04:20 +0200
Subject: [PATCH 4/8] gnu: qgis: Set #:sh argument of 'wrap-qt-program'.
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

* gnu/packages/geo.scm
(qgis)[arguments]<#:phases>{wrap-qt}:
Set #:sh argument of ‘wrap-qt-program’.
---
gnu/packages/geo.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

Toggle diff (18 lines)
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index c4bdb6aca0..65b763ecbe 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -2224,8 +2224,9 @@ growing set of geoscientific methods.")
(add-after 'install 'wrap-python
(assoc-ref python:%standard-phases 'wrap))
(add-after 'wrap-python 'wrap-qt
- (lambda* (#:key outputs #:allow-other-keys)
- (wrap-qt-program (assoc-ref outputs "out") "qgis")
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (wrap-qt-program (assoc-ref outputs "out") "qgis"
+ #:sh (search-input-file "bin/bash"))
#t))
(add-after 'wrap-qt 'wrap-gis
(lambda* (#:key inputs outputs #:allow-other-keys)
--
2.31.1
From d34d7b0cd464b6abbe7ffa30f8c674a61a14f886 Mon Sep 17 00:00:00 2001
From: Maxime Devos <maximedevos@telenet.be>
Date: Sat, 5 Jun 2021 11:04:20 +0200
Subject: [PATCH 5/8] gnu: keepassxc: Set #:sh argument of 'wrap-qt-program'.
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

* gnu/packages/password-utils.scm
(keepassxc)[arguments]<#:phases>{wrap-qt}:
Set #:sh argument of ‘wrap-qt-program’.
---
gnu/packages/password-utils.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

Toggle diff (18 lines)
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 310253c2a4..2a5a1e5c9f 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -146,8 +146,9 @@ human.")
#:phases
(modify-phases %standard-phases
(add-after 'install 'wrap-qt
- (lambda* (#:key outputs #:allow-other-keys)
- (wrap-qt-program (assoc-ref outputs "out") "keepassxc")
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (wrap-qt-program (assoc-ref outputs "out") "keepassxc"
+ #:sh (search-input-file inputs "bin/bash"))
#t)))))
(native-inputs
`(("asciidoctor" ,ruby-asciidoctor)
--
2.31.1
From 256910012b96e0c7489ac65e7748f4806906c360 Mon Sep 17 00:00:00 2001
From: Maxime Devos <maximedevos@telenet.be>
Date: Sat, 5 Jun 2021 11:04:21 +0200
Subject: [PATCH 6/8] gnu: qtpass: Set #:sh argument of 'wrap-qt-program'.
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

* gnu/packages/password-utils.scm
(qtpass)[arguments]<#:phases>{wrap-qt}:
Set #:sh argument of ‘wrap-qt-program’.
---
gnu/packages/password-utils.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

Toggle diff (18 lines)
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 2a5a1e5c9f..19b1b5623c 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -683,8 +683,9 @@ key URIs using the standard otpauth:// scheme.")
(install-file "qtpass.1" man)
#t)))
(add-after 'install 'wrap-qt
- (lambda* (#:key outputs #:allow-other-keys)
- (wrap-qt-program (assoc-ref outputs "out") "qtpass")
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (wrap-qt-program (assoc-ref outputs "out") "qtpass"
+ #:sh (search-input-file inputs "bin/bash"))
#t))
(add-before 'check 'check-setup
;; Make Qt render "offscreen", required for tests.
--
2.31.1
From 23486d123442d63aac7b54ec0c4d0b4786237762 Mon Sep 17 00:00:00 2001
From: Maxime Devos <maximedevos@telenet.be>
Date: Sat, 5 Jun 2021 11:04:21 +0200
Subject: [PATCH 7/8] gnu: openshot: Set #:sh argument of 'wrap-qt-program'.
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

* gnu/packages/video.scm
(openshot)[arguments]<#:phases>{wrap-program}:
Set #:sh argument of ‘wrap-qt-program’.
---
gnu/packages/video.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

Toggle diff (19 lines)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 4b1d2540e4..250ca944aa 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -4560,9 +4560,10 @@ API. It includes bindings for Python, Ruby, and other languages.")
(setenv "HOME" "/tmp")
#t))
(add-after 'install 'wrap-program
- (lambda* (#:key outputs #:allow-other-keys)
+ (lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
- (wrap-qt-program out "openshot-qt"))
+ (wrap-qt-program out "openshot-qt"
+ #:sh (search-input-file "bin/bash")))
#t)))))
(home-page "https://www.openshot.org/")
(synopsis "Video editor")
--
2.31.1
From 92803cbef5affa3dbbf049262e1fcf290d8d8622 Mon Sep 17 00:00:00 2001
From: Maxime Devos <maximedevos@telenet.be>
Date: Sat, 5 Jun 2021 11:04:21 +0200
Subject: [PATCH 8/8] gnu: kristall: Set #:sh argument of 'wrap-qt-program'.
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

* gnu/packages/web-browsers.scm
(kristall)[arguments]<#:phases>{wrap-program}:
Set #:sh argument of ‘wrap-qt-program’.
---
gnu/packages/web-browsers.scm | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)

Toggle diff (20 lines)
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index af178f9092..3633ff34a8 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -443,9 +443,10 @@ access.")
"/share/fonts/truetype/NotoColorEmoji")))
#t))
(add-after 'install 'wrap-program
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (wrap-qt-program out "kristall"))
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (bash (search-input-file inputs "bin/bash")))
+ (wrap-qt-program out "kristall" #:sh bash))
#t)))))
(native-inputs
`(("breeze-stylesheet"
--
2.31.1
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYLtkuhccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7h9UAPwL/gNHHZiy/jvK9Jpa1FoORrkh
Gsu8NdPnSRO963lwagEAxKk9Hoi1CIdR2B6M1oCWPTGjtUYSFseNzC0RrNnklwc=
=nXH1
-----END PGP SIGNATURE-----


M
M
Maxim Cournoyer wrote on 20 Jan 23:24 +0100
(name . Maxime Devos)(address . maximedevos@telenet.be)(address . 48849@debbugs.gnu.org)
87a5ozd4nh.fsf@gmail.com
Hi Maxime,

Maxime Devos <maximedevos@telenet.be> writes:

Toggle quote (26 lines)
> Hi guix,
>
> This patch series adds a #:sh keyword argument to wrap-qt-program
> and adjusts callers to set this keyword argument appropriately.
>
> Setting this argument appropriately is required for cross-compilation.
> Otherwise, a bash for SYSTEM (as in --system=..) is used instead
> of a bash for TARGET (as in --target=...).
>
> I didn't test building some qt programs with this patch series yet,
> as I'm currently waiting on the substitute servers to catch up
> with recent changed to core-updates (to avoid building a tower
> of rusts). I'll do that later.
>
> Greetings,
> Maxime
>
> From 27d42f25f54b16f382e18b9ef0fb202fb00da90d Mon Sep 17 00:00:00 2001
> From: Maxime Devos <maximedevos@telenet.be>
> Date: Sat, 5 Jun 2021 11:02:16 +0200
> Subject: [PATCH 1/8] qt-utils: Allow overriding the shell interpreter in
> 'wrap-qt-program'.
>
> * guix/build/qt-utils.scm (wrap-qt-program): Introduce a #:sh keyword
> argument and pass it to 'wrap-program'.

If bash-minimal is added to inputs as we do for other packages making
use of wrap-program, we don't need to do more, no? Why do we need to
explicit the argument here?

--
Thanks,
Maxim
M
M
Maxim Cournoyer wrote on 20 Jan 23:24 +0100
control message for bug #48849
(address . control@debbugs.gnu.org)
878r4jd4n9.fsf@gmail.com
tags 48849 + moreinfo
quit
M
RE: bug#48849: [PATCH core-updates]: Add #:sh argument towrap-qt-program
20240121000457.dB4w2B0081cshW701B4xZR@laurent.telenet-ops.be
Toggle quote (10 lines)
>> Subject: [PATCH 1/8] qt-utils: Allow overriding the shell interpreter in
>> 'wrap-qt-program'.
>>
>> * guix/build/qt-utils.scm (wrap-qt-program): Introduce a #:sh keyword
>> argument and pass it to 'wrap-program'.
>
> If bash-minimal is added to inputs as we do for other packages making
> use of wrap-program, we don't need to do more, no? Why do we need to
> explicit the argument here?

Post-hoc reason (for the first patch): wrap-program has #:sh argument, wrap-qt-program doesn’t, which is inconsistent.

For the rest (to be clear I think the remaining patches can be removed):

Right, technically we don’t. The reason is to make sure that it’s the bash from inputs instead of the bash native-inputs. Currently, at first it gets the (wrong) native bash, and later on this is fixed up by the patch-shebangs phase, IIRC.

However, (IIRC) that behaviour is a bug – patch-shebangs is for /usr/bin/… -> /gnu/store/… stuff – if the code “make install” or the like already set a proper /gnu/store/… shebang, why automatically change it to something else? Presumably it set it to the right interpreter, and now patch-shebangs might autocorrupt it.

Another problem: there might not even be a patch-shebangs phase, uses of wrap-program, wrap-qt-program and the phase of the qt-build-system that uses wrap-qt-program (IIRC there exists such a phase) should be usable in isolation. Also, there is a hidden assumption that the uses of wrap-program are _before_ the shebang patching, whereas it might be run afterwards as wll.

Instead, I think it’s better for the uses of ‘wrap-program’ to directly set it to the _right_ bash.
That’s what the #:sh argument is for, but #:sh is set to by default (which “bash”), which is incorrect. Hence, #:sh needs to be set explicitly, and hence wrap-qt-program needs a #:sh argument or the like to pass on to wrap-program.

That said, I don’t think all this explicit #:sh is appropriate either – it would need to be repeated for every single package definition refering to wrap-program, etc.. Instead, for the future, I’d propose to eliminate the argument list of phases, turning phase procedures in phase thunks and stuffing the old arguments in parameter objects instead.

Then, the #:sh of ‘wrap-program’ could default to (search-input-file (inputs) “bin/inputs”) – automatically correct (without needing patch-shebangs) both for native and cross-compilation, and when cross-compiling without “bash” in (implicit) inputs, it automatically errors out (instead of doing the wrong thing as done currently).

The phases would also be a bit less verbose to write – (lambda* (#:key this that #:allow-other-keys) (proc this) stuff …) could become (lambda () (proc) stuff …).

(The ‘procedure’ syntax (inputs) for parameter objects might not be the best here, but that’s nothing some bikeshedding over the precise syntax can’t fix.)

Bst regards,
Maxime Devos

(p.s. I received the mails for the other patches but I’m not responding at the time – not active with Guix currently, and borrowing another computer because of repairs.)
Attachment: file
M
M
Maxim Cournoyer wrote on 22 Jan 05:58 +0100
Re: bug#48849: [PATCH core-updates]: Add #:sh argument to wrap-qt-program
(name . M)(address . maximedevos@telenet.be)(name . 48849@debbugs.gnu.org)(address . 48849@debbugs.gnu.org)
87il3m3qwc.fsf_-_@gmail.com
Hi Maxime,

M <maximedevos@telenet.be> writes:

Toggle quote (13 lines)
>>> Subject: [PATCH 1/8] qt-utils: Allow overriding the shell interpreter in
>>> 'wrap-qt-program'.
>>>
>>> * guix/build/qt-utils.scm (wrap-qt-program): Introduce a #:sh keyword
>>> argument and pass it to 'wrap-program'.
>>
>> If bash-minimal is added to inputs as we do for other packages making
>> use of wrap-program, we don't need to do more, no? Why do we need to
>> explicit the argument here?
>
> Post-hoc reason (for the first patch): wrap-program has #:sh argument,
> wrap-qt-program doesn’t, which is inconsistent.

Good point.

Toggle quote (2 lines)
> For the rest (to be clear I think the remaining patches can be removed):

OK, good.

Toggle quote (5 lines)
> Right, technically we don’t. The reason is to make sure that it’s the
> bash from inputs instead of the bash native-inputs. Currently, at
> first it gets the (wrong) native bash, and later on this is fixed up
> by the patch-shebangs phase, IIRC.

I see.

Toggle quote (6 lines)
> However, (IIRC) that behaviour is a bug – patch-shebangs is for
> /usr/bin/… -> /gnu/store/… stuff – if the code “make install” or the
> like already set a proper /gnu/store/… shebang, why automatically
> change it to something else? Presumably it set it to the right
> interpreter, and now patch-shebangs might autocorrupt it.

Ah! Interesting. I haven't seen any report for such bug.

Toggle quote (34 lines)
> Another problem: there might not even be a patch-shebangs phase, uses
> of wrap-program, wrap-qt-program and the phase of the qt-build-system
> that uses wrap-qt-program (IIRC there exists such a phase) should be
> usable in isolation. Also, there is a hidden assumption that the uses
> of wrap-program are _before_ the shebang patching, whereas it might be
> run afterwards as wll.
>
> Instead, I think it’s better for the uses of ‘wrap-program’ to directly set it to the _right_ bash.
> That’s what the #:sh argument is for, but #:sh is set to by default
> (which “bash”), which is incorrect. Hence, #:sh needs to be set
> explicitly, and hence wrap-qt-program needs a #:sh argument or the
> like to pass on to wrap-program.
>
> That said, I don’t think all this explicit #:sh is appropriate either
> – it would need to be repeated for every single package definition
> refering to wrap-program, etc.. Instead, for the future, I’d propose
> to eliminate the argument list of phases, turning phase procedures in
> phase thunks and stuffing the old arguments in parameter objects
> instead.
>
> Then, the #:sh of ‘wrap-program’ could default to (search-input-file
> (inputs) “bin/inputs”) – automatically correct (without needing
> patch-shebangs) both for native and cross-compilation, and when
> cross-compiling without “bash” in (implicit) inputs, it automatically
> errors out (instead of doing the wrong thing as done currently).
>
> The phases would also be a bit less verbose to write – (lambda* (#:key
> this that #:allow-other-keys) (proc this) stuff …) could become
> (lambda () (proc) stuff …).
>
> (The ‘procedure’ syntax (inputs) for parameter objects might not be
> the best here, but that’s nothing some bikeshedding over the precise
> syntax can’t fix.)

Thanks for sharing your perspective on this. It's an interesting idea
that you are proposing, but it'd entail a massive effort to port the
code base.

Cheers! Enjoy whatever hack you are currently pursuing!

--
Maxim
M
M
Maxim Cournoyer wrote on 22 Jan 06:09 +0100
control message for bug #48849
(address . control@debbugs.gnu.org)
87cytu3qf1.fsf@gmail.com
tags 48849 - moreinfo
quit
M
M
Maxim Cournoyer wrote on 22 Jan 06:12 +0100
Re: bug#48849: [PATCH core-updates]: Add #:sh argument to wrap-qt-program
(name . Maxime Devos)(address . maximedevos@telenet.be)(address . 48849-done@debbugs.gnu.org)
878r4i3q9n.fsf@gmail.com
Hi again,

Maxime Devos <maximedevos@telenet.be> writes:

Toggle quote (26 lines)
> Hi guix,
>
> This patch series adds a #:sh keyword argument to wrap-qt-program
> and adjusts callers to set this keyword argument appropriately.
>
> Setting this argument appropriately is required for cross-compilation.
> Otherwise, a bash for SYSTEM (as in --system=..) is used instead
> of a bash for TARGET (as in --target=...).
>
> I didn't test building some qt programs with this patch series yet,
> as I'm currently waiting on the substitute servers to catch up
> with recent changed to core-updates (to avoid building a tower
> of rusts). I'll do that later.
>
> Greetings,
> Maxime
>
> From 27d42f25f54b16f382e18b9ef0fb202fb00da90d Mon Sep 17 00:00:00 2001
> From: Maxime Devos <maximedevos@telenet.be>
> Date: Sat, 5 Jun 2021 11:02:16 +0200
> Subject: [PATCH 1/8] qt-utils: Allow overriding the shell interpreter in
> 'wrap-qt-program'.
>
> * guix/build/qt-utils.scm (wrap-qt-program): Introduce a #:sh keyword
> argument and pass it to 'wrap-program'.

I see this patch was already merged by Mathieu in
77b98bf1874aac8ed447e9f0b0ee0865a1d652ba; thus, I'm closing this ticket.

Thank you!

--
Maxim
Closed
?