[PATCH] gnu: nginx: Build with support for a few more modules.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 4 years ago
(address . guix-patches@gnu.org)
20210604202904.28218-1-mail@cbaines.net
I think this is generally useful. Personally, I want the HTTP gzip static and
gunzip ones for serving gzip compressed log files, and I spotted that the HTTP
sub and addition ones are easy to enable as well.

* gnu/packages/web.scm (nginx)[arguments]: Add the following configure flags:
--with-http_gzip_static_module, --with-http_gunzip_module,
--with-http_addition_module, --with-http_sub_module.
---
gnu/packages/web.scm | 4 ++++
1 file changed, 4 insertions(+)

Toggle diff (17 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 4753eca8da..15befe7e6d 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -399,6 +399,10 @@ the same, being completely separated from the Internet.")
"--with-http_ssl_module"
"--with-http_v2_module"
"--with-http_xslt_module"
+ "--with-http_gzip_static_module"
+ "--with-http_gunzip_module"
+ "--with-http_addition_module"
+ "--with-http_sub_module"
"--with-pcre-jit"
"--with-debug"
"--with-stream"
--
2.31.1
Ludovic Courtès wrote 4 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 48838@debbugs.gnu.org)
87tum8dqcu.fsf@gnu.org
Hi!

Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (8 lines)
> I think this is generally useful. Personally, I want the HTTP gzip static and
> gunzip ones for serving gzip compressed log files, and I spotted that the HTTP
> sub and addition ones are easy to enable as well.
>
> * gnu/packages/web.scm (nginx)[arguments]: Add the following configure flags:
> --with-http_gzip_static_module, --with-http_gunzip_module,
> --with-http_addition_module, --with-http_sub_module.

LGTM, thanks!

Ludo’.
Christopher Baines wrote 4 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 48838-done@debbugs.gnu.org)
87wnr3sbhl.fsf@cbaines.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (14 lines)
> Hi!
>
> Christopher Baines <mail@cbaines.net> skribis:
>
>> I think this is generally useful. Personally, I want the HTTP gzip static and
>> gunzip ones for serving gzip compressed log files, and I spotted that the HTTP
>> sub and addition ones are easy to enable as well.
>>
>> * gnu/packages/web.scm (nginx)[arguments]: Add the following configure flags:
>> --with-http_gzip_static_module, --with-http_gunzip_module,
>> --with-http_addition_module, --with-http_sub_module.
>
> LGTM, thanks!

Great, pushed as 2d31eeecf06ab14732d374c75cdf6e7a55aa704e.

Thanks for taking a look!
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmDAd9ZfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xfakg/+LZY86L19O1o6C4pseWnlV2UPWzJn9wPw
0nBlr+ClfjFlg6/KcjPoVPoV8oP2o9VhW9oN3yFvDpASBpTQCoLkusW9X5MXeoIG
2G8Bq/GYKL+sR0DKe/lkM73r3p4TfYEYIxHWxwi1w7z2+vRQMVTtxC9mPQeSsXz7
OstE2v3aPt7wj5zH7wh+v7wNHwTX78nFsS5EZ9/eiXmdA1raUYPmXkzYnWlcWkgA
iQIXvF3ggNd8zkZnSeHCKC4nC8V8HUXjUlzqaAIHptjEtcCuef31GD/rceaFNsIy
+iOaRrNj4ww/JnrIgl5MhPKrrrZXvRSk5SAgz8Zm5Yffj/JPda13EIPgcOsptaD6
FmetNzi4IyeSNyzGtNr/u2eHKA5YAuOLHk+GYlQZOvXVJ6WAnPrIgtGCsrPbs1Oq
nyvvbOP2pUTclRz5t12niNhFLrKfcY0gF8s4+EbHMRSQ5IVrM+LQFSPCCjjJ2euR
jejdC1QXCDTc3MugbwwJocHR6cDjyFGuaajmSkAS4ymp2n/WoMR5SjNfPDTAHBvH
/dIU/4qVF8Un+UhKKKb5EVk8l0MAyDHCMfHfxe+NIm9XzPxDvCXxMbjXQ+YrM3zW
dq1VrGNhyhFhz9ykUCSavVOpz3w/uwEzwF+YML/YtO0lpgyVbpK3843wQYy8MrSB
hOySoeCt/f8=
=QPLG
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 48838@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 48838
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help