[PATCH 0/2]: gnu: Add cl-nst

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 4 years ago
(address . guix-patches@gnu.org)
CAO+9K5opRD5SY7=ci4DYGbwPoWs6f=O09OL1C5x5h=e4OVgFAA@mail.gmail.com
Hi Guix team!
I propose to extract all testing frameworks from lisp-xyz to dedicated
module lisp-check the same way as python and haskell have.
lisp-check module is initiated with new package cl-nst, if you are ok
with that split I'll dedicate some time to extract copyright string
for each framework added to lisp-xyz and move related packages to
lisp-check.
Thoughts?
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
Sharlatan Hellseher wrote 4 years ago
[PATCH 1/2]: gnu: Add cl-org-sampler
(address . 48835@debbugs.gnu.org)
CAO+9K5q9QygOS+MAfPv0+vHg2NaZN+NDA87Ym+onMsFVKOG-TQ@mail.gmail.com
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
From d6bd1f9f10ea080be53dd6e469a8c50b49f510c5 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Fri, 4 Jun 2021 20:21:01 +0100
Subject: [PATCH 1/2] gnu: Add cl-org-sampler

* gnu/packages/lisp-xyz.scm: (sbcl-org-sampler, ecl-org-sampler,
cl-org-sampler): New variables
---
gnu/packages/lisp-xyz.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 04954647fc..ccec725b8e 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -17247,3 +17247,34 @@ needed. The low-level command API is fully mapped however.")
(define-public cl-legit
(sbcl-package->cl-source-package sbcl-legit))
+
+(define-public sbcl-org-sampler
+ (let ((commit "ee135a417750e5b1d810bb9574eb85223cb3038a")
+ (revision "1"))
+ (package
+ (name "sbcl-org-sampler")
+ (version (git-version "0.2.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jphmrst/cl-org-sampler")
+ (commit commit)))
+ (file-name (git-file-name "org-sampler" version))
+ (sha256
+ (base32 "1dg029in14928qfxvfshyxmdwhzskzhxx3na0zy98ybx69b21qla"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("iterate" ,sbcl-iterate)))
+ (home-page "https://github.com/jphmrst/cl-org-sampler")
+ (synopsis "Extracting Common Lisp docstrings as Emacs Org-mode documents")
+ (description
+ "ORG-SAMPLER allows to use Lisp docstrings and reflection to make org-mode
+text for inclusion into a larger document.")
+ (license license:llgpl))))
+
+(define-public ecl-org-sampler
+ (sbcl-package->ecl-package sbcl-org-sampler))
+
+(define-public cl-org-sampler
+ (sbcl-package->cl-source-package sbcl-org-sampler))
--
2.31.1
Sharlatan Hellseher wrote 4 years ago
[PATCH 2/2]: gnu: Add cl-nst
(address . 48835@debbugs.gnu.org)
CAO+9K5owKPh_pTiyxy+iMqsRf6Jpm9hTNQWr_eFGVUVLFV6hyg@mail.gmail.com
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
From 8a1278b97669c08ed6cf5dd9c6bb2a5a490f246d Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Fri, 4 Jun 2021 20:26:48 +0100
Subject: [PATCH 2/2] gnu: Add cl-nst

Initiate new file the same way as other language spcific
ones (python-check, haskell-check)

* gnu/packages/lisp-check.scm: (sbcl-nst, ecl-nst, cl-nst): New variables
[lisp-check]: new module

* gnu/local.mk: add lisp-check.scm to build list
---
gnu/local.mk | 2 ++
gnu/packages/lisp-check.scm | 63 +++++++++++++++++++++++++++++++++++++
2 files changed, 65 insertions(+)
create mode 100644 gnu/packages/lisp-check.scm

Toggle diff (91 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 8c235f50c8..3c05ece58a 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -42,6 +42,7 @@
# Copyright © 2021 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
# Copyright © 2021 Philip McGrath <philip@philipmcgrath.com>
# Copyright © 2021 Arun Isaac <arunisaac@systemreboot.net>
+# Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
#
# This file is part of GNU Guix.
#
@@ -350,6 +351,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/linux.scm \
%D%/packages/lirc.scm \
%D%/packages/lisp.scm \
+ %D%/packages/lisp-check.scm \
%D%/packages/lisp-xyz.scm \
%D%/packages/llvm.scm \
%D%/packages/lout.scm \
diff --git a/gnu/packages/lisp-check.scm b/gnu/packages/lisp-check.scm
new file mode 100644
index 0000000000..dcf80207a9
--- /dev/null
+++ b/gnu/packages/lisp-check.scm
@@ -0,0 +1,63 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages lisp-check)
+ #:use-module (gnu packages)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (gnu packages lisp-xyz)
+ #:use-module (guix packages)
+ #:use-module (guix git-download)
+ #:use-module (guix build-system asdf))
+
+;;; Commentary:
+;;;
+;;; This module only contains Common Lisp libraries related to code testing
+;;; facilities.
+
+(define-public sbcl-nst
+ (let ((commit "6c0990f594abcf5887e8d80f1035e3b60454b61b")
+ (revision "1"))
+ (package
+ (name "sbcl-nst")
+ (version (git-version "4.1.2" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jphmrst/cl-nst")
+ (commit commit)))
+ (file-name (git-file-name "nst" version))
+ (sha256
+ (base32 "1hf3r6pqbnd9vsd1i24qmz928kia72hdgmiafiwb6jw1hmj3r6ga"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("closer-mop" ,sbcl-closer-mop)
+ ("org-sampler" ,sbcl-org-sampler)))
+ (home-page "https://github.com/jphmrst/cl-nst")
+ (synopsis "Unit testing for Common Lisp")
+ (description
+ "NST is unit/regression testing system for Common Lisp.")
+ (license license:llgpl))))
+
+(define-public ecl-nst
+ (sbcl-package->ecl-package sbcl-nst))
+
+(define-public cl-nst
+ (sbcl-package->cl-source-package sbcl-nst))
+
+;;; lisp-check.scm ends here
--
2.31.1
Guillaume Le Vaillant wrote 4 years ago
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 48835-done@debbugs.gnu.org)
87k0mjmotj.fsf@kitej
Patches pushed as e101a117eb5af9affcf68e27e91d68d3bfd72986 and
following.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYNR52A8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j9AvAEAlloNE278T5IiUj/TRSY6vbNP8r4TJz1WDlqA
hsI5TbEBAJ4bqnsqL8eTEm7HCPdppyF42ONS9iGq+e0aC4JXn2wu
=/CMl
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 48835@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 48835
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help