[PATCH 0/7] gnu: calibre: Update to 5.20.0.

  • Done
  • quality assurance status badge
Details
One participant
  • Brendan Tildesley
Owner
unassigned
Submitted by
Brendan Tildesley
Severity
normal
B
B
Brendan Tildesley wrote on 4 Jun 2021 13:30
(address . guix-patches@gnu.org)
20210604113007.19166-1-mail@brendan.scot
Calibre update, plus some dependency updates without too many dependants.
B
B
Brendan Tildesley wrote on 4 Jun 2021 13:30
[PATCH 1/7] gnu: calibre: Remove unused input python-dukpy.
(address . guix-patches@gnu.org)
20210604113007.19166-2-mail@brendan.scot
* gnu/packages/ebook.scm (calibre): Remove unused input python-dukpy.
---
gnu/packages/ebook.scm | 1 -
1 file changed, 1 deletion(-)

Toggle diff (14 lines)
diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index 3a779a4fea..65d231c4b5 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -174,7 +174,6 @@ with Microsoft Compiled HTML (CHM) files")
("python-dateutil" ,python-dateutil)
("python-dbus" ,python-dbus)
("python-dnspython" ,python-dnspython-1.16)
- ("python-dukpy" ,python-dukpy)
("python-feedparser" ,python-feedparser)
("python-html2text" ,python-html2text)
("python-html5-parser" ,python-html5-parser)
--
2.31.1
B
B
Brendan Tildesley wrote on 4 Jun 2021 13:30
[PATCH 2/7] gnu: Remove python-dukpy, python2-dukpy.
(address . guix-patches@gnu.org)
20210604113007.19166-3-mail@brendan.scot
* gnu/packages/python-xyz.scm: Remove unused packages python-dukpy,
python2-dukpy.
This is actually not the 'dukpy' package in pypi either but something
else made for calibre.
---
gnu/packages/python-xyz.scm | 26 --------------------------
1 file changed, 26 deletions(-)

Toggle diff (39 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b3ed73f04a..0c909b9a90 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18883,32 +18883,6 @@ executed more than a given number of times during a given period.")
(define-public python2-ratelimiter
(package-with-python2 python-ratelimiter))
-(define-public python-dukpy
- (package
- (name "python-dukpy")
- (version "0.3")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/kovidgoyal/dukpy")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "13h21nqzasv4zj32xs61brmc106pr2cx243672crcmwxxnjgaxls"))))
- (build-system python-build-system)
- (home-page "https://github.com/kovidgoyal/dukpy")
- (synopsis "Run JavaScript in python")
- (description
- "dukpy is a JavaScript runtime environment for Python using the duktape
-embeddable JavaScript engine.")
- ;; Dukpy is licensed under MIT like the embedded duktape library,
- ;; with 'errors.c' as GPL3.
- (license (list license:expat license:gpl3))))
-
-(define-public python2-dukpy
- (package-with-python2 python-dukpy))
-
(define-public python-jsonrpclib-pelix
(package
(name "python-jsonrpclib-pelix")
--
2.31.1
B
B
Brendan Tildesley wrote on 4 Jun 2021 13:30
[PATCH 5/7] gnu: python-regex: Update to 2021.4.4.
(address . guix-patches@gnu.org)
20210604113007.19166-6-mail@brendan.scot
* gnu/packages/python-xyz.scm (python-regex): Update to 2021.4.4.
---
gnu/packages/python-xyz.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b036fe2904..059f4c31c9 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18447,13 +18447,13 @@ window memory map manager.")
(define-public python-regex
(package
(name "python-regex")
- (version "2020.6.8")
+ (version "2021.4.4")
(source (origin
(method url-fetch)
(uri (pypi-uri "regex" version))
(sha256
(base32
- "1b3k0zi1pd99q5mk7ri7vcx2y1mq5inm9hk8dryqyhrpkmh4xdp9"))))
+ "1yws1kqvw4krmdi519iry5jl1i2ihnr5n45wwkbljb4lkczkvfjj"))))
(build-system python-build-system)
(arguments
'(#:phases
--
2.31.1
B
B
Brendan Tildesley wrote on 4 Jun 2021 13:30
[PATCH 4/7] gnu: python-zeroconf: Update to 0.31.0.
(address . guix-patches@gnu.org)
20210604113007.19166-5-mail@brendan.scot
* gnu/packages/python-xyz.scm (python-zeroconf): Update to 0.31.0.
[native-inputs]: Add python-pytest.
[arguments]: Disable more networking tests that won't work in Guix.
---
gnu/packages/python-xyz.scm | 11 +++++++----
1 file changed, 7 insertions(+), 4 deletions(-)

Toggle diff (39 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0c909b9a90..b036fe2904 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -22030,17 +22030,18 @@ enumeration library in Python.")
(define-public python-zeroconf
(package
(name "python-zeroconf")
- (version "0.28.8")
+ (version "0.31.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "zeroconf" version))
(sha256
(base32
- "0narq8haa3b375vfblbyil77n8bw0wxqnanl91pl0wwwm884mqjb"))))
+ "0i4qs6baj7mc468mr40hmy77sgfr7vhbrz7zs4dziikihhj818ak"))))
(build-system python-build-system)
(native-inputs
- `(("python-nose" ,python-nose)))
+ `(("python-nose" ,python-nose)
+ ("python-pytest" ,python-pytest)))
(propagated-inputs
`(("python-ifaddr" ,python-ifaddr)))
(arguments
@@ -22052,7 +22053,9 @@ enumeration library in Python.")
"--exclude" "test_integration_with_listener_ipv6"
"--exclude" "test_launch_and_close_v6_only"
"--exclude" "test_launch_and_close_v4_v6"
- "--exclude" "test_launch_and_close"))))))
+ "--exclude" "test_launch_and_close"
+ "--exclude" "test_close_multiple_times"
+ "--exclude" "test_add_multicast_member_socket_errors"))))))
(home-page "https://github.com/jstasiak/python-zeroconf")
(synopsis "Pure Python mDNS service discovery")
(description
--
2.31.1
B
B
Brendan Tildesley wrote on 4 Jun 2021 13:30
[PATCH 7/7] gnu: python-msgpack: Update to 1.0.2.
(address . guix-patches@gnu.org)
20210604113007.19166-8-mail@brendan.scot
* gnu/packages/python-xyz.scm (python-msgpack): Update to 1.0.2.
---
gnu/packages/python-xyz.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 059f4c31c9..9632f83fed 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9849,13 +9849,13 @@ third-party code.")
(define-public python-msgpack
(package
(name "python-msgpack")
- (version "1.0.0")
+ (version "1.0.2")
(source (origin
(method url-fetch)
(uri (pypi-uri "msgpack" version))
(sha256
(base32
- "1h5mxh84rcw04dvxy1qbfn2hisavfqgilh9k09rgyjhd936dad4m"))))
+ "1109s2yynrahwi64ikax68hx0mbclz8p35afmpphw5dwynb49q7s"))))
(build-system python-build-system)
(arguments
`(#:modules ((guix build utils)
--
2.31.1
B
B
Brendan Tildesley wrote on 4 Jun 2021 13:30
[PATCH 6/7] gnu: python-pycryptodome: Update to 3.10.1.
(address . guix-patches@gnu.org)
20210604113007.19166-7-mail@brendan.scot
* gnu/packages/python-crypto.scm (python-pycryptodome): Update to 3.10.1.
---
gnu/packages/python-crypto.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 733a87cd2f..8170c3c794 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -992,14 +992,14 @@ protocol (Javascript Object Signing and Encryption).")
(define-public python-pycryptodome
(package
(name "python-pycryptodome")
- (version "3.9.9")
+ (version "3.10.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pycryptodome" version))
(sha256
(base32
- "1i4m74f88qj9ci8rpyzrbk2slmsdj5ipmwdkq6qk24byalm203li"))))
+ "0ws6ivk5v6bs57ak8hwjyjf0jqcdl87bkka3z06ijpqcb033lbiy"))))
(build-system python-build-system)
(home-page "https://www.pycryptodome.org")
(synopsis "Low-level cryptographic Python library")
--
2.31.1
B
B
Brendan Tildesley wrote on 4 Jun 2021 13:46
[PATCH 1/7] gnu: calibre: Remove unused input python-dukpy.
(address . 48831@debbugs.gnu.org)
20210604114640.25535-2-mail@brendan.scot
* gnu/packages/ebook.scm (calibre): Remove unused input python-dukpy.
---
gnu/packages/ebook.scm | 1 -
1 file changed, 1 deletion(-)

Toggle diff (14 lines)
diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index 3a779a4fea..65d231c4b5 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -174,7 +174,6 @@ with Microsoft Compiled HTML (CHM) files")
("python-dateutil" ,python-dateutil)
("python-dbus" ,python-dbus)
("python-dnspython" ,python-dnspython-1.16)
- ("python-dukpy" ,python-dukpy)
("python-feedparser" ,python-feedparser)
("python-html2text" ,python-html2text)
("python-html5-parser" ,python-html5-parser)
--
2.31.1
B
B
Brendan Tildesley wrote on 4 Jun 2021 13:46
Resending patches.
(address . 48831@debbugs.gnu.org)
20210604114640.25535-1-mail@brendan.scot
I messed up the last git send-email command and the patches went flying everywhere.
They should all come after this now.
B
B
Brendan Tildesley wrote on 4 Jun 2021 13:46
[PATCH 2/7] gnu: Remove python-dukpy, python2-dukpy.
(address . 48831@debbugs.gnu.org)
20210604114640.25535-3-mail@brendan.scot
* gnu/packages/python-xyz.scm: Remove unused packages python-dukpy,
python2-dukpy.
This is actually not the 'dukpy' package in pypi either but something
else made for calibre.
---
gnu/packages/python-xyz.scm | 26 --------------------------
1 file changed, 26 deletions(-)

Toggle diff (39 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b3ed73f04a..0c909b9a90 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18883,32 +18883,6 @@ executed more than a given number of times during a given period.")
(define-public python2-ratelimiter
(package-with-python2 python-ratelimiter))
-(define-public python-dukpy
- (package
- (name "python-dukpy")
- (version "0.3")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/kovidgoyal/dukpy")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "13h21nqzasv4zj32xs61brmc106pr2cx243672crcmwxxnjgaxls"))))
- (build-system python-build-system)
- (home-page "https://github.com/kovidgoyal/dukpy")
- (synopsis "Run JavaScript in python")
- (description
- "dukpy is a JavaScript runtime environment for Python using the duktape
-embeddable JavaScript engine.")
- ;; Dukpy is licensed under MIT like the embedded duktape library,
- ;; with 'errors.c' as GPL3.
- (license (list license:expat license:gpl3))))
-
-(define-public python2-dukpy
- (package-with-python2 python-dukpy))
-
(define-public python-jsonrpclib-pelix
(package
(name "python-jsonrpclib-pelix")
--
2.31.1
B
B
Brendan Tildesley wrote on 4 Jun 2021 13:46
[PATCH 3/7] gnu: calibre: Update to 5.20.0.
(address . 48831@debbugs.gnu.org)
20210604114640.25535-4-mail@brendan.scot
* gnu/packages/ebook.scm (calibre): Update to 5.20.0.
---
gnu/packages/ebook.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index 65d231c4b5..66b91873b6 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -115,7 +115,7 @@ with Microsoft Compiled HTML (CHM) files")
(define-public calibre
(package
(name "calibre")
- (version "5.14.0")
+ (version "5.20.0")
(source
(origin
(method url-fetch)
@@ -124,7 +124,7 @@ with Microsoft Compiled HTML (CHM) files")
version ".tar.xz"))
(sha256
(base32
- "0w8j9r9qa56r8gm9b10dwh8zrzqlv79s2br82jqg02lrnrbwwv0q"))
+ "0njlbq3715ryd0k8ms0s4cbp9yz2jyf9chsycsj4wfrkr3xs54mn"))
(modules '((guix build utils)))
(snippet
'(begin
--
2.31.1
B
B
Brendan Tildesley wrote on 4 Jun 2021 13:46
[PATCH 4/7] gnu: python-zeroconf: Update to 0.31.0.
(address . 48831@debbugs.gnu.org)
20210604114640.25535-5-mail@brendan.scot
* gnu/packages/python-xyz.scm (python-zeroconf): Update to 0.31.0.
[native-inputs]: Add python-pytest.
[arguments]: Disable more networking tests that won't work in Guix.
---
gnu/packages/python-xyz.scm | 11 +++++++----
1 file changed, 7 insertions(+), 4 deletions(-)

Toggle diff (39 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0c909b9a90..b036fe2904 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -22030,17 +22030,18 @@ enumeration library in Python.")
(define-public python-zeroconf
(package
(name "python-zeroconf")
- (version "0.28.8")
+ (version "0.31.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "zeroconf" version))
(sha256
(base32
- "0narq8haa3b375vfblbyil77n8bw0wxqnanl91pl0wwwm884mqjb"))))
+ "0i4qs6baj7mc468mr40hmy77sgfr7vhbrz7zs4dziikihhj818ak"))))
(build-system python-build-system)
(native-inputs
- `(("python-nose" ,python-nose)))
+ `(("python-nose" ,python-nose)
+ ("python-pytest" ,python-pytest)))
(propagated-inputs
`(("python-ifaddr" ,python-ifaddr)))
(arguments
@@ -22052,7 +22053,9 @@ enumeration library in Python.")
"--exclude" "test_integration_with_listener_ipv6"
"--exclude" "test_launch_and_close_v6_only"
"--exclude" "test_launch_and_close_v4_v6"
- "--exclude" "test_launch_and_close"))))))
+ "--exclude" "test_launch_and_close"
+ "--exclude" "test_close_multiple_times"
+ "--exclude" "test_add_multicast_member_socket_errors"))))))
(home-page "https://github.com/jstasiak/python-zeroconf")
(synopsis "Pure Python mDNS service discovery")
(description
--
2.31.1
B
B
Brendan Tildesley wrote on 4 Jun 2021 13:46
[PATCH 5/7] gnu: python-regex: Update to 2021.4.4.
(address . 48831@debbugs.gnu.org)
20210604114640.25535-6-mail@brendan.scot
* gnu/packages/python-xyz.scm (python-regex): Update to 2021.4.4.
---
gnu/packages/python-xyz.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b036fe2904..059f4c31c9 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18447,13 +18447,13 @@ window memory map manager.")
(define-public python-regex
(package
(name "python-regex")
- (version "2020.6.8")
+ (version "2021.4.4")
(source (origin
(method url-fetch)
(uri (pypi-uri "regex" version))
(sha256
(base32
- "1b3k0zi1pd99q5mk7ri7vcx2y1mq5inm9hk8dryqyhrpkmh4xdp9"))))
+ "1yws1kqvw4krmdi519iry5jl1i2ihnr5n45wwkbljb4lkczkvfjj"))))
(build-system python-build-system)
(arguments
'(#:phases
--
2.31.1
B
B
Brendan Tildesley wrote on 4 Jun 2021 13:46
[PATCH 7/7] gnu: python-msgpack: Update to 1.0.2.
(address . 48831@debbugs.gnu.org)
20210604114640.25535-8-mail@brendan.scot
* gnu/packages/python-xyz.scm (python-msgpack): Update to 1.0.2.
---
gnu/packages/python-xyz.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 059f4c31c9..9632f83fed 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9849,13 +9849,13 @@ third-party code.")
(define-public python-msgpack
(package
(name "python-msgpack")
- (version "1.0.0")
+ (version "1.0.2")
(source (origin
(method url-fetch)
(uri (pypi-uri "msgpack" version))
(sha256
(base32
- "1h5mxh84rcw04dvxy1qbfn2hisavfqgilh9k09rgyjhd936dad4m"))))
+ "1109s2yynrahwi64ikax68hx0mbclz8p35afmpphw5dwynb49q7s"))))
(build-system python-build-system)
(arguments
`(#:modules ((guix build utils)
--
2.31.1
B
B
Brendan Tildesley wrote on 4 Jun 2021 13:46
[PATCH 6/7] gnu: python-pycryptodome: Update to 3.10.1.
(address . 48831@debbugs.gnu.org)
20210604114640.25535-7-mail@brendan.scot
* gnu/packages/python-crypto.scm (python-pycryptodome): Update to 3.10.1.
---
gnu/packages/python-crypto.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 733a87cd2f..8170c3c794 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -992,14 +992,14 @@ protocol (Javascript Object Signing and Encryption).")
(define-public python-pycryptodome
(package
(name "python-pycryptodome")
- (version "3.9.9")
+ (version "3.10.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pycryptodome" version))
(sha256
(base32
- "1i4m74f88qj9ci8rpyzrbk2slmsdj5ipmwdkq6qk24byalm203li"))))
+ "0ws6ivk5v6bs57ak8hwjyjf0jqcdl87bkka3z06ijpqcb033lbiy"))))
(build-system python-build-system)
(home-page "https://www.pycryptodome.org")
(synopsis "Low-level cryptographic Python library")
--
2.31.1
B
B
Brendan Tildesley wrote on 4 Jun 2021 13:48
Closing: sent by mistake
(name . 48831-close@debbugs.gnu.org)(address . 48831-close@debbugs.gnu.org)
2110295150.10510.1622807322979@office.mailbox.org
I messed up the git send-email command somehow only the *third* patch ended up as it's own bug report. Fascinating.
B
B
Brendan Tildesley wrote on 7 Feb 2022 03:02
[PATCH 0/7] gnu: calibre: Update to 5.20.0.
(name . 48831-close@debbugs.gnu.org)(address . 48831-close@debbugs.gnu.org)
670178602.259679.1644199323701@office.mailbox.org
Stale patches. I'll make a new bug for the latest calibre.
?