Toggle diff (246 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 6a1e459e4e..0016ac12af 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1375,6 +1375,8 @@ dist_patch_DATA = \
%D%/packages/patches/lierolibre-newer-libconfig.patch \
%D%/packages/patches/lierolibre-remove-arch-warning.patch \
%D%/packages/patches/lierolibre-try-building-other-arch.patch \
+ %D%/packages/patches/lightgbm-python-use-system-lib-lightgbm.patch \
+ %D%/packages/patches/lightgbm-use-system-libraries.patch \
%D%/packages/patches/linbox-fix-pkgconfig.patch \
%D%/packages/patches/linkchecker-tests-require-network.patch \
%D%/packages/patches/linphone-desktop-without-sdk.patch \
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index ead47a534a..1a3f647dde 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -56,6 +56,7 @@
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages cmake)
+ #:use-module (gnu packages cpp)
#:use-module (gnu packages cran)
#:use-module (gnu packages databases)
#:use-module (gnu packages dejagnu)
@@ -70,8 +71,10 @@
#:use-module (gnu packages mpi)
#:use-module (gnu packages ocaml)
#:use-module (gnu packages onc-rpc)
+ #:use-module (gnu packages opencl)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages pretty-print)
#:use-module (gnu packages protobuf)
#:use-module (gnu packages python)
#:use-module (gnu packages python-build)
@@ -1058,33 +1061,39 @@ main intended application of Autograd is gradient-based optimization.")
(define-public lightgbm
(package
(name "lightgbm")
- (version "2.0.12")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/Microsoft/LightGBM")
- (commit (string-append "v" version))))
- (sha256
- (base32
- "0jlvyn7k81dzrh9ij3zw576wbgiwmmr26rzpdxjn1dbpc3njpvzi"))
- (file-name (git-file-name name version))))
+ (version "3.2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Microsoft/LightGBM")
+ (commit (string-append "v" version))))
+ (patches
+ (search-patches "lightgbm-use-system-libraries.patch"
+ "lightgbm-python-use-system-lib-lightgbm.patch"))
+ (sha256
+ (base32 "1fchiiwl3pz1kpi0kbfanif6c6b688wmmjjbqz4ff4djc6g2sg7z"))
+ (file-name (git-file-name name version))))
(native-inputs
- `(("python-pytest" ,python-pytest)
- ("python-nose" ,python-nose)))
+ `(("googletest" ,googletest)
+ ("opencl-headers" ,opencl-headers)))
(inputs
- `(("openmpi" ,openmpi)))
- (propagated-inputs
- `(("python-numpy" ,python-numpy)
- ("python-scipy" ,python-scipy)))
+ `(("boost" ,boost)
+ ("eigen" ,eigen)
+ ("fast-double-parser" ,fast-double-parser)
+ ("fmt" ,fmt)
+ ("ocl-icd" ,ocl-icd)
+ ("openmpi" ,openmpi)))
(arguments
- `(#:configure-flags
- '("-DUSE_MPI=ON")
- #:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda _
- (with-directory-excursion "../source"
- (invoke "pytest" "tests/c_api_test/test_.py")))))))
+ `(;; FIXME: With 'find_package(GTest CONFIG)' (default), googletest
+ ;; is not found by CMake. If we replace CONFIG with REQUIRED, the
+ ;; test files fail to link with googletest in the build phase.
+ #:tests? #f
+ #:test-target "testlightgbm"
+ #:configure-flags
+ (list "-DBUILD_CPP_TEST=OFF"
+ "-DUSE_GPU=ON" ;using OpenCL
+ "-DUSE_MPI=ON")))
(build-system cmake-build-system)
(home-page "https://github.com/Microsoft/LightGBM")
(synopsis "Gradient boosting framework based on decision tree algorithms")
diff --git a/gnu/packages/patches/lightgbm-python-use-system-lib-lightgbm.patch b/gnu/packages/patches/lightgbm-python-use-system-lib-lightgbm.patch
new file mode 100644
index 0000000000..69cb721daa
--- /dev/null
+++ b/gnu/packages/patches/lightgbm-python-use-system-lib-lightgbm.patch
@@ -0,0 +1,74 @@
+From c73be84d8ec6ac71dfdaa71b7943ae344f5d7cde Mon Sep 17 00:00:00 2001
+From: Vinicius Monego <monego@posteo.net>
+Date: Tue, 1 Jun 2021 00:24:38 -0300
+Subject: [PATCH] Use system lib_lightgbm.
+
+---
+ python-package/lightgbm/libpath.py | 4 ++++
+ python-package/setup.py | 12 ++++++++----
+ 2 files changed, 12 insertions(+), 4 deletions(-)
+
+diff --git a/python-package/lightgbm/libpath.py b/python-package/lightgbm/libpath.py
+index 6533792..27af2b9 100644
+--- a/python-package/lightgbm/libpath.py
++++ b/python-package/lightgbm/libpath.py
+@@ -17,8 +17,12 @@ def find_lib_path() -> List[str]:
+ # we don't need lib_lightgbm while building docs
+ return []
+
++ # This variable will be set during substitution.
++ lib_lightgbm_path = ''
++
+ curr_path = os.path.dirname(os.path.abspath(os.path.expanduser(__file__)))
+ dll_path = [curr_path,
++ lib_lightgbm_path,
+ os.path.join(curr_path, '../../'),
+ os.path.join(curr_path, 'compile'),
+ os.path.join(curr_path, '../compile'),
+diff --git a/python-package/setup.py b/python-package/setup.py
+index ee98b1a..2f7ce38 100644
+--- a/python-package/setup.py
++++ b/python-package/setup.py
+@@ -231,7 +231,7 @@ class CustomInstall(install):
+ self.opencl_library = None
+ self.mpi = 0
+ self.hdfs = 0
+- self.precompile = 0
++ self.precompile = 1
+ self.nomp = 0
+ self.bit32 = 0
+
+@@ -274,7 +274,7 @@ class CustomBdistWheel(bdist_wheel):
+ self.opencl_library = None
+ self.mpi = 0
+ self.hdfs = 0
+- self.precompile = 0
++ self.precompile = 1
+ self.nomp = 0
+ self.bit32 = 0
+
+@@ -324,7 +324,10 @@ if __name__ == "__main__":
+ copy_file(os.path.join(CURRENT_DIR, os.path.pardir, 'VERSION.txt'),
+ os.path.join(CURRENT_DIR, 'lightgbm', 'VERSION.txt'),
+ verbose=0) # type:ignore
+- version = open(os.path.join(CURRENT_DIR, 'lightgbm', 'VERSION.txt'), encoding='utf-8').read().strip()
++
++ # This variable will be set during substitution.
++ version = ''
++
+ readme = open(os.path.join(CURRENT_DIR, 'README.rst'), encoding='utf-8').read()
+
+ sys.path.insert(0, CURRENT_DIR)
+@@ -355,7 +358,8 @@ if __name__ == "__main__":
+ zip_safe=False,
+ cmdclass={
+ 'install': CustomInstall,
+- 'install_lib': CustomInstallLib,
++ # Lib will be loaded from the lightgbm package.
++ # 'install_lib': CustomInstallLib,
+ 'bdist_wheel': CustomBdistWheel,
+ 'sdist': CustomSdist,
+ },
+--
+2.31.1
+
diff --git a/gnu/packages/patches/lightgbm-use-system-libraries.patch b/gnu/packages/patches/lightgbm-use-system-libraries.patch
new file mode 100644
index 0000000000..115ca02775
--- /dev/null
+++ b/gnu/packages/patches/lightgbm-use-system-libraries.patch
@@ -0,0 +1,58 @@
+From 894648291b9629d51785e4fd1cae820d2858e039 Mon Sep 17 00:00:00 2001
+From: Vinicius Monego <monego@posteo.net>
+Date: Mon, 31 May 2021 21:23:52 -0300
+Subject: [PATCH] Use system libraries.
+
+---
+ CMakeLists.txt | 11 ++++++++---
+ include/LightGBM/utils/common.h | 4 ++--
+ 2 files changed, 10 insertions(+), 5 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index b845f36..560e477 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -93,9 +93,6 @@ if(USE_SWIG)
+ endif()
+ endif(USE_SWIG)
+
+-SET(EIGEN_DIR "${PROJECT_SOURCE_DIR}/external_libs/eigen")
+-include_directories(${EIGEN_DIR})
+-
+ # See https://gitlab.com/libeigen/eigen/-/blob/master/COPYING.README
+ ADD_DEFINITIONS(-DEIGEN_MPL2_ONLY)
+
+@@ -399,6 +396,14 @@ if(USE_SWIG)
+ endif()
+ endif(USE_SWIG)
+
++find_package (Eigen3 3.3 REQUIRED NO_MODULE)
++TARGET_LINK_LIBRARIES (lightgbm Eigen3::Eigen)
++TARGET_LINK_LIBRARIES (_lightgbm Eigen3::Eigen)
++
++find_package(fmt)
++TARGET_LINK_LIBRARIES(lightgbm fmt::fmt)
++TARGET_LINK_LIBRARIES(_lightgbm fmt::fmt)
++
+ if(USE_MPI)
+ TARGET_LINK_LIBRARIES(lightgbm ${MPI_CXX_LIBRARIES})
+ TARGET_LINK_LIBRARIES(_lightgbm ${MPI_CXX_LIBRARIES})
+diff --git a/include/LightGBM/utils/common.h b/include/LightGBM/utils/common.h
+index 4357357..00101a5 100644
+--- a/include/LightGBM/utils/common.h
++++ b/include/LightGBM/utils/common.h
+@@ -32,9 +32,9 @@
+
+ #if (!((defined(sun) || defined(__sun)) && (defined(__SVR4) || defined(__svr4__))))
+ #define FMT_HEADER_ONLY
+-#include "../../../external_libs/fmt/include/fmt/format.h"
++#include "fmt/format.h"
+ #endif
+-#include "../../../external_libs/fast_double_parser/include/fast_double_parser.h"
++#include "fast_double_parser.h"
+
+ #ifdef _MSC_VER
+ #include <intrin.h>
+--
+2.31.1
+
--
2.31.1