[PATCH] gnu: Add libdqlite.

  • Done
  • quality assurance status badge
Details
2 participants
  • Dion Mendel
  • Ludovic Courtès
Owner
unassigned
Submitted by
Dion Mendel
Severity
normal

Debbugs page

Dion Mendel wrote 4 years ago
(address . guix-patches@gnu.org)
20210601060323.GA27513@dm9.info
* gnu/packages/cluster.scm (libdqlite): New Variable.
---
gnu/packages/cluster.scm | 41 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (65 lines)
diff --git a/gnu/packages/cluster.scm b/gnu/packages/cluster.scm
index 18f2707469..8421af5140 100644
--- a/gnu/packages/cluster.scm
+++ b/gnu/packages/cluster.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Andrew Miloradovsky <andrew@interpretmath.pw>
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
+;;; Copyright © 2021 Dion Mendel <guix@dm9.info>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -33,6 +34,7 @@
#:use-module (gnu packages linux)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages sphinx)
+ #:use-module (gnu packages sqlite)
#:use-module (gnu packages texinfo)
#:use-module (gnu packages tls))
@@ -220,3 +222,42 @@ that, a pluggable interface defines the I/O implementation for networking
(send/receive RPC messages) and disk persistence (store log entries and
snapshots).")
(license license:asl2.0)))
+
+(define-public libdqlite
+ (package
+ (name "libdqlite")
+ (version "1.7.0")
+ (home-page "https://github.com/canonical/dqlite")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "15cg8yl3n7lcg0qyg0byciz8v6y200ghmzzkwpdzggy3m6c168wl"))))
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'disable-failing-tests
+ (lambda _
+ (substitute* "Makefile.am"
+ ;; Test client/query sometimes fails.
+ ;; The actual tested asserts succeed, but there appears to be a
+ ;; race condition when tearing down the test server.
+ ((".*test_client.c.*") "")))))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libraft" ,libraft)
+ ("libuv" ,libuv)))
+ (propagated-inputs
+ `(("sqlite" ,sqlite))) ; dqlite.h includes sqlite3.h
+ (build-system gnu-build-system)
+ (synopsis "Distributed SQLite")
+ (description "dqlite is a C library that implements an embeddable and replicated
+SQL database engine with high-availability and automatic failover.")
+ (license license:lgpl3+)))
--
2.31.1
Ludovic Courtès wrote 4 years ago
(name . Dion Mendel)(address . guix@dm9.info)(address . 48773-done@debbugs.gnu.org)
87wnr8knkv.fsf@gnu.org
Dion Mendel <guix@dm9.info> skribis:

Toggle quote (2 lines)
> * gnu/packages/cluster.scm (libdqlite): New Variable.

[...]

Toggle quote (2 lines)
> + (license license:lgpl3+)))

Changed to ‘lgpl3’ because ‘LICENSE’ explicitly says “version 3”
(without “or later”).

Thanks,
Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 48773@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 48773
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help