(address . bug-guix@gnu.org)
I have attempted to install 1.3.0 from the iso, but the "guided"
install encounters an error after partitioning; which if I read
correctly, indicates swap cannot be created.
This happens when I use _any_ partitioning scheme, manual or
automatic.
The command 'mkswap -f /dev/sda3' executes correctly from the shell
session on tty3 from the installer.
Sadly, this is also fatal and the installation cannot continue, so
I'm a bit surprized no one has reported this - as I can recreate
this situation reliably every time I attempt it. (Maybe I just am
blind and cannot find the bug report at the guix bug tracker, if
so, my apologies for the duplicate.)
Error file attached.
---
In ice-9/ports.scm:
478:4 19 (with-error-to-port _ _)
In guix/build/utils.scm:
654:6 18 (invoke _ . _)
In ice-9/boot-9.scm:
1669:16 17 (raise-exception _ #:continuable? _)
1667:16 16 (raise-exception _ #:continuable? _)
1667:16 15 (raise-exception _ #:continuable? _)
1667:16 14 (raise-exception _ #:continuable? _)
1667:16 13 (raise-exception _ #:continuable? _)
1667:16 12 (raise-exception _ #:continuable? _)
1667:16 11 (raise-exception _ #:continuable? _)
1667:16 10 (raise-exception _ #:continuable? _)
1667:16 9 (raise-exception _ #:continuable? _)
1667:16 8 (raise-exception _ #:continuable? _)
1667:16 7 (raise-exception _ #:continuable? _)
1764:13 6 (_ #<&invoke-error program: "mkswap" arguments: ("-f" "/dev/sda3") exit-status: 1 term-signal: #f stop-signal: #f>)
In ice-9/eval.scm:
619:8 5 (_ #(#(#<directory (guile-user) 7f2d93296c80> #<<installer> name: newt init: #<procedure init ()> exit: #<procedure exit ()> exit-error: #<procedure exit-error (file key args)> f…>) …))
619:8 4 (_ #(#(#(#<directory (guile-user) 7f2d93296c80> #<<installer> name: newt init: #<procedure init ()> exit: #<procedure exit ()> exit-error: #<procedure exit-error (file key arg…>) …) #))
In ice-9/ports.scm:
463:17 3 (call-with-output-file _ _ #:binary _ #:encoding _)
In ice-9/eval.scm:
619:8 2 (_ #(#(#<directory (guile-user) 7f2d93296c80> %exception (#<&invoke-error program: "mkswap" arguments: ("-f" "/dev/sda3") exit-status: 1 term-signal: #f stop-signal: #f>)) #<output:…>))
159:9 1 (_ #(#(#<directory (guile-user) 7f2d93296c80> %exception (#<&invoke-error program: "mkswap" arguments: ("-f" "/dev/sda3") exit-status: 1 term-signal: #f stop-signal: #f>)) #<output:…>))
In unknown file:
0 (make-stack #t)
ice-9/eval.scm:159:9: ERROR:
1. &invoke-error:
program: "mkswap"
arguments: ("-f" "/dev/sda3")
exit-status: 1
term-signal: #f
stop-signal: #f