emacs-all-the-icons missing all the icons

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Prikler
  • Liliana Marie Prikler
Owner
unassigned
Submitted by
Leo Prikler
Severity
normal

Debbugs page

Leo Prikler wrote 4 years ago
(address . bug-guix@gnu.org)
6034fecaa0ec23963c0d591de2f3df0a178f99f6.camel@student.tugraz.at
Pardon the pun in the title.

The problem:
emacs-all-the-icons has a subdirectory fonts, that it wants installed
to share/fonts (currently, they are installed to its own fonts
directory). Some of them are vendored, but at least one seems to be
genuinely their own.

Proposed solution:
Make it, so that emacs-all-the-icons installs its own fonts to
share/data and copies vendored fonts from inputs where packages can
be found.

Note, that this won't work for a setup with all-the-icons in a non-
default profile or ad-hoc environment (compare #31403). Would everyone
be fine with the proposed solution or is there a better one?

Regards,
Leo
Liliana Marie Prikler wrote 3 years ago
[PATCH] gnu: emacs-all-the-icons: Install all the fonts.
(address . 48713@debbugs.gnu.org)
b35b5937074bfa429686331bcbe1baf2bf358552.camel@gmail.com
* gnu/packages/emacs-xyz.scm (emacs-all-the-icons)[#:include]: Drop fonts.
[#:phases]<install-fonts>: Install them directly to ‘/share’.
[propagated-inputs]: Add font-awesome.
---
gnu/packages/emacs-xyz.scm | 19 +++++++++++++++++--
1 file changed, 17 insertions(+), 2 deletions(-)

Toggle diff (44 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index b305bb5386..b3f7b6daa6 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -150,6 +150,7 @@ (define-module (gnu packages emacs-xyz)
#:use-module (gnu packages djvu)
#:use-module (gnu packages ebook)
#:use-module (gnu packages emacs)
+ #:use-module (gnu packages fonts)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages golang)
#:use-module (gnu packages guile)
@@ -22420,13 +22421,27 @@ (define-public emacs-all-the-icons
(base32 "0lwgvgnqf7vihglm0c5bwsxbl4x7f641289cji5s7jwy2dbsqk7g"))))
(build-system emacs-build-system)
(arguments
- `(#:include '("\\.el$" "^data/" "^fonts/")
+ `(#:include '("\\.el$" "^data/")
;; Compiling "test/" fails with "Symbol’s value as variable is void:
;; all-the-icons--root-code". Ignoring tests.
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'install-fonts
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((fonts (string-append (assoc-ref outputs "out")
+ "/share/fonts")))
+ (mkdir-p fonts)
+ (with-directory-excursion "fonts"
+ (install-file "all-the-icons.ttf" fonts)
+ (install-file "file-icons.ttf" fonts)
+ (install-file "material-design-icons.ttf" fonts)
+ (install-file "octicons.ttf" fonts)
+ (install-file "weathericons.ttf" fonts))))))
#:exclude '("^test/")
#:tests? #f))
(propagated-inputs
- `(("f" ,emacs-f)
+ `(("font-awesome" ,font-awesome)
+ ("f" ,emacs-f)
("memoize" ,emacs-memoize)))
(home-page "https://github.com/domtronn/all-the-icons.el")
(synopsis "Collect icon fonts and propertize them within Emacs")
--
2.33.1
Liliana Marie Prikler wrote 3 years ago
(address . 48713-done@debbugs.gnu.org)
b2258e154fc7c6c41ae71760f59c761fc6460fd6.camel@gmail.com
Am Sonntag, dem 14.11.2021 um 16:13 +0100 schrieb Liliana Marie
Prikler:
Toggle quote (4 lines)
> * gnu/packages/emacs-xyz.scm (emacs-all-the-icons)[#:include]: Drop
> fonts.
> [#:phases]<install-fonts>: Install them directly to ‘/share’.
> [propagated-inputs]: Add font-awesome.
Also propagated material icons and pushed.

Cheers!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 48713@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 48713
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help