[PATCH 0/3] Add Common Lisp game engine - trial

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 4 years ago
(address . guix-patches@gnu.org)
CAO+9K5rNGZdVgyU4wbsBwny=NFS+7vPfu-QQMngYSGWKRw=AJQ@mail.gmail.com
Hi Guix team!
Here is a semi ready set of the last paches adding game engine written
in Common Lisp - Trial.
WIP for backends which require to pack QT bindings and cl-sdl2 which
is failing to build for me.
gnu: Add cl-trial
1 file changed, 69 insertions(+), 2 deletions(-)
gnu/packages/game-development.scm | 71 +++++++++++++++++++++++++++++++++++++--
gnu: Add cl-gamepad
1 file changed, 55 insertions(+)
gnu/packages/lisp-xyz.scm | 55 +++++++++++++++++++++++++++++++++++++++++++++++
gnu: Add cl-flow
1 file changed, 46 insertions(+)
gnu/packages/lisp-xyz.scm | 46 ++++++++++++++++++++++++++++++++++++++++++++++
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
Sharlatan Hellseher wrote 4 years ago
[PATCH 1/3]: gnu: Add cl-flow
(address . 48708@debbugs.gnu.org)
CAO+9K5qan=qb_VkoPs+uJ1-gnwOxed8U=w3BsTvLo72bUzBidg@mail.gmail.com
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
From a277392dae94c313bef52d73ee3620d883be20c4 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Thu, 27 May 2021 22:01:22 +0100
Subject: [PATCH 1/3] gnu: Add cl-flow

* gnu/packages/lisp-xyz.scm: (sbcl-flow, ecl-flow, cl-flow): New variables.
---
gnu/packages/lisp-xyz.scm | 46 +++++++++++++++++++++++++++++++++++++++
1 file changed, 46 insertions(+)

Toggle diff (56 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index e760a90045..dcdf7b3f50 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -17175,3 +17175,49 @@ any existing or future application.")
(define-public cl-flare
(sbcl-package->cl-source-package sbcl-flare))
+
+(define-public sbcl-flow
+ (let ((commit "6d925af009cdfe033650d7048197a5e6ee937d15")
+ (revision "1"))
+ (package
+ (name "sbcl-flow")
+ (version (git-version "1.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Shinmera/flow")
+ (commit commit)))
+ (file-name (git-file-name "flow" version))
+ (sha256
+ (base32 "0ysw1kwiqlf8kzllhnz8v3q40dmvwf83fzq8bfkbmwy5hfjh3pxp"))))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ ;; FIXME: (Sharlatan-20210527T203118+0100): FLOW-VISUALIZER requires
+ ;; COMMONQT which is not packed yet and required tweaks with QT. Remove
+ ;; this when it's ready.
+ `(#:asd-files '("flow.asd")))
+ (inputs
+ `(("closer-mop" ,sbcl-closer-mop)
+ ("documentation-utils" ,sbcl-documentation-utils)))
+ (home-page "https://shinmera.github.io/flow/")
+ (synopsis "Tools for the representation of graphs and flowcharts")
+ (description
+ "FLOW is a flowchart graph library. Unlike other graphing libraries, this
+one focuses on nodes in a graph having distinct @code{ports} through which
+connections to other nodes are formed. This helps in many concrete scenarios
+where it is important to distinguish not only which nodes are connected, but
+also how they are connected to each other.
+
+Particularly, a lot of data flow and exchange problems can be reduced to such
+a @code{flowchart}. For example, an audio processing library may present its pipeline
+as a flowchart of segments that communicate with each other through audio sample
+buffers. Flow gives a convenient view onto this kind of problem, and even allows
+the generic visualisation of graphs in this format.")
+ (license license:zlib))))
+
+(define-public ecl-flow
+ (sbcl-package->ecl-package sbcl-flow))
+
+(define-public cl-flow
+ (sbcl-package->cl-source-package sbcl-flow))
--
2.31.1
Sharlatan Hellseher wrote 4 years ago
[PATCH 2/3]: gnu: Add cl-gamepad
(address . 48708@debbugs.gnu.org)
CAO+9K5rJOOsF=16afEVd13QLeuMb0nsi9GEUavCSzyn12w-9LQ@mail.gmail.com
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
From 3a00de74ea423a1ecc2fe2a8d3b281bd391436dd Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Thu, 27 May 2021 22:05:17 +0100
Subject: [PATCH 2/3] gnu: Add cl-gamepad

* gnu/packages/lisp-xyz.scm: (sbcl-cl-gamepad, ecl-cl-gamepad,
cl-gamepad): New variables
---
gnu/packages/lisp-xyz.scm | 55 +++++++++++++++++++++++++++++++++++++++
1 file changed, 55 insertions(+)

Toggle diff (72 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index dcdf7b3f50..33d4bf99d0 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -90,6 +90,7 @@
#:use-module (gnu packages web)
#:use-module (gnu packages webkit)
#:use-module (gnu packages xdisorg)
+ #:use-module (gnu packages xorg)
#:use-module (ice-9 match)
#:use-module (srfi srfi-1)
#:use-module (srfi srfi-19))
@@ -17221,3 +17222,57 @@ the generic visualisation of graphs in this format.")
(define-public cl-flow
(sbcl-package->cl-source-package sbcl-flow))
+
+(define-public sbcl-cl-gamepad
+ (let ((commit "2bb8f9eef29f8968fd12d0b4060314bf925169ef")
+ (revision "1"))
+ (package
+ (name "sbcl-cl-gamepad")
+ (version (git-version "3.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Shirakumo/cl-gamepad")
+ (commit commit)))
+ (file-name (git-file-name "cl-gamepad" version))
+ (sha256
+ (base32 "18b9fainnswm0fb7lhkrkx3dxipyw0s7lzdjyqw7mchxpvicz9rv"))))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; FIXME: (Sharlatan-20210527T212052+0100):
+ ;; default-device-mappings.lisp contains auto-generated code if it
+ ;; kept unsubstituted build fails with:
+ ;;
+ ;; The function ORG.SHIRAKUMO.FRAF.GAMEPAD:LIST-DEVICES is undefined.
+ ;;
+ (add-after 'unpack 'skip-load-default-device-mappings
+ (lambda _
+ (substitute* "cl-gamepad.asd"
+ ((".*default-device-mappings.*") ""))))
+ (add-after 'unpack 'patch-evdev-lib-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "evdev-cffi.lisp"
+ (("libevdev.so" all)
+ (string-append
+ (assoc-ref inputs "libevdev")
+ "/lib/" all))))))))
+ (inputs
+ `(("cffi" ,sbcl-cffi)
+ ("documentation-utils" ,sbcl-documentation-utils)
+ ("libevdev" ,libevdev)
+ ("trivial-features" ,sbcl-trivial-features)))
+ (home-page "https://shirakumo.github.io/cl-gamepad/")
+ (synopsis "Library for access to gamepads and joystick input devices")
+ (description
+ "This is a library to provide cross-platform access to gamepads,
+joysticks, and other such HID devices.")
+ (license license:zlib))))
+
+(define-public ecl-cl-gamepad
+ (sbcl-package->ecl-package sbcl-cl-gamepad))
+
+(define-public cl-gamepad
+ (sbcl-package->cl-source-package sbcl-cl-gamepad))
--
2.31.1
Sharlatan Hellseher wrote 4 years ago
[PATCH 3/3]: gnu: Add cl-trial
(address . 48708@debbugs.gnu.org)
CAO+9K5pQzAHk24x3Lhn2VZSBZO9YFwN7SXHLwtpuO7quSCBMoQ@mail.gmail.com
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
From f3ec7b37885ef7e494fbd101f287dc09c5241497 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Thu, 27 May 2021 22:11:32 +0100
Subject: [PATCH 3/3] gnu: Add cl-trial

* gnu/packages/game-development.scm: (sbcl-trial, ecl-trial, cl-trial):
New variables.
---
gnu/packages/game-development.scm | 71 ++++++++++++++++++++++++++++++-
1 file changed, 69 insertions(+), 2 deletions(-)

Toggle diff (117 lines)
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 62b8c6cdb1..1bdb2775ec 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -21,6 +21,7 @@
;;; Copyright © 2020 Timotej Lazar <timotej.lazar@araneo.si>
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2021 Alexandru-Sergiu Marton <brown121407@posteo.ro>
+;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -46,6 +47,7 @@
#:use-module (guix git-download)
#:use-module (guix svn-download)
#:use-module (guix utils)
+ #:use-module (guix build-system asdf)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
@@ -55,16 +57,16 @@
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
#:use-module (gnu packages boost)
- #:use-module (gnu packages compression)
#:use-module (gnu packages check)
+ #:use-module (gnu packages compression)
#:use-module (gnu packages curl)
+ #:use-module (gnu packages dbm)
#:use-module (gnu packages documentation)
#:use-module (gnu packages fltk)
#:use-module (gnu packages fonts)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages fribidi)
- #:use-module (gnu packages dbm)
#:use-module (gnu packages gcc)
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
@@ -76,6 +78,7 @@
#:use-module (gnu packages guile)
#:use-module (gnu packages image)
#:use-module (gnu packages linux)
+ #:use-module (gnu packages lisp-xyz)
#:use-module (gnu packages lua)
#:use-module (gnu packages m4)
#:use-module (gnu packages mono)
@@ -2577,3 +2580,67 @@ fully dynamic omnidirectional shadows, global illumination, HDR lighting,
deferred shading, morphological / temporal / multisample anti-aliasing, and
much more.")
(license license:zlib))))
+
+(define-public sbcl-trial
+ (let ((commit "ba178cac3a5528c570c7e8dad66c58cc770db53a")
+ (revision "1"))
+ (package
+ (name "sbcl-trial")
+ (version (git-version "1.2.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Shirakumo/trial")
+ (commit commit)))
+ (file-name (git-file-name "trial" version))
+ (sha256
+ (base32 "1vpv9nrpq93fz1c5cyi1hazaaz9ijbrf1l7zwp7gammndr5v028r"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("alexandria" ,sbcl-alexandria)
+ ("3d-matrices" ,sbcl-3d-matrices)
+ ("3d-vectors" ,sbcl-3d-vectors)
+ ("bordeaux-threads" ,sbcl-bordeaux-threads)
+ ("cl-gamepad" ,sbcl-cl-gamepad)
+ ("cl-jpeg" ,sbcl-cl-jpeg)
+ ("cl-opengl" ,sbcl-cl-opengl)
+ ("cl-ppcre" ,sbcl-cl-ppcre)
+ ("cl-tga" ,sbcl-cl-tga)
+ ("closer-mop" ,sbcl-closer-mop)
+ ("deploy" ,sbcl-deploy)
+ ("fast-io" ,sbcl-fast-io)
+ ("flare" ,sbcl-flare)
+ ("float-features" ,sbcl-float-features)
+ ("flow" ,sbcl-flow)
+ ("for" ,sbcl-for)
+ ("form-fiddle" ,sbcl-form-fiddle)
+ ("glsl-toolkit" ,sbcl-glsl-toolkit)
+ ("ieee-floats" ,sbcl-ieee-floats)
+ ("jsown" ,sbcl-jsown)
+ ("lambda-fiddle" ,sbcl-lambda-fiddle)
+ ("lquery" ,sbcl-lquery)
+ ("messagebox" ,sbcl-messagebox)
+ ("mmap" ,sbcl-mmap)
+ ("pathname-utils" ,sbcl-pathname-utils)
+ ("pngload" ,sbcl-pngload)
+ ("retrospectiff" ,sbcl-retrospectiff)
+ ("static-vectors" ,sbcl-static-vectors)
+ ("terrable" ,sbcl-terrable)
+ ("trivial-garbage" ,sbcl-trivial-garbage)
+ ("trivial-indent" ,sbcl-trivial-indent)
+ ("verbose" ,sbcl-verbose)
+ ("zpng" ,sbcl-zpng)))
+ (home-page "https://github.com/Shirakumo/trial")
+ (synopsis "Common Lisp game engine")
+ (description
+ "Trial is a game engine written in Common Lisp. Unlike many other
+engines, it is meant to be more of a loose connection of components that can be
+fit together as required by any particular game.")
+ (license license:zlib))))
+
+(define-public ecl-trial
+ (sbcl-package->ecl-package sbcl-trial))
+
+(define-public cl-trial
+ (sbcl-package->cl-source-package sbcl-trial))
--
2.31.1
Guillaume Le Vaillant wrote 4 years ago
Re: [bug#48708] [PATCH 2/3]: gnu: Add cl-gamepad
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 48708@debbugs.gnu.org)
877dj490e8.fsf@kitej
I pushed the patch for cl-flow as
c03da7edb0bc4bb48c2f8e00e1ef5932c399f800.

Concerning cl-gamepad, is the library working even when all the gamepad
mappings are missing?

I took a quick look to the issue with the 'list-devices' function, and
apparently the compiler is expecting it to be in the
'org.shirakumo.fraf.gamepad' package, however it is defined in the
'org.shirakumo.fraf.gamepad.impl' package.
Maybe you could ask upstream about it?
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYL82vw8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j/kMQD/Ur1+kTdgaHoxA4Kl8ic/SffTW0EUd4K7+7Xj
IONrfkcA/1xZVJXk677Yg2CFyv3s8OL2vnUc9hicbQXHJsGqFiyz
=sTNF
-----END PGP SIGNATURE-----

Sharlatan Hellseher wrote 4 years ago
(name . Guillaume Le Vaillant)(address . glv@posteo.net)(address . 48708@debbugs.gnu.org)
CAO+9K5qJhZbCGkYMVr593QdusV8hW5xkTbh7RNWY-EoNdBd1Cw@mail.gmail.com
Hi Guillaume,
Thanks for the clue, I've open an issue with Shinmera, but he is not
responsive in general so it could take some time when he notices that
open issue.
On Tue, 8 Jun 2021 at 09:22, Guillaume Le Vaillant <glv@posteo.net> wrote:
Toggle quote (12 lines)
>
> I pushed the patch for cl-flow as
> c03da7edb0bc4bb48c2f8e00e1ef5932c399f800.
>
> Concerning cl-gamepad, is the library working even when all the gamepad
> mappings are missing?
>
> I took a quick look to the issue with the 'list-devices' function, and
> apparently the compiler is expecting it to be in the
> 'org.shirakumo.fraf.gamepad' package, however it is defined in the
> 'org.shirakumo.fraf.gamepad.impl' package.
> Maybe you could ask upstream about it?
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
Sharlatan Hellseher wrote 4 years ago
(name . Guillaume Le Vaillant)(address . glv@posteo.net)(address . 48708@debbugs.gnu.org)
CAO+9K5reZdDzqGoGWXvBvrH=kQEReua5QM1SNN+ruyUN83QbmQ@mail.gmail.com
Hi,
I think we hitting this issue (I guess) when ASDF does not load
trivial-fiature during :linux feature check.
Also cl-gamepad.asd has some not trivial layout.
On Tue, 8 Jun 2021 at 20:05, Sharlatan Hellseher <sharlatanus@gmail.com> wrote:
Toggle quote (30 lines)
>
> Hi Guillaume,
>
> Thanks for the clue, I've open an issue with Shinmera, but he is not
> responsive in general so it could take some time when he notices that
> open issue.
>
> https://github.com/Shirakumo/cl-gamepad/issues/8
>
> On Tue, 8 Jun 2021 at 09:22, Guillaume Le Vaillant <glv@posteo.net> wrote:
> >
> > I pushed the patch for cl-flow as
> > c03da7edb0bc4bb48c2f8e00e1ef5932c399f800.
> >
> > Concerning cl-gamepad, is the library working even when all the gamepad
> > mappings are missing?
> >
> > I took a quick look to the issue with the 'list-devices' function, and
> > apparently the compiler is expecting it to be in the
> > 'org.shirakumo.fraf.gamepad' package, however it is defined in the
> > 'org.shirakumo.fraf.gamepad.impl' package.
> > Maybe you could ask upstream about it?
>
>
>
> --
>
> … наш разум - превосходная объяснительная машина которая способна
> найти смысл почти в чем угодно, истолковать любой феномен, но
> совершенно не в состоянии принять мысль о непредсказуемости.
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
Sharlatan Hellseher wrote 4 years ago
(name . Guillaume Le Vaillant)(address . glv@posteo.net)(address . 48708@debbugs.gnu.org)
CAO+9K5ohgR7j_k_EYi5rGwEKzs1FCb8eehaZZuqgDtrOknVNKQ@mail.gmail.com
Hi,
Shinmera did not provide any useful information on this issue and
pointed on the problem somewhere in the OS itself.
I've played a little with asdf:load-system in REPL and I could load it
and evaluate asdf:compile-system but when compile directly it exits
with the same error
Toggle snippet (25 lines)
CL-USER> (asdf:compile-system :cl-gamepad)
; Debugger entered on #<UNDEFINED-FUNCTION LIST-DEVICES {1002B438B3}>
[1] CL-USER>
;
; compilation unit aborted
; caught 1 fatal ERROR condition
; Evaluation aborted on #<SB-KERNEL::RETRY-UNDEFINED-FUNCTION
LIST-DEVICES {1002EA0003}>
CL-USER> (asdf:load-system :cl-gamepad)
; compiling file "/mnt/library/code/cl-gamepad/documentation.lisp"
(written 12 JUN 2021 09:37:42 PM):
; processing (IN-PACKAGE #:ORG.SHIRAKUMO.FRAF.GAMEPAD)
; processing (DOCUMENTATION-UTILS:DEFINE-DOCS (FUNCTION CONFIGURE-DEVICE ...))
; processing (DOCUMENTATION-UTILS:DEFINE-DOCS (TYPE
*DEFAULT-MAPPINGS-FILE* ...) ...)
; processing (DOCUMENTATION-UTILS:DEFINE-DOCS (VARIABLE +LABELS+ ...) ...)
; wrote /home/sharlatan/.cache/common-lisp/sbcl-2.1.5-linux-x64/mnt/library/code/cl-gamepad/documentation-tmpGHU3ALSV.fasl
; compilation finished in 0:00:00.004
T
CL-USER> (asdf:compile-system :cl-gamepad)
T
On Tue, 8 Jun 2021 at 22:01, Sharlatan Hellseher <sharlatanus@gmail.com> wrote:
Toggle quote (49 lines)
>
> Hi,
>
> I think we hitting this issue (I guess) when ASDF does not load
> trivial-fiature during :linux feature check.
>
> https://github.com/quicklisp/quicklisp-client/pull/122
>
> Also cl-gamepad.asd has some not trivial layout.
>
> On Tue, 8 Jun 2021 at 20:05, Sharlatan Hellseher <sharlatanus@gmail.com> wrote:
> >
> > Hi Guillaume,
> >
> > Thanks for the clue, I've open an issue with Shinmera, but he is not
> > responsive in general so it could take some time when he notices that
> > open issue.
> >
> > https://github.com/Shirakumo/cl-gamepad/issues/8
> >
> > On Tue, 8 Jun 2021 at 09:22, Guillaume Le Vaillant <glv@posteo.net> wrote:
> > >
> > > I pushed the patch for cl-flow as
> > > c03da7edb0bc4bb48c2f8e00e1ef5932c399f800.
> > >
> > > Concerning cl-gamepad, is the library working even when all the gamepad
> > > mappings are missing?
> > >
> > > I took a quick look to the issue with the 'list-devices' function, and
> > > apparently the compiler is expecting it to be in the
> > > 'org.shirakumo.fraf.gamepad' package, however it is defined in the
> > > 'org.shirakumo.fraf.gamepad.impl' package.
> > > Maybe you could ask upstream about it?
> >
> >
> >
> > --
> >
> > … наш разум - превосходная объяснительная машина которая способна
> > найти смысл почти в чем угодно, истолковать любой феномен, но
> > совершенно не в состоянии принять мысль о непредсказуемости.
>
>
>
> --
>
> … наш разум - превосходная объяснительная машина которая способна
> найти смысл почти в чем угодно, истолковать любой феномен, но
> совершенно не в состоянии принять мысль о непредсказуемости.
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
Guillaume Le Vaillant wrote 4 years ago
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 48708-done@debbugs.gnu.org)
87h7hnmoga.fsf@kitej
Sharlatan Hellseher <sharlatanus@gmail.com> skribis:

Toggle quote (7 lines)
> Shinmera did not provide any useful information on this issue and
> pointed on the problem somewhere in the OS itself.
>
> I've played a little with asdf:load-system in REPL and I could load it
> and evaluate asdf:compile-system but when compile directly it exits
> with the same error

I changed your package definition to use a custom build phase using
'asdf:load-system' instead of the usual 'asdf:compile-system' as
a workaround. However I'm don't know why one works and the other
doesn't...

Patches pushed as d09184ce2eafd1c5f7d4d1962c44b0becfaede16 and
following.
Thanks.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 48708@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 48708
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help