[PATCH 0/4] Update python-numpy

  • Done
  • quality assurance status badge
Details
3 participants
  • Greg Hogan
  • Vinicius Monego
  • Xinglu Chen
Owner
unassigned
Submitted by
Greg Hogan
Severity
normal
G
G
Greg Hogan wrote on 27 May 2021 17:10
(address . guix-patches@gnu.org)
CA+3U0Zno9wPf7jGtse0GeuGvAFV0zzPEocWuWLdUSzGYeZveuw@mail.gmail.com
In March there were two attempts to update python-numpy (#45698 and #47183
/ #47184) which failed to build python-pandas and python-scipy.

The attached patches update and successfully build python-numpy,
python-pandas, python-matplotlib, and python-scipy.

In addition to modified dependencies, python-matplotlib expanded the regex
to silence image font differences and I was only able to successfully build
and test python-pandas when replacing python-openpyxl
with python-xlsxwriter.

Greg
Attachment: file
X
X
Xinglu Chen wrote on 2 Jun 2021 21:14
87tumgjcyd.fsf@yoctocell.xyz
On Thu, May 27 2021, Greg Hogan wrote:

Toggle quote (11 lines)
> In March there were two attempts to update python-numpy (#45698 and #47183
> / #47184) which failed to build python-pandas and python-scipy.
>
> The attached patches update and successfully build python-numpy,
> python-pandas, python-matplotlib, and python-scipy.
>
> In addition to modified dependencies, python-matplotlib expanded the regex
> to silence image font differences and I was only able to successfully build
> and test python-pandas when replacing python-openpyxl
> with python-xlsxwriter.

Thank you for working on this!

All the four packages you mentioned, ‘python-numpy’, ‘python-pandas’,
‘python-matplotlib’, and ‘python-scipy’ build for me.
-----BEGIN PGP SIGNATURE-----

iQJJBAEBCAAzFiEEAVhh4yyK5+SEykIzrPUJmaL7XHkFAmC32KoVHHB1YmxpY0B5
b2N0b2NlbGwueHl6AAoJEKz1CZmi+1x55C0P/jvr1tluA1SfO+2duoq5v6pd8FSp
mbThdtCTf4hEDv9k3DML5VcOWHRrBBpG2/8EI9BNOfVz98NswMklsSTSlb/FDuuo
vlgo8UnZ8oU/DfbSr8pLm+UjIdLFhDBv0kcjbI/AkvZHTlXrM5oR1+KZ5Y3l5NSp
enhIcWxI1bqZo2jLhyJjujgAZdz6ECps1EAKd0Lu7by7XtH5Hzh7UCpI3GKjBiDC
gOTghlQZagzvTB6uTV2oDzPe0drsQe40Mier5NKSGvBEOQTscoYv9KuJDRry/KE2
llHf5oIRaDscJClWsOEokZpPgX6q+iuYWbT7h0hYt2eafNdYMjOy1c0dRuoLvh6w
7dupf/pgN/H51LAi7fos7VO5SikJ3GMjB8q0xCRAzij5imQKObgsFa6IrILY/CtY
t03/G56TyIY8QwB3u7jwgq7xm5Dg8/L3hKrPevdF+2b/TYgJ+R4g0s0APOiHwdH8
HXlYS2bfcpHPKurbQDEHSYwi6S6AoGdRQWg5CqsNo7NzMb0AyfCyQ4F3jPrbTNhL
LOWj3oKdQjFm9h8xqMnhXddQ0utNs60Uj1oXFT5ZBwVzkbBPzjH3oFjCuExgN70U
Rt3pH6Ag4a+wqMHDCNoTquTpa2VzeXNTjm2JJnSKLhBzXdpc2Lo7E+uX4cO2CpxL
gmbXoS0yJoXKmI2E
=s38W
-----END PGP SIGNATURE-----

V
V
Vinicius Monego wrote on 16 Jun 2021 11:10
[PATCH 0/4] Update python-numpy
(address . 48703@debbugs.gnu.org)
462a8613b51f255d4c004c1619c8200535574086.camel@posteo.net
Hello,

Since this is a mid to long term update (the packages have quite a few
[heavy] dependents), I'd like to suggest some refactoring. I will talk
about each package separately.

- python-numpy:

1. Why is it sourced from a tar.gz in the github releases page and not
from PyPI or a checkout? I had a look at the PyPI source file and the
tests are provided. If that source is required, a comment would help.

2.

Toggle quote (3 lines)
> ;; Tests can only be run after the library has been installed and not
> ;; within the source directory.

I'm not sure if pytest was invoked manually or if the runtests.py
script was executed to reach that conclusion.

Numpy uses the tests under subdirectories structure. In that case,
tests should run with "python -m pytest --pyargs numpy" or "pytest --
pyargs numpy". I have this generic template that worked for all of my
packages so far:

Toggle quote (6 lines)
> (replace 'check
> (lambda* (#:key inputs outputs tests? #:allow-other-keys)
> (when tests?
> (add-installed-pythonpath inputs outputs)
> (invoke "python" "-m" "pytest" "--pyargs" "numpy"))))

NumPy could be a special case, but a more detailed comment would help.

3. #:tests? is not respected.

4. Don't return #t in the phases.

- python-scipy

1. Same comment about tests from NumPy. Overriding the check would also
allow removing the 'disable-broken-tests phase.

2. #:tests? is not respected here either.

3. Don't return #t in the phases.

4. Since documentation is being built, it would be good to have the
sphinx theme for scipy ready. The current documentation doesn't have
any CSS. Not a big problem though.

- python-matplotlib

1. Respect #:tests?.

2. Don't return #t in the phases.

LGTM otherwise.

- python-pandas

1. I think the check phase could be simplified by using the same pytest
structure suggested in numpy and scipy.
2. Respect #:tests?
3. Don't return #t in the phases.
G
G
Greg Hogan wrote on 28 Jan 2022 12:48
Re: bug#48703: Acknowledgement ([PATCH 0/4] Update python-numpy)
(address . 48703-done@debbugs.gnu.org)
CA+3U0ZmAaF2K021mdmnLLWbvwsz_NB98b-iok2E0DqPt9MFa7A@mail.gmail.com
The same or newer package versions are in the main branch. Closing.

On Thu, May 27, 2021 at 11:12 AM GNU bug Tracking System <
help-debbugs@gnu.org> wrote:

Toggle quote (22 lines)
> Thank you for filing a new bug report with debbugs.gnu.org.
>
> This is an automatically generated reply to let you know your message
> has been received.
>
> Your message is being forwarded to the package maintainers and other
> interested parties for their attention; they will reply in due course.
>
> Your message has been sent to the package maintainer(s):
> guix-patches@gnu.org
>
> If you wish to submit further information on this problem, please
> send it to 48703@debbugs.gnu.org.
>
> Please do not send mail to help-debbugs@gnu.org unless you wish
> to report a problem with the Bug-tracking system.
>
> --
> 48703: http://debbugs.gnu.org/cgi/bugreport.cgi?bug=48703
> GNU Bug Tracking System
> Contact help-debbugs@gnu.org with problems
>
Attachment: file
Closed
?