[PATCH 2/2]: gnu: Add cl-flare

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 4 years ago
(address . guix-patches@gnu.org)
CAO+9K5pzSBWNJxWRT1mON_XkrNpFJdJx-gGB6bpxdCqQ_xpXTA@mail.gmail.com
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
From e40b208585e77a55b9c97622ae16f596cbc90c88 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Wed, 26 May 2021 23:05:00 +0100
Subject: [PATCH 2/2] gnu: Add cl-flare

* gnu/packages/lisp-xyz.scm: (sbcl-flare, ecl-flare, cl-flare): New variables.
---
gnu/packages/lisp-xyz.scm | 38 ++++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 8e7731f57d..e760a90045 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -17137,3 +17137,41 @@ require code-walking and is easier to extend.")
(define-public cl-for
(sbcl-package->cl-source-package sbcl-for))
+
+(define-public sbcl-flare
+ (let ((commit "4f9f17a4fc5b368c2a1988b9a20288695b8d8c48")
+ (revision "1"))
+ (package
+ (name "sbcl-flare")
+ (version (git-version "1.1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Shinmera/flare")
+ (commit commit)))
+ (file-name (git-file-name "flare" version))
+ (sha256
+ (base32 "00nm3sjngbflj2gd5q0xs2m136w4kix6krww23nk64pkkyq2fs86"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("3d-vectors" ,sbcl-3d-vectors)
+ ("array-utils" ,sbcl-array-utils)
+ ("documentation-utils" ,sbcl-documentation-utils)
+ ("for" ,sbcl-for)
+ ("lambda-fiddle" ,sbcl-lambda-fiddle)
+ ("trivial-garbage" ,sbcl-trivial-garbage)))
+ (home-page "https://shinmera.github.io/flare/")
+ (synopsis "Easy particle systems with fine grained control")
+ (description
+ "FLARE is a library designed to allow quick and precise particle effect
+creations. It does not concern itself with displaying and only with the
+management and movement of particles. As such, it can easily be integrated into
+any existing or future application.")
+ (license license:zlib))))
+
+(define-public ecl-flare
+ (sbcl-package->ecl-package sbcl-flare))
+
+(define-public cl-flare
+ (sbcl-package->cl-source-package sbcl-flare))
--
2.31.1
Sharlatan Hellseher wrote 4 years ago
[PATCH 1/2]: gnu: Add cl-for
(address . 48689@debbugs.gnu.org)
CAO+9K5ojfY7rkYS6tvijbsw-LxsMxuiX67MnO5=ubzA=wA0N2Q@mail.gmail.com
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
From 3e92373309a3f366e61a03c856619414b6ad984a Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Wed, 26 May 2021 23:02:50 +0100
Subject: [PATCH 1/2] gnu: Add cl-for

* gnu/packages/lisp-xyz.scm: (sbcl-for, ecl-for, cl-for): New variables.
---
gnu/packages/lisp-xyz.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 8b0ba1a3b8..8e7731f57d 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -17102,3 +17102,38 @@ Django with a syntax similar to Python Jinja2.")
(define-public cl-djula
(sbcl-package->cl-source-package sbcl-djula))
+
+(define-public sbcl-for
+ (let ((commit "2e4fcfa0f9c1d2f4559c58cef20ccefa50ba180d")
+ (revision "1"))
+ (package
+ (name "sbcl-for")
+ (version (git-version "1.1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Shinmera/for")
+ (commit commit)))
+ (file-name (git-file-name "for" version))
+ (sha256
+ (base32 "1akz9ggh33x2cq3h0f1cd0p632v1mbagv3dzsb0r10bwg9lh3nmv"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("documentation-utils" ,sbcl-documentation-utils)
+ ("form-fiddle" ,sbcl-form-fiddle)
+ ("lambda-fiddle" ,sbcl-lambda-fiddle)))
+ (home-page "https://shinmera.github.io/for/")
+ (synopsis "Extensible iteration macro library")
+ (description
+ "For is a library for an extensible iteration macro. It allows you to write
+concise looping constructs similar to @code{loop} and @code{iterate}. Unlike
+loop however it is extensible and sensible, and unlike iterate it does not
+require code-walking and is easier to extend.")
+ (license license:zlib))))
+
+(define-public ecl-for
+ (sbcl-package->ecl-package sbcl-for))
+
+(define-public cl-for
+ (sbcl-package->cl-source-package sbcl-for))
--
2.31.1
Guillaume Le Vaillant wrote 4 years ago
Re: [bug#48689] [PATCH 2/2]: gnu: Add cl-flare
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 48689-done@debbugs.gnu.org)
87lf80mz0p.fsf@kitej
Patches pushed as 1ab3aab59af43f42113408020cf052389cb6e303 and
following.
Thanks.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 48689@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 48689
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help