[PATCH 3/3]: gnu: Add r-opencpu

  • Done
  • quality assurance status badge
Details
2 participants
  • Ricardo Wurmus
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal
S
S
Sharlatan Hellseher wrote on 26 May 2021 22:52
(address . guix-patches@gnu.org)
CAO+9K5oQAB3_tDsx0Z9h6ch5U8Od0Nc_TOJ1v0OKEBLsmYau2A@mail.gmail.com
--
… ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
From 14e98b24842842e4fe5fe78e2cff3fc253f0a515 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Wed, 26 May 2021 21:43:59 +0100
Subject: [PATCH 3/3] gnu: Add r-opencpu

* gnu/packages/cran.scm: (r-opencpu): New variable.
---
gnu/packages/cran.scm | 44 +++++++++++++++++++++++++++++++++++++++++++
1 file changed, 44 insertions(+)

Toggle diff (54 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index e39617efcd..4e84d26784 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -29054,3 +29054,47 @@ time. The @code{RProtoBuf} package on the other hand uses the protobuf runtime
library to provide a general- purpose toolkit for reading and writing arbitrary
protocol-buffer data in R.")
(license license:expat)))
+
+(define-public r-opencpu
+ (package
+ (name "r-opencpu")
+ (version "2.2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "opencpu" version))
+ (sha256
+ (base32 "0dr3ga8vw10vllqjq6n53dwivvgvzrgrjcn17kmabp620533bj1k"))))
+ (properties `((upstream-name . "opencpu")))
+ (build-system r-build-system)
+ (inputs
+ `(("pandoc" ,pandoc)))
+ (propagated-inputs
+ `(("r-brew" ,r-brew)
+ ("r-curl" ,r-curl)
+ ("r-evaluate" ,r-evaluate)
+ ("r-httpuv" ,r-httpuv)
+ ("r-jsonlite" ,r-jsonlite)
+ ("r-knitr" ,r-knitr)
+ ("r-mime" ,r-mime)
+ ("r-openssl" ,r-openssl)
+ ("r-protolite" ,r-protolite)
+ ("r-rappdirs" ,r-rappdirs)
+ ("r-remotes" ,r-remotes)
+ ("r-sys" ,r-sys)
+ ("r-webutils" ,r-webutils)
+ ("r-zip" ,r-zip)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page "https://www.opencpu.org")
+ (synopsis "API for embedded scientific computing producing reproducing results")
+ (description
+ "This package provides a system for embedded scientific computing and
+reproducible research with R. The OpenCPU server exposes a simple but powerful
+HTTP api for RPC and data interchange with R. This provides a reliable and
+scalable foundation for statistical services or building R web applications. The
+OpenCPU server runs either as a single-user development server within the
+interactive R session, or as a multi-user Linux stack based on Apache2. The
+entire system is fully open source and permissively licensed. The OpenCPU
+website has detailed documentation and example apps.")
+ (license license:asl2.0)))
--
2.31.1
S
S
Sharlatan Hellseher wrote on 26 May 2021 22:54
[PATCH 2/3]: gnu: Add r-protolite
(address . 48684@debbugs.gnu.org)
CAO+9K5pDS8OpoKkbB0=idXTtS0Bfp+g0nq=-m2x=yvP30VfTyQ@mail.gmail.com
--
… ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
From 4730970563155c1f812c814002207d3d25a447b2 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Wed, 26 May 2021 21:42:54 +0100
Subject: [PATCH 2/3] gnu: Add r-protolite

* gnu/packages/cran.scm: (r-protolite): New variable.
---
gnu/packages/cran.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index f7c841ad52..e39617efcd 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -29021,3 +29021,36 @@ complex functions.")
application/x-www-form-urlencoded format. Includes example of hosting and
parsing html form data in R using either @code{httpuv} or @code{Rhttpd}.")
(license license:expat)))
+
+(define-public r-protolite
+(package
+ (name "r-protolite")
+ (version "2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "protolite" version))
+ (sha256
+ (base32 "0mwpdlpxsxbj4s2s30d0w1h4dsg0j1jzzldh8kvxii9lpfkiv2gz"))))
+ (properties `((upstream-name . "protolite")))
+ (build-system r-build-system)
+ (inputs
+ `(("protobuf" ,protobuf)))
+ (propagated-inputs
+ `(("r-jsonlite" ,r-jsonlite)
+ ("r-rcpp" ,r-rcpp)))
+ (native-inputs
+ `(("protobuf" ,protobuf)
+ ("pkg-config" ,pkg-config)))
+ (home-page "https://github.com/jeroen/protolite")
+ (synopsis "Highly Optimized Protocol Buffer Serializers")
+ (description
+ "Pure C++ implementations for reading and writing several common data
+formats based on Google protocol-buffers. Currently supports @code{rexp.proto}
+for serialized R objects, @code{geobuf.proto} for binary geojson, and
+@code{mvt.proto} for vector tiles. This package uses the auto-generated C++ code
+by protobuf-compiler, hence the entire serialization is optimized at compile
+time. The @code{RProtoBuf} package on the other hand uses the protobuf runtime
+library to provide a general- purpose toolkit for reading and writing arbitrary
+protocol-buffer data in R.")
+ (license license:expat)))
--
2.31.1
From e0dc0df9b3f891822c3069b53538492a40ce654b Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Wed, 26 May 2021 21:47:13 +0100
Subject: [PATCH] gnu: Add missing module protofub

---
gnu/packages/cran.scm | 1 +
1 file changed, 1 insertion(+)

Toggle diff (14 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 4e84d26784..fcd3e6bc43 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -96,6 +96,7 @@
#:use-module (gnu packages pdf)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages protobuf)
#:use-module (gnu packages pulseaudio) ;libsndfile
#:use-module (gnu packages python)
#:use-module (gnu packages python-xyz)
--
2.31.1
S
S
Sharlatan Hellseher wrote on 26 May 2021 22:55
[PATCH 1/3]: gnu: Add r-webutils
(address . 48684@debbugs.gnu.org)
CAO+9K5ogJ3_eZr2HP4JM9-TvTVYkjs=pUHuGLuvhjg1o3zaHFQ@mail.gmail.com
--
… ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
From 22f09a7faf4295b76b57a8ff360697b3c3127cfb Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Wed, 26 May 2021 21:41:30 +0100
Subject: [PATCH 1/3] gnu: Add r-webutils

* gnu/packages/cran.scm (r-webutils): New variable.
---
gnu/packages/cran.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 19aa2b407b..f7c841ad52 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -34,6 +34,7 @@
;;; Copyright © 2020 Simon Tournier <zimon.toutoune@gmail.com>
;;; Copyright © 2020 Aniket Patil <aniket112.patil@gmail.com>
;;; Copyright © 2021 Tim Howes <timhowes@lavabit.com>
+;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -28997,3 +28998,26 @@ complex functions.")
(description
"The Gaussian hypergeometric function for complex numbers.")
(license license:gpl2)))
+
+(define-public r-webutils
+ (package
+ (name "r-webutils")
+ (version "1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "webutils" version))
+ (sha256
+ (base32 "16a6ds0fnb6y8i1r9ba1hf1ydb53am57s070b3hi5jmrs84b9qik"))))
+ (properties `((upstream-name . "webutils")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-curl" ,r-curl)
+ ("r-jsonlite" ,r-jsonlite)))
+ (home-page "https://github.com/jeroen/webutils")
+ (synopsis "Utility Functions for Developing Web Applications")
+ (description
+ "Parses http request data in application/json, multipart/form-data, or
+application/x-www-form-urlencoded format. Includes example of hosting and
+parsing html form data in R using either @code{httpuv} or @code{Rhttpd}.")
+ (license license:expat)))
--
2.31.1
R
R
Ricardo Wurmus wrote on 22 Jul 2021 11:38
[PATCH 3/3]: gnu: Add r-opencpu
(address . 48684-done@debbugs.gnu.org)
87h7gm4rip.fsf@elephly.net
Hi,

thanks for the patches.

I rebased them, fixed the indentation, the descriptions, and the
synopses, and added a missing module import. I pushed the changes
with commit 9cfa6c3c587766a310252f4c1271503d819bdd8a.

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 48684@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 48684
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch