[PATCH 0/3] Update emacs-geiser, emacs-geiser-guile and add emacs-geiser-racket

  • Done
  • quality assurance status badge
Details
3 participants
  • David Dashyan
  • Nicolas Goaziou
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
David Dashyan
Severity
normal

Debbugs page

David Dashyan wrote 4 years ago
(address . guix-patches@gnu.org)(name . David Dashyan)(address . mail@davie.li)
20210524213150.1158-1-mail@davie.li
Hello guix! I packaged emacs-geiser-racket today and found that emacs-geiser
emacs-geiser-guile a bit outdated. Here are the patches! Beware that I
havent used them extensively yet. They load, and repl starts fine for guile
and racket so shouldn't much problem I guess.

Patch files that were included with packages are no longer needed since
autoloading fixes are now in geiser upsteam.

David Dashyan (3):
gnu: emacs-geiser: Update to 0.16.
gnu: Add emacs-geiser-racket.
gnu: emacs-geiser-guile: Update to 0.17.

gnu/local.mk | 2 -
gnu/packages/emacs-xyz.scm | 57 ++++++++++++++++---
...ser-autoload-activate-implementation.patch | 26 ---------
.../emacs-geiser-guile-auto-activate.patch | 34 -----------
4 files changed, 49 insertions(+), 70 deletions(-)
delete mode 100644 gnu/packages/patches/emacs-geiser-autoload-activate-implementation.patch
delete mode 100644 gnu/packages/patches/emacs-geiser-guile-auto-activate.patch


base-commit: 488fc3d2e6e0a3d5fc4fe747587cf831989ece58
--
2.31.1
David Dashyan wrote 4 years ago
[PATCH 1/3] gnu: emacs-geiser: Update to 0.16.
(address . 48635@debbugs.gnu.org)(name . David Dashyan)(address . mail@davie.li)
20210524213857.1683-1-mail@davie.li
---
gnu/local.mk | 1 -
gnu/packages/emacs-xyz.scm | 7 +++--
...ser-autoload-activate-implementation.patch | 26 -------------------
3 files changed, 3 insertions(+), 31 deletions(-)
delete mode 100644 gnu/packages/patches/emacs-geiser-autoload-activate-implementation.patch

Toggle diff (78 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 9dac7ea152..d772128518 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -973,7 +973,6 @@ dist_patch_DATA = \
%D%/packages/patches/emacs-exwm-fix-fullscreen-states.patch \
%D%/packages/patches/emacs-fix-scheme-indent-function.patch \
%D%/packages/patches/emacs-geiser-guile-auto-activate.patch \
- %D%/packages/patches/emacs-geiser-autoload-activate-implementation.patch \
%D%/packages/patches/emacs-ignore-empty-xim-styles.patch \
%D%/packages/patches/emacs-json-reformat-fix-tests.patch \
%D%/packages/patches/emacs-highlight-stages-add-gexp.patch \
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index cc843bfb78..46e28e6cbe 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -98,6 +98,7 @@
;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
;;; Copyright © 2021 Eugene Klimov <lipklim@mailbox.org>
;;; Copyright © 2021 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2021 David Dashyan <mail@davie.li>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -221,7 +222,7 @@
(define-public emacs-geiser
(package
(name "emacs-geiser")
- (version "0.13")
+ (version "0.16")
(source
(origin
(method git-fetch)
@@ -230,9 +231,7 @@
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0bwjcfmcyv6z0i5ivqirgcibxdkrlf5vyxcbj7k8dk7flwg1fpd9"))
- (patches
- (search-patches "emacs-geiser-autoload-activate-implementation.patch"))))
+ (base32 "18gx7ak2ldpmqbimnq221dn2qg7qwm5n1mj6ajymwkgvqwcrsl2r"))))
(build-system emacs-build-system)
(arguments
'(#:phases
diff --git a/gnu/packages/patches/emacs-geiser-autoload-activate-implementation.patch b/gnu/packages/patches/emacs-geiser-autoload-activate-implementation.patch
deleted file mode 100644
index 47d513b3a3..0000000000
--- a/gnu/packages/patches/emacs-geiser-autoload-activate-implementation.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 9fd3174cead8bfa17a8413bffa38362853d71a02 Mon Sep 17 00:00:00 2001
-From: jao <jao@gnu.org>
-Date: Mon, 5 Apr 2021 23:06:56 +0100
-Subject: [PATCH] autoload geiser activate implementation
-
----
- elisp/geiser.el | 3 +++
- readme.org | 4 ++--
- 2 files changed, 5 insertions(+), 2 deletions(-)
-
-diff --git a/elisp/geiser.el b/elisp/geiser.el
-index 887b8da..96c1dd6 100644
---- a/elisp/geiser.el
-+++ b/elisp/geiser.el
-@@ -104,6 +104,9 @@
- ;;;###autoload
- (autoload 'geiser-mode--maybe-activate "geiser-mode")
-
-+;;;###autoload
-+(autoload 'geiser-activate-implementation "geiser-impl")
-+
- ;;;###autoload
- (mapc (lambda (group)
- (custom-add-load group (symbol-name group))
---
-GitLab
--
2.31.1
David Dashyan wrote 4 years ago
[PATCH 2/3] gnu: Add emacs-geiser-racket.
(address . 48635@debbugs.gnu.org)(name . David Dashyan)(address . mail@davie.li)
20210524213932.1848-1-mail@davie.li
---
gnu/packages/emacs-xyz.scm | 44 ++++++++++++++++++++++++++++++++++++++
1 file changed, 44 insertions(+)

Toggle diff (64 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 46e28e6cbe..089d57f5f1 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -187,6 +187,7 @@
#:use-module (gnu packages package-management)
#:use-module (gnu packages perl)
#:use-module (gnu packages pdf)
+ #:use-module (gnu packages racket)
#:use-module (gnu packages ruby)
#:use-module (gnu packages rust-apps)
#:use-module (gnu packages scheme)
@@ -360,6 +361,49 @@ using geiser.")
a generic Scheme interaction mode for the GNU Emacs editor.")
(license license:expat)))
+(define-public emacs-geiser-racket
+ (package
+ (name "emacs-geiser-racket")
+ (version "0.16")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/emacs-geiser/racket.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1aqsvmk1hi7kc3j4h8xlza7c6rwm71v98fv5wpw8kmyj9vsp49wx"))))
+ (build-system emacs-build-system)
+ (arguments
+ '(#:include (cons "^src/" %default-include)
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'make-autoloads 'patch-autoloads
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* (string-append
+ (elpa-directory (assoc-ref outputs "out"))
+ "/geiser-racket-autoloads.el")
+ ;; Activating implementations fails when Geiser is not yet
+ ;; loaded, so let's defer that until it is.
+ (("\\(geiser-activate-implementation .*\\)" all)
+ (string-append
+ "(eval-after-load 'geiser-impl '" all ")"))
+ (("\\(geiser-implementation-extension .*\\)" all)
+ (string-append
+ "(eval-after-load 'geiser-impl '" all ")")))
+ #t)))))
+ (inputs
+ `(("racket" ,racket)))
+ (propagated-inputs
+ `(("geiser" ,emacs-geiser)))
+ (home-page "https://nongnu.org/geiser/")
+ (synopsis "Racket support for Geiser")
+ (description
+ "This package adds support for the Racket implementation to Geiser,
+a generic Scheme interaction mode for the GNU Emacs editor.")
+ (license license:bsd-3)))
+
(define-public emacs-vc-hgcmd
(package
(name "emacs-vc-hgcmd")
--
2.31.1
David Dashyan wrote 4 years ago
[PATCH 3/3] gnu: emacs-geiser-guile: Update to 0.17.
(address . 48635@debbugs.gnu.org)(name . David Dashyan)(address . mail@davie.li)
20210524214038.2172-1-mail@davie.li
---
gnu/local.mk | 1 -
gnu/packages/emacs-xyz.scm | 6 ++--
.../emacs-geiser-guile-auto-activate.patch | 34 -------------------
3 files changed, 2 insertions(+), 39 deletions(-)
delete mode 100644 gnu/packages/patches/emacs-geiser-guile-auto-activate.patch

Toggle diff (78 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index d772128518..b0df9d582d 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -972,7 +972,6 @@ dist_patch_DATA = \
%D%/packages/patches/emacs-exec-path.patch \
%D%/packages/patches/emacs-exwm-fix-fullscreen-states.patch \
%D%/packages/patches/emacs-fix-scheme-indent-function.patch \
- %D%/packages/patches/emacs-geiser-guile-auto-activate.patch \
%D%/packages/patches/emacs-ignore-empty-xim-styles.patch \
%D%/packages/patches/emacs-json-reformat-fix-tests.patch \
%D%/packages/patches/emacs-highlight-stages-add-gexp.patch \
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 089d57f5f1..4959949cb3 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -271,7 +271,7 @@ e.g. emacs-geiser-guile for Guile.")
(define-public emacs-geiser-guile
(package
(name "emacs-geiser-guile")
- (version "0.13")
+ (version "0.17")
(source
(origin
(method git-fetch)
@@ -280,9 +280,7 @@ e.g. emacs-geiser-guile for Guile.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0w264pjwlxna31260ll6gd0n77jlynhzf3h2dws5wr7jflns5mbc"))
- (patches (search-patches
- "emacs-geiser-guile-auto-activate.patch"))))
+ (base32 "0iw23nlgqppf6f00ly50m8lq85n9mv244pw3whxv0hynfjxr2ic0"))))
(build-system emacs-build-system)
(arguments
'(#:include (cons "^src/" %default-include)
diff --git a/gnu/packages/patches/emacs-geiser-guile-auto-activate.patch b/gnu/packages/patches/emacs-geiser-guile-auto-activate.patch
deleted file mode 100644
index 44837f90df..0000000000
--- a/gnu/packages/patches/emacs-geiser-guile-auto-activate.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From 93ef7101fdfcc7eac6f465b4b9788c384a323c14 Mon Sep 17 00:00:00 2001
-From: jao <jao@gnu.org>
-Date: Mon, 5 Apr 2021 20:17:50 +0100
-Subject: [PATCH] fix: auto-activate guile implementation
-
----
- geiser-guile.el | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/geiser-guile.el b/geiser-guile.el
-index 340442b..deeb76f 100644
---- a/geiser-guile.el
-+++ b/geiser-guile.el
-@@ -25,6 +25,7 @@
- (require 'geiser-syntax)
- (require 'geiser-custom)
- (require 'geiser-repl)
-+(require 'geiser-impl)
- (require 'geiser-base)
- (require 'geiser-eval)
- (require 'geiser-edit)
-@@ -474,6 +475,9 @@ it spawn a server thread."
-
- (geiser-impl--add-to-alist 'regexp "\\.scm$" 'guile t)
-
-+;;;###autoload
-+(geiser-activate-implementation 'guile)
-+
- ;;;###autoload
- (autoload 'run-guile "geiser-guile" "Start a Geiser Guile REPL." t)
-
---
-GitLab
-
--
2.31.1
Sharlatan Hellseher wrote 4 years ago
Related
(address . 48635@debbugs.gnu.org)
CAO+9K5pN2YObdofRpd=Bnprsni38B_+Zd1-hfDN76pgg6xWKPg@mail.gmail.com
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
Nicolas Goaziou wrote 4 years ago
Re: [bug#48635] [PATCH 2/3] gnu: Add emacs-geiser-racket.
(name . David Dashyan)(address . mail@davie.li)(address . 48635-done@debbugs.gnu.org)
87sg2b5f4e.fsf@nicolasgoaziou.fr
Hello,

David Dashyan <mail@davie.li> writes:

Toggle quote (4 lines)
> ---
> gnu/packages/emacs-xyz.scm | 44 ++++++++++++++++++++++++++++++++++++++
> 1 file changed, 44 insertions(+)

Thank you!

I tweaked the commit message and applied this patch. I dropped the other
two because they were a duplicate of bug#48537.

I forgot to add a copyright line for you in "emacs-xyz.scm". I'll do
that shortly.

Regards,
--
Nicolas Goaziou
Closed
David Dashyan wrote 4 years ago
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 48635-done@debbugs.gnu.org)
87im33dny6.fsf@davie.li
Nicolas Goaziou writes:
Toggle quote (3 lines)
> I tweaked the commit message and applied this patch. I dropped the other
> two because they were a duplicate of bug#48537.

Thank you Nicolas!

--
David aka zzappie
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 48635@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 48635
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help