[PATCH 1/1]: gnu: cl-trivial-features: Update to 1.0

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 4 years ago
(address . guix-patches@gnu.org)
CAO+9K5q2tNLPDgWVuyCc-sNCM8Kq3CQG6-QAzHPe+15ySE74uw@mail.gmail.com
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
From afc1bd8b4b80962c4866c33a98fed601fe44f0a8 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Sat, 22 May 2021 20:45:09 +0100
Subject: [PATCH] gnu: cl-trivial-features: Update to 1.0

* gnu/packages/lisp-xyz.scm (sbcl-trivial-features)
[package]: Use upstream latest tag from <2021-02-28>
[arguments]: Add comments of desabled tests reason
---
gnu/packages/lisp-xyz.scm | 48 +++++++++++++++++++++------------------
1 file changed, 26 insertions(+), 22 deletions(-)

Toggle diff (62 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 04a245befd..5355c21678 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -1360,29 +1360,33 @@ utilities that make it even easier to manipulate text in Common Lisp. It has
(sbcl-package->ecl-package sbcl-cl-strings))
(define-public sbcl-trivial-features
- ;; No release since 2014.
- (let ((commit "870d03de0ed44067963350936856e17ee725153e"))
- (package
- (name "sbcl-trivial-features")
- (version (git-version "0.8" "1" commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/trivial-features/trivial-features")
- (commit commit)))
- (file-name (git-file-name "trivial-features" version))
- (sha256
- (base32 "14pcahr8r2j3idhyy216zyw8jnj1dnrx0qbkkbdqkvwzign1ah4j"))))
- (build-system asdf-build-system/sbcl)
- (arguments
- '(#:asd-files '("trivial-features.asd")
- #:tests? #f))
- (home-page "https://cliki.net/trivial-features")
- (synopsis "Ensures consistency of @code{*FEATURES*} in Common Lisp")
- (description "Trivial-features ensures that @code{*FEATURES*} is
+ (package
+ (name "sbcl-trivial-features")
+ (version "1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/trivial-features/trivial-features")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name "trivial-features" version))
+ (sha256
+ (base32 "0jsqah1znzqilxnw5vannb083ayk0d7phkackqzwwqkyg5hpn6pq"))))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ '(#:asd-files '("trivial-features.asd")
+ ;; FIXME: (Sharlatan-20210522T204148+0100): When testes are enabled
+ ;; they require `cffi', but it hangs after build phase for 4-8min then
+ ;; exit with error to increase HEAP space for Guile, it seams to me
+ ;; like a circular dependencies somewhere.
+ #:tests? #f))
+ ;; (native-inputs
+ ;; `(("cffi" ,sbcl-cffi)))
+ (home-page "https://cliki.net/trivial-features")
+ (synopsis "Ensures consistency of @code{*FEATURES*} in Common Lisp")
+ (description "Trivial-features ensures that @code{*FEATURES*} is
consistent across multiple Common Lisp implementations.")
- (license license:expat))))
+ (license license:expat)))
(define-public cl-trivial-features
(sbcl-package->cl-source-package sbcl-trivial-features))
--
2.31.1
Guillaume Le Vaillant wrote 4 years ago
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 48590-done@debbugs.gnu.org)
87tumtbrwj.fsf@kitej
Patch pushed as d49402ab45486347cddfd000951a69f0c872cfda.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYKo+/A8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j81VwD/ZAnbMFdrs0u9lQ9EZJa3XQtTjQw3vOlAbLEm
f7W3bO0A/ip51jZkJBS/UW6fvcctJsTWZNpt+TFYC62nv60XEo+4
=hJD2
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 48590@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 48590
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help