[PATCH WIP] gnu: Add tagainijisho.

  • Open
  • quality assurance status badge
Details
2 participants
  • Nicolò Balzarotti
  • Sarah Morgensen
Owner
unassigned
Submitted by
Nicolò Balzarotti
Severity
normal
N
N
Nicolò Balzarotti wrote on 21 May 2021 18:29
[WIP] [PATCH] Add
(address . guix-patches@gnu.org)
87v97ct5ii.fsf@guixSD.i-did-not-set--mail-host-address--so-tickle-me
Hi!

I created a package for tagainijisho and its dependency (kanjivg).

I marked this as WIP because I have a few doubts:
- kanjivg distributes an xml file generated by joining xml files stored
in the repo. I'm not sure where this xml should be installed
(under /share/something?)
- kanjivg: guix lint fails with: updater 'github' failed to find
upstream releases, but I don't know why
- two other xml required by tagainijisho use non-versioned urls, is
there something we can do about this?

It's the first time I use this program but it seems to be working ok.

Thanks,
Nicolò
From fa44401753d5c70f0e177270072b8eb70d166dd6 Mon Sep 17 00:00:00 2001
From: nixo <nicolo@nixo.xyz>
Date: Fri, 21 May 2021 18:15:04 +0200
Subject: [PATCH 1/2] gnu: Add kanjivg.

* gnu/packages/education.scm (kanjivg): New variable.
---
gnu/packages/education.scm | 44 ++++++++++++++++++++++++++++++++++++++
1 file changed, 44 insertions(+)

Toggle diff (57 lines)
diff --git a/gnu/packages/education.scm b/gnu/packages/education.scm
index 0986d2a19e..043933abe0 100644
--- a/gnu/packages/education.scm
+++ b/gnu/packages/education.scm
@@ -405,6 +405,50 @@ specialized device.")
(home-page "https://bipede.fr/contrib/")
(license license:gpl3)))
+(define-public kanjivg
+ (package
+ (name "kanjivg")
+ (version "20160426")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/KanjiVG/kanjivg")
+ (commit (string-append "r" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "10pkcay9zixr0nwwcm4z360w7pkcr1v91kp7889qbsfj8123mywh"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no check target
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'build
+ (lambda _
+ (invoke "python" "kvg.py" "release")))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (fname "kanjivg.xml"))
+ (mkdir-p out)
+ ;; FIXME: No idea in which path it should be copied (and if
+ ;; other files are needed)
+ (copy-file fname (string-append out "/" fname))))))))
+ (native-inputs
+ ;; Does not work with python3
+ `(("python2" ,python-2)))
+ (synopsis "Kanji description and vectorial data in correct stroke order")
+ (description "KanjiVG is a description of the sinographs (or kanji) used
+by the Japanese language. For each character, it provides a SVG file that
+gives the shape, direction and of each of its strokes. This file is also
+enriched with exhaustive information about the components of the character,
+the type of stroke employed, etc.
+
+Using KanjiVG, it is possible to create stroke order diagrams or animations
+and kanji dictionaries.")
+ (home-page "https://kanjivg.tagaini.net")
+ (license license:cc-by-sa3.0)))
(define-public childsplay
(package
(name "childsplay")
--
2.31.1
S
S
Sarah Morgensen wrote on 7 Aug 2021 08:49
control message for bug #48570
(address . control@debbugs.gnu.org)
E1mCG95-0000hY-0U@debbugs.gnu.org
retitle 48570 [PATCH WIP] gnu: Add tagainijisho.
quit
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 48570@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 48570
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch