(name . bug-guix)(address . bug-guix@gnu.org)
Hello,
I just noticed about this problem following a reboot. I can also
reproduce it in 'guix system vm', simply adding the opendht-service-type
to my operating-system declaration.
The boot proceeds until 'error in finalization thread: Success' then
hangs indefinitely.
What is troubling for me is that the service is rather straightforwardly
defined. It uses the make-forkexec-constructor/container like so:
Toggle snippet (15 lines)
(define (opendht-shepherd-service config)
"Return a <shepherd-service> running OpenDHT."
(shepherd-service
(documentation "Run an OpenDHT node.")
(provision '(opendht dhtnode dhtproxy))
(requirement '(user-processes syslogd))
(start #~(make-forkexec-constructor/container
(list #$@(opendht-configuration->command-line-arguments config))
#:mappings (list (file-system-mapping
(source "/dev/log") ;for syslog
(target source)))
#:user "opendht"))
(stop #~(make-kill-destructor))))
I'm not sure how using such basic building blocks could lead to a hang
in Shepherd ?
Thanks,
Maxim