[PATCH 2/2]: gnu: common-lisp-jupyter: Update to 0.1.0-3.ba9f0e7

  • Done
  • quality assurance status badge
Details
3 participants
  • Guillaume Le Vaillant
  • Jack Hill
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 4 years ago
(address . guix-patches@gnu.org)
CAO+9K5q_qxNWx63jPYHOAR_1BkiORat8hG4i=khO7Fx-UhR8xA@mail.gmail.com
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
From 178aab2b39001310997da838ecba33c313a92562 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Mon, 17 May 2021 20:43:47 +0100
Subject: [PATCH 2/2] gnu: common-lisp-jupyter: Update to 0.1.0-3.ba9f0e7

* gnu/packages/lisp-xyz.scm (sbcl-common-lisp-jupyter)
[version]: Refactor format
[inputs]: Add `dissect`, replace jsown to `shasht`
---
gnu/packages/lisp-xyz.scm | 12 +++++++-----
1 file changed, 7 insertions(+), 5 deletions(-)

Toggle diff (46 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index ce8c61eefe..7c647c7fb2 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -14878,10 +14878,11 @@ and @code{doseq*}.")
(sbcl-package->cl-source-package sbcl-trivial-do))
(define-public sbcl-common-lisp-jupyter
- (let ((commit "011f60b69a3b8c70eefeafe7acb724cd00dd3e62"))
+ (let ((commit "ba9f0e746b9200d6fd6db647d7274448119ed01b")
+ (revision "3"))
(package
(name "sbcl-common-lisp-jupyter")
- (version (git-version "0.1" "2" commit))
+ (version (git-version "0.1.0" revision commit))
(source
(origin
(method git-fetch)
@@ -14890,7 +14891,7 @@ and @code{doseq*}.")
(commit commit)))
(file-name (git-file-name name commit))
(sha256
- (base32 "10jdghlcmp9p6ygrvw7g49i8f9jy71ybzn29n544fzb6g47siqhw"))))
+ (base32 "0si69xfzi769dprwfy7gp1x3bl7lxz6d4n98sa26w9r41wvay5ja"))))
(build-system asdf-build-system/sbcl)
(inputs
`(("alexandria" ,sbcl-alexandria)
@@ -14899,13 +14900,14 @@ and @code{doseq*}.")
("cl-base64" ,sbcl-cl-base64)
("cl-indentify" ,sbcl-cl-indentify)
("closer-mop" ,sbcl-closer-mop)
+ ("dissect" ,sbcl-dissect)
("eclector" ,sbcl-eclector)
("ironclad" ,sbcl-ironclad)
("iterate" ,sbcl-iterate)
- ("jsown" ,sbcl-jsown)
("multilang-documentation" ,sbcl-multilang-documentation)
- ("pzmq" ,sbcl-pzmq)
("puri" ,sbcl-puri)
+ ("pzmq" ,sbcl-pzmq)
+ ("shasht" ,sbcl-shasht)
("static-vectors" ,sbcl-static-vectors)
("trivial-do" ,sbcl-trivial-do)
("trivial-garbage" ,sbcl-trivial-garbage)
--
2.31.1
Sharlatan Hellseher wrote 4 years ago
[PATCH 1/2]: gnu: Add shasht
(address . 48485@debbugs.gnu.org)
CAO+9K5qmVdm+aE=dMWsHH80T-JAacd9AAVCHrwLQ+Q4_T==gnw@mail.gmail.com
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
From f99196cff24a7802f143797f7a842960fcdf2323 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Mon, 17 May 2021 20:32:18 +0100
Subject: [PATCH 1/2] gnu: Add shasht

* gnu/packages/lisp-xyz.scm (sbcl-shasht, ecl-shasht, cl-shasht): New variables.
---
gnu/packages/lisp-xyz.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 64955a13f6..ce8c61eefe 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -16644,3 +16644,36 @@ all kind of typesetting applications.")
(define-public cl-typesetting
(sbcl-package->cl-source-package sbcl-cl-typesetting))
+
+(define-public sbcl-shasht
+ (let ((commit "4055327ef8e2aaa8627892ab256350ff3cb15e3c")
+ (revision "1"))
+ (package
+ (name "sbcl-shasht")
+ (version (git-version "0.1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/yitzchak/shasht.git")
+ (commit commit)))
+ (file-name (git-file-name "shasht" version))
+ (sha256
+ (base32 "01mh20s5gj0lajq45anxji77ykq1wcg72mn1y9a1k8i7q1ainjlr"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("alexandria" ,sbcl-alexandria)
+ ("parachute" ,sbcl-parachute)
+ ("trivial-do" ,sbcl-trivial-do)))
+ (home-page "https://yitzchak.github.io/shasht/")
+ (synopsis "Common Lisp JSON reading and writing for the Kzinti")
+ (description
+ "This package provides a Common Lisp library to work with JSON file
+format.")
+ (license license:expat))))
+
+(define-public ecl-shasht
+ (sbcl-package->ecl-package sbcl-shasht))
+
+(define-public cl-shasht
+ (sbcl-package->cl-source-package sbcl-shasht))
--
2.31.1
Guillaume Le Vaillant wrote 4 years ago
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 48485-done@debbugs.gnu.org)
87r1i4v5q1.fsf@kitej
Patches pushed as ff11a9f449e2f259faabebd075ce2ae1e13d27c2 and following
with a few modifications:
- shasht: alexandria and parachute moved to native-inputs as they are
only used for the tests.
- common-lisp-jupyter: license changed to expat/MIT as this is what is
indicated upstream.

Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYKNyRg8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j9ASAD+IAaUEweqX2hE9R/rrNSie2zspQfUSNVj+Ly7
cRYA80UA/iMfDlg/gMo2xZDGLLSdhS2ctX/510w9xmw1XE92GY8c
=GrMP
-----END PGP SIGNATURE-----

Closed
Jack Hill wrote 4 years ago
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
alpine.DEB.2.21.2105181145560.2109@marsh.hcoop.net
Thanks for working on this. However, I have a question about the synopsis:

Toggle quote (2 lines)
> + (synopsis "Common Lisp JSON reading and writing for the Kzinti")

As a native American English speaker, I find Kzinti to be an obscure word.
I didn't know what it meant when I first read it. Doing a search online
wasn't that enlightening. The best thing I could fine talked about alien
cats [0]. Do you think the synopsis could be improved in the future to
more clearly say what the software is for and improve search results?
Perhaps shortening it to "Common Lisp JSON reading and writing" would be
sufficient?


Best,
Jack
Guillaume Le Vaillant wrote 4 years ago
(name . Jack Hill)(address . jackhill@jackhill.us)
87o8d8uh9l.fsf@kitej
Jack Hill <jackhill@jackhill.us> skribis:

Toggle quote (16 lines)
> Thanks for working on this. However, I have a question about the synopsis:
>
>> + (synopsis "Common Lisp JSON reading and writing for the Kzinti")
>
> As a native American English speaker, I find Kzinti to be an obscure word.
> I didn't know what it meant when I first read it. Doing a search online
> wasn't that enlightening. The best thing I could fine talked about alien cats
> [0]. Do you think the synopsis could be improved in the future to more clearly
> say what the software is for and improve search results? Perhaps shortening it
> to "Common Lisp JSON reading and writing" would be sufficient?
>
> [0] https://en.wikipedia.org/wiki/Kzin
>
> Best,
> Jack

Before pushing Sharlatan's patch, I changed the synopsis to "Common Lisp
JSON reading and writing library". I also didn't know that word, found
that it was probably a reference to a cat-looking warrior from space in
a series of science fiction novels, and concluded that it was not
really related to JSON processing.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYKPuFg8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j/fzwD+Pl4lroxezQoD0834nSODMvMJylczPhrNMrXr
qvn7LWQA/2G12GYuZV3wCAaJELBTqPXcF29tgNV1PnMCED1g127n
=hucd
-----END PGP SIGNATURE-----

Jack Hill wrote 4 years ago
(name . Guillaume Le Vaillant)(address . glv@posteo.net)
alpine.DEB.2.21.2105181248320.2109@marsh.hcoop.net
On Tue, 18 May 2021, Guillaume Le Vaillant wrote:

Toggle quote (24 lines)
> Jack Hill <jackhill@jackhill.us> skribis:
>
>> Thanks for working on this. However, I have a question about the synopsis:
>>
>>> + (synopsis "Common Lisp JSON reading and writing for the Kzinti")
>>
>> As a native American English speaker, I find Kzinti to be an obscure word.
>> I didn't know what it meant when I first read it. Doing a search online
>> wasn't that enlightening. The best thing I could fine talked about alien cats
>> [0]. Do you think the synopsis could be improved in the future to more clearly
>> say what the software is for and improve search results? Perhaps shortening it
>> to "Common Lisp JSON reading and writing" would be sufficient?
>>
>> [0] https://en.wikipedia.org/wiki/Kzin
>>
>> Best,
>> Jack
>
> Before pushing Sharlatan's patch, I changed the synopsis to "Common Lisp
> JSON reading and writing library". I also didn't know that word, found
> that it was probably a reference to a cat-looking warrior from space in
> a series of science fiction novels, and concluded that it was not
> really related to JSON processing.

Happy to here that I wasn't alone in thinking that. I guess it's time to
`guix pull` and benefit from the new packages.

Thanks!
Jack
?
Your comment

This issue is archived.

To comment on this conversation send an email to 48485@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 48485
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help