Add: mariadb-connector-python

  • Open
  • quality assurance status badge
Details
One participant
  • Simon Streit
Owner
unassigned
Submitted by
Simon Streit
Severity
normal
S
S
Simon Streit wrote on 16 May 2021 21:20
(address . guix-patches@gnu.org)
ygu4kf2xz7a.fsf@netpanic.org
Hello,

please find attached a patch to add mariadb-connector-python.

Please note, that although this package uses the python build system,
and is available in pypi, the package follows the naming convention that
closely resembles its sister package `mariadb-connector-c', which it
also depends on.

I think it might be better to adapt the naming scheme to avoid any
confusions.

I also checked the licensing too. Apparently the source code reads
LGPLv2.1, while the pypi summary page says it is LGPLv2+. So I kept it
at v2.1.


Cheers
Simon
From b76d2c42ce6a5d6060fef657718f594654176cbc Mon Sep 17 00:00:00 2001
From: Simon Streit <simon@netpanic.org>
Date: Sun, 16 May 2021 19:53:09 +0200
Subject: [PATCH] gnu: Add: mariadb-connector-python.

* gnu/packages/databases.scm (mariadb-connector-python): New variable.
---
gnu/packages/databases.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 8907c40166..cee2354f36 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -51,6 +51,7 @@
;;; Copyright © 2021 David Larsson <david.larsson@selfhosted.xyz>
;;; Copyright © 2021 Pjotr Prins <pjotr.guix@thebird.nl>
;;; Copyright © 2021 Bonface Munyoki Kilyungi <me@bonfacemunyoki.com>
+;;; Copyright © 2021 Simon Streit <simon@netpanic.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3946,3 +3947,28 @@ PostreSQL, SQLite, ODBC and MySQL.")
"FreeTDS is an implementation of the Tabular DataStream protocol, used for
connecting to MS SQL and Sybase servers over TCP/IP.")
(license license:lgpl2.0+)))
+
+(define-public mariadb-connector-python
+ (package
+ (name "mariadb-connector-python")
+ (version "1.0.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "mariadb" version))
+ (sha256
+ (base32
+ "06vy4pdw5ls0d2jkffcb010fjzd544lhmhqmgamaa8lffkq95dmf"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("mariadb-connector-c" ,mariadb-connector-c)))
+ (inputs
+ `(("mariadb" ,mariadb "dev")))
+ (home-page
+ "https://www.github.com/mariadb-corporation/mariadb-connector-python")
+ (synopsis "Client library to connect to MariaDB or MySQL databases for Python")
+ (description "MariaDB Connector/Python enables python programs to
+access MariaDB and MySQL databases, using an API which is compliant
+with the Python DB API 2.0 (PEP-249). It is written in C and uses
+MariaDB Connector/C client library for client server communication.")
+ (license license:lgpl2.1)))
--
2.31.1
?