(name . Guix Patches)(address . guix-patches@gnu.org)
From 4804e417e9e131022a1f9f4a155b30cf85cc5eec Mon Sep 17 00:00:00 2001
From: Adam Kandur <rndd@tuta.io>
Date: Sun, 16 May 2021 18:47:39 +0300
Subject: [PATCH] gnu: Add python-pyglet.
* gnu/packages/python-xyz.scm (python-pyglet): New variable.
---
gnu/packages/python-xyz.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)
Toggle diff (37 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f79fc54e24..b1d51b6a26 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4022,6 +4022,32 @@ text styles of documentation.")
(description "This package installs Github custom lexers to Pygments.")
(license license:bsd-3)))
+(define-public python-pyglet
+ (package
+ (name "python-pyglet")
+ ;; as mentioned in README, this is the stable branch
+ (version "pyglet-1.5-maintenance")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pyglet/pyglet")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1f90pc21x4rq1qp0qddk111h4kyivhhcfc8k0mx67k89rz9hcrm2"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f)) ; FIXME: tests are failing.
+ (native-inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (home-page "https://github.com/pyglet/pyglet")
+ (synopsis "pyglet is a cross-platform windowing and multimedia library for Python")
+ (description "This library is intended for developing games and other visually rich applications.
+It supports windowing, user interface event handling, Joysticks, OpenGL graphics, loading images and videos,
+and playing sounds and music.")
+ (license license:bsd-3)))
+
(define-public python-bump2version
(package
(name "python-bump2version")
--
2.31.1