[PATCH] gnu: Add python-pyglet.

  • Done
  • quality assurance status badge
Details
2 participants
  • Adam Kandur
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Adam Kandur
Severity
normal
A
A
Adam Kandur wrote on 16 May 2021 17:52
(name . Guix Patches)(address . guix-patches@gnu.org)
M_ps9xo--3-2@tuta.io
From 4804e417e9e131022a1f9f4a155b30cf85cc5eec Mon Sep 17 00:00:00 2001
From: Adam Kandur <rndd@tuta.io>
Date: Sun, 16 May 2021 18:47:39 +0300
Subject: [PATCH] gnu: Add python-pyglet.

* gnu/packages/python-xyz.scm (python-pyglet): New variable.
---
gnu/packages/python-xyz.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f79fc54e24..b1d51b6a26 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4022,6 +4022,32 @@ text styles of documentation.")
     (description "This package installs Github custom lexers to Pygments.")
     (license license:bsd-3)))

+(define-public python-pyglet
+    (package
+      (name "python-pyglet")
+      ;; as mentioned in README, this is the stable branch
+      (version "pyglet-1.5-maintenance")
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+        (url "https://github.com/pyglet/pyglet")
+        (commit version)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1f90pc21x4rq1qp0qddk111h4kyivhhcfc8k0mx67k89rz9hcrm2"))))
+      (build-system python-build-system)
+      (arguments
+       '(#:tests? #f)) ; FIXME: tests are failing.
+      (native-inputs
+       `(("python-setuptools" ,python-setuptools)))
+      (home-page "https://github.com/pyglet/pyglet")
+      (synopsis "pyglet is a cross-platform windowing and multimedia library for Python")
+      (description "This library is intended for developing games and other visually rich applications. 
+It supports windowing, user interface event handling, Joysticks, OpenGL graphics, loading images and videos,
+and playing sounds and music.")
+      (license license:bsd-3)))
+
(define-public python-bump2version
   (package
     (name "python-bump2version")
--
2.31.1
S
S
Sharlatan Hellseher wrote on 18 Oct 22:15 +0200
(address . 48467-done@debbugs.gnu.org)
877ca5p3qh.fsf@gmail.com
Hi,

I've combined efforts and refresh package from:

- 48467 [PATCH] gnu: Add python-pyglet.
;;; Copyright © 2021 Adam Kandur <kefironpremise@gmail.com>
- 50505 [PATCH 00/12] gnu: Add python-manim
;;; Copyright © 2021 Daniel Meißner <daniel.meissner-i4k@ruhr-uni-bochum.de>
- 52116 [PATCH 0/2] gnu: Add printrun.
;;; Copyright © 2021 Morgan Smith <Morgan.J.Smith@outlook.com>
- 67131 [PATCH 0/7] gnu: Add tuxemon.
;;; Copyright © 2023 Adam Faiz <adam.faiz@disroot.org>

Pushed as 88471af678959b1eb4e357a47293030d05de8658 to master.

--
Thanks,
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmcSwdYACgkQdtcnv/Ys
0rXj6BAAsWh9ej/g4fVCEc31yjMcU5vlFHNtXCJ146gduLcE469xD9PGgS5U0a46
G4dz7pfsseQHrn/JIEnF1iDY7NBonYKeHl1YNIuoHzXVPdJTo5XyW4HNW3I0BaNR
7WF+PNPu7t9gogVUDjFkuT8No8MxKXuyrxoaNH0cFOiOP9pRFJNFmOQT6I1Kc7uV
2boNfbO6YCbpCJP69o38TB5GH2rsdQztmVIDZFxrsdlYJbW6EG9UJ2DZWSfLOztc
mcah68KxHX/rJXFeacATZEBtM/2cT/5cpF2XBLWwxn2kfmM+uxqN+e6KYOuUPqfa
v7UV73xsRyPBRtSMv6npWe/H9ysr1u3M3Xo8ABJokva3bPve8HrEcW/A0Ck1+56Y
7baUvcaqxqEuRdp1euBLmj45n84rD/RpPOftCSvFFz85ckFIg2/HAdIHRAJHwbD+
BnC5dYFAC+Q1Y6Ym36q+qlk1VcE8W5lEtupOFVaZMVHtssZM+phnVcM3c5ZSoKmz
GaY7cmwgBVNjNCK2uqLKzzTmHH2IrNFzvpRlsgE2DF0MwcBsP1urjSWwxjnwQ+qK
7TvBPxwlLJtlhN06Ctk8C+ewDIfNuNjkd7WxKckYn8ZHVWf5ylzpHHuebkM/hgVP
2Ub5sh2eiXS3KmmxlVlXVIdW+MzETAaGl5YHX73FeoOCBPcZ2RU=
=quDS
-----END PGP SIGNATURE-----

Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 48467@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 48467
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch