[PATCH 1/1]: Add assay

  • Done
  • quality assurance status badge
Details
One participant
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal
S
S
Sharlatan Hellseher wrote on 15 May 2021 22:52
(address . guix-patches@gnu.org)
CAO+9K5rTZU_tF3BMS9Q2_bjfb9BSpqn=GsrrqT_c_c03PA911w@mail.gmail.com
--
… ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
From 7887efb4854ce131e67ba64e559b91317e843886 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Wed, 5 May 2021 23:05:39 +0100
Subject: [PATCH] gnu: Add assay

* gnu/packages/python-check.scm (python-assay): New variable
---
gnu/packages/python-check.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (32 lines)
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 01922b0d9d..cdbeb8fbfc 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -1389,3 +1389,25 @@ allows one to create a set of tests using @emph{pairwise combinations} method,
reducing a number of combinations of variables into a lesser set that covers
most situations.")
(license license:expat)))
+
+(define-public python-assay
+ (let ((commit "d61a16e060c50f9c1a97df84ad9960825031915e")
+ (revision "1"))
+ (package
+ (name "python-assay")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/brandon-rhodes/assay")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0shcbchwcdq1qqv8grfj34ap92mfm6l0hs9q69jb8gshnhsl8p7r"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/brandon-rhodes/assay")
+ (synopsis "Python testing framework")
+ (description
+ "Simple experimental Python testing framework")
+ (license license:expat))))
--
2.31.1
S
S
Sharlatan Hellseher wrote on 6 Nov 16:23 +0100
(address . 48454-done@debbugs.gnu.org)
87h68k4ca3.fsf@gmail.com
Added in fbece5a8e0f55d00c91edf082d01e1f9778a0913.

Closing.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmcridQACgkQdtcnv/Ys
0rUkxg/8CIA1ViRfm2oxAhhjUwTcVoF5e89rWHd0NPdj6lM9Oj6ZnlpXF0O+pCFv
hgFkN7KGXkyGd0krhNBEWFcPXYXDUm9X9yrCwue+oz8/bNIRD124UBYjXNNc0lpX
1Sw0cu9MrY7nPVRXcQjGI+gy5QdsvuA0uKlDYZ43ucp5FNEqWR39jAdNu8Y3UZWM
nGIveXTAdp9xIoF57+Z46OUfxyImPyKDCpswn0o4MDnRXuclB6rpG6q5WUpWbp2r
9BYTsLTmaKy+ymHe8pySswtABrZUX6pnp0wppLqrikAH+VwPvTIiM+ofew6dUy6s
1OwWBIq6sz2uiphULF5hZu7JSmj9wjNJvNO4+xGMJhSrTTHquvQDYX7scUWhSXK5
j4MNi4FWuOgbrRVoDPlNra3lfW+JcEA8x/m9aQe9Q8rWlCf53tode8IeLl9hxHdZ
dWFJgnuPFvWb4MWwHlVrCMns+XoLQqWCH5sQ96IU8EppkqDBUywN1T+J1b/NRe1U
wkyzo7n53qG/hHnB9OSLIaQX2z1XlrLp/m2P5b6ZuWISIOLmPDyszPoRhVWOhWwd
f2EokPfKYvK2e0tWWRkDAZlllxXIoul6sFc0Frgudm7H9Z+ipDwQkT8ZvnHJ2gwS
rTXrjE+6+8RyLmwg4xoMBb842tGzPMu07zxmhPeR0vAOz/f/6XI=
=2GjU
-----END PGP SIGNATURE-----

Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 48454@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 48454
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch