[PATCH 1/1]: Add assay

  • Open
  • quality assurance status badge
Details
One participant
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal
S
S
Sharlatan Hellseher wrote on 15 May 2021 22:52
(address . guix-patches@gnu.org)
CAO+9K5rTZU_tF3BMS9Q2_bjfb9BSpqn=GsrrqT_c_c03PA911w@mail.gmail.com
--
… ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
From 7887efb4854ce131e67ba64e559b91317e843886 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Wed, 5 May 2021 23:05:39 +0100
Subject: [PATCH] gnu: Add assay

* gnu/packages/python-check.scm (python-assay): New variable
---
gnu/packages/python-check.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (32 lines)
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 01922b0d9d..cdbeb8fbfc 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -1389,3 +1389,25 @@ allows one to create a set of tests using @emph{pairwise combinations} method,
reducing a number of combinations of variables into a lesser set that covers
most situations.")
(license license:expat)))
+
+(define-public python-assay
+ (let ((commit "d61a16e060c50f9c1a97df84ad9960825031915e")
+ (revision "1"))
+ (package
+ (name "python-assay")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/brandon-rhodes/assay")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0shcbchwcdq1qqv8grfj34ap92mfm6l0hs9q69jb8gshnhsl8p7r"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/brandon-rhodes/assay")
+ (synopsis "Python testing framework")
+ (description
+ "Simple experimental Python testing framework")
+ (license license:expat))))
--
2.31.1
?