[PATCH 1/1]: Add cl-typesetting

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal
S
S
Sharlatan Hellseher wrote on 15 May 2021 22:49
(address . guix-patches@gnu.org)
CAO+9K5pnAuMZG-5RP=ir7YO=FvLf1mu5WKOFM5aWRYmavX9Z5g@mail.gmail.com
Hi Guix team!

Build of ecl version breaks because of ecl-xmls package, the build of
ecl-xmls breaks by itself as well.

Toggle snippet (36 lines)
phase `build' succeeded after 1.6 seconds starting phase `check'
Invoking ecl: "/gnu/store/pmg6fgkd59v8p52g186q3na0dx2bw3p1-ecl-21.2.1/bin/ecl"
"--eval" "(require :asdf)" "--eval" "(asdf:load-asd (truename
\"/gnu/store/97aiyiablqfph85bmkna350b4g7nchl1-ecl-xmls-3.0.2-1.18546f0/share/common-lisp/ecl/xmls/xmls.asd\"))"
"--eval" "(when (uiop:file-exists-p \"xmls-tests.asd\") (asdf:load-asd
(truename \"xmls-tests.asd\")))" "--eval" "(when (uiop:file-exists-p
\"xmls-test.asd\") (asdf:load-asd (truename \"xmls-test.asd\")))"
"--eval" "(when (uiop:file-exists-p \"tests.asd\") (asdf:load-asd
(truename \"tests.asd\")))" "--eval" "(when (uiop:file-exists-p
\"test.asd\") (asdf:load-asd (truename \"test.asd\")))" "--eval"
"(asdf:test-system \"xmls\")" "--eval" "(quit)" ;;; Loading
#P"/gnu/store/pmg6fgkd59v8p52g186q3na0dx2bw3p1-ecl-21.2.1/lib/ecl-21.2.1/asdf.fas"
An error occurred during initialization: There is no symbol :TEST in
package "XMLS". command
"/gnu/store/pmg6fgkd59v8p52g186q3na0dx2bw3p1-ecl-21.2.1/bin/ecl"
"--eval" "(require :asdf)" "--eval" "(asdf:load-asd (truename
\"/gnu/store/97aiyiablqfph85bmkna350b4g7nchl1-ecl-xmls-3.0.2-1.18546f0/share/common-lisp/ecl/xmls/xmls.asd\"))"
"--eval" "(when (uiop:file-exists-p \"xmls-tests.asd\") (asdf:load-asd
(truename \"xmls-tests.asd\")))" "--eval" "(when (uiop:file-exists-p
\"xmls-test.asd\") (asdf:load-asd (truename \"xmls-test.asd\")))"
"--eval" "(when (uiop:file-exists-p \"tests.asd\") (asdf:load-asd
(truename \"tests.asd\")))" "--eval" "(when (uiop:file-exists-p
\"test.asd\") (asdf:load-asd (truename \"test.asd\")))" "--eval"
"(asdf:test-system \"xmls\")" "--eval" "(quit)" failed with status 1
builder for `/gnu/store/ibfq58irvnmbl28xs2llg8d4bliqdr26-ecl-xmls-3.0.2-1.18546f0.drv'
failed with exit code 1 build of
/gnu/store/ibfq58irvnmbl28xs2llg8d4bliqdr26-ecl-xmls-3.0.2-1.18546f0.drv
failed View build log at
'/var/log/guix/drvs/ib/fq58irvnmbl28xs2llg8d4bliqdr26-ecl-xmls-3.0.2-1.18546f0.drv.bz2'.
cannot build derivation
`/gnu/store/rdpii2amg77ir8ncydjk3mbc3x0r1xs8-ecl-cl-typesetting-0.8.0-1.86eba98.drv':
1 dependencies couldn't be built guix build: error: build of
`/gnu/store/rdpii2amg77ir8ncydjk3mbc3x0r1xs8-ecl-cl-typesetting-0.8.0-1.86eba98.drv'
failed

--
… ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
From bd91fed654392674d1909b9b9da99ca43731c86f Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Sat, 15 May 2021 21:42:18 +0100
Subject: [PATCH] gnu: add: cl-typesetting

* gnu/packages/lisp-xyz.scm (sbcl-cl-typesetting, ecl-cl-typesetting,
cl-typesetting): New variables.
---
gnu/packages/lisp-xyz.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index efd18f21a3..cf4968d628 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -16602,3 +16602,39 @@ package locks across supported Common Lisp implementations.")
(define-public cl-package-locks
(sbcl-package->cl-source-package sbcl-cl-package-locks))
+
+(define-public sbcl-cl-typesetting
+ (let ((commit "86eba981fc4254addebecf765578ec350d6e3b75")
+ (revision "1"))
+ (package
+ (name "sbcl-cl-typesetting")
+ (version (git-version "0.8.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mbattyani/cl-typesetting")
+ (commit commit)))
+ (file-name (git-file-name "cl-typesetting" version))
+ (sha256
+ (base32 "0fcs5mq0gxfczbrg7ay8r4bf5r4g6blvpdbjkhcl8dapcikyn35h"))))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ ;; NOTE: (Sharlatan-20210515T213014+0100): Circular dependencies with
+ ;; cl-typegraph
+ `(#:tests? #f))
+ (inputs
+ `(("cl-pdf" ,sbcl-cl-pdf)
+ ("xmls" ,sbcl-xmls)))
+ (home-page "https://github.com/mbattyani/cl-typesetting")
+ (synopsis "Stand-alone Common Lisp typesetting system")
+ (description
+ "CL-TYPESETTING is a cross-platform Common Lisp typesetting library for
+all kind of typesetting applications.")
+ (license license:bsd-2))))
+
+(define-public ecl-cl-typesetting
+ (sbcl-package->ecl-package sbcl-cl-typesetting))
+
+(define-public cl-typesetting
+ (sbcl-package->cl-source-package sbcl-cl-typesetting))
--
2.31.1
G
G
Guillaume Le Vaillant wrote on 17 May 2021 10:52
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 48453-done@debbugs.gnu.org)
87fsylspwp.fsf@kitej
Patch pushed as 0d85c83602c58cf83117643571e56205cfaeadc9.
Thanks.


Sharlatan Hellseher <sharlatanus@gmail.com> skribis:

Toggle quote (3 lines)
> Build of ecl version breaks because of ecl-xmls package, the build of
> ecl-xmls breaks by itself as well.

I fixed the build of ecl-xmls by disabling tests in
9983dee6b0b4a3ccec263dce6810f06e70b2aba3, given that some of the code
required to run the tests in ECL is missing upstream.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYKIu1g8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j8/8AD/VNfsJzgjaj1l1o8mg2+3Wr5qBHigKzgzsBuo
kyysR+MBAKMR+yXSA5HaiaiDIXlm9z9x09gex7tdnXNKbxTECXxO
=zzf7
-----END PGP SIGNATURE-----

Closed
?