[PATCH 0/2] Add libkpathsea.

  • Done
  • quality assurance status badge
Details
2 participants
  • Thiago Jung Bauermann
  • Leo Prikler
Owner
unassigned
Submitted by
Leo Prikler
Severity
normal
L
L
Leo Prikler wrote on 15 May 2021 16:39
(address . guix-patches@gnu.org)
cd5aec2d967863cd640ae493b2c3f9cae0248b4d.camel@student.tugraz.at
Some nice thing for y'all who want to read .dvi files.
L
L
Leo Prikler wrote on 15 May 2021 16:42
[PATCH 1/2] gnu: Add texlive-libkpathsea.
(address . 48443@debbugs.gnu.org)
20210515144230.22035-1-leo.prikler@student.tugraz.at
* gnu/packages/tex.scm (texlive-libkpathsea): New variable.
---
gnu/packages/tex.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index b9eeb0e792..3e8384eaad 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -457,6 +457,38 @@ This package contains the binaries.")
(license (license:fsf-free "https://www.tug.org/texlive/copying.html"))
(home-page "https://www.tug.org/texlive/")))
+(define-public texlive-libkpathsea
+ (package/inherit texlive-bin
+ (name "texlive-libkpathsea")
+ (source
+ (origin
+ (inherit (package-source texlive-bin))
+ (snippet
+ `(begin
+ ,(origin-snippet (package-source texlive-bin))
+ (with-directory-excursion "texk"
+ (let ((preserved-directories '("." ".." "kpathsea")))
+ (for-each
+ delete-file-recursively
+ (scandir "."
+ (lambda (file)
+ (and (not (member file preserved-directories))
+ (eq? 'directory (stat:type (stat file)))))))))))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments texlive-bin)
+ ((#:configure-flags flags)
+ `(cons* "--disable-all-pkgs" "--enable-kpathsea"
+ "--enable-shared" ,flags))
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (delete 'configure-ghostscript-executable)
+ (delete 'use-code-for-new-poppler)
+ (delete 'patch-dvisvgm-build-files)
+ (delete 'disable-failing-test)
+ (replace 'postint
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (with-directory-excursion "texk/kpathsea"
+ (invoke "make" "install"))))))))))
(define texlive-docstrip
(package
--
2.31.1
L
L
Leo Prikler wrote on 15 May 2021 16:42
[PATCH 2/2] gnu: evince: Build with libkpathsea.
(address . 48443@debbugs.gnu.org)
20210515144230.22035-2-leo.prikler@student.tugraz.at
* gnu/packages/gnome.scm (evince)[inputs]: Add libkpathsea.
---
gnu/packages/gnome.scm | 4 +---
1 file changed, 1 insertion(+), 3 deletions(-)

Toggle diff (17 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index be458c07bb..93f74d8c95 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2592,9 +2592,7 @@ forgotten when the session ends.")
("ghostscript" ,ghostscript)
("poppler" ,poppler)
("libtiff" ,libtiff)
- ;; TODO:
- ;; Build libkpathsea as a shared library for DVI support.
- ;; ("libkpathsea" ,texlive-bin)
+ ("libkpathsea" ,texlive-libkpathsea)
("gnome-desktop" ,gnome-desktop)
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
("gspell" ,gspell)
--
2.31.1
T
T
Thiago Jung Bauermann wrote on 13 Jul 2021 02:32
Re: [bug#48443] [PATCH 1/2] gnu: Add texlive-libkpathsea.
(name . Leo Prikler)(address . leo.prikler@student.tugraz.at)(address . 48443@debbugs.gnu.org)
7264704.8eCzXKmJsZ@popigai
Hello Leo,

I have very little experience creating Guix packages, but I spent
some time working on the TeX Live ones recently so hopefully my comments
and suggestions below are helpful.

I like adding a separate package for libkpathsea, and it’s what other
distros such as Debian and Ubuntu do. Thank you for implementing it. I just
have a few comments below:

Em sábado, 15 de maio de 2021, às 11:42:29 -03, Leo Prikler escreveu:
Toggle quote (17 lines)
> * gnu/packages/tex.scm (texlive-libkpathsea): New variable.
> ---
> gnu/packages/tex.scm | 32 ++++++++++++++++++++++++++++++++
> 1 file changed, 32 insertions(+)
>
> diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
> index b9eeb0e792..3e8384eaad 100644
> --- a/gnu/packages/tex.scm
> +++ b/gnu/packages/tex.scm
> @@ -457,6 +457,38 @@ This package contains the binaries.")
> (license (license:fsf-free
> "https://www.tug.org/texlive/copying.html")) (home-page
> "https://www.tug.org/texlive/")))
>
> +(define-public texlive-libkpathsea
> + (package/inherit texlive-bin

According to a recent message from Ludo¹, ‘package/inherit’ is meant to be
used in specific situations, and IIUC it doesn’t apply here:

Toggle quote (4 lines)
> It should also be (package (inherit …) …) rather than (package/inherit
> …). The latter is only useful when defining variants of a package (same
> version, same code) where the same security updates would apply.

I also wonder whether inheriting from texlive-bin is the best option. One
disadvantage is that it makes this package too sensitive to changes in
texlive-bin. As an example, it doesn’t work anymore with the version in
core-updates because in the branch, the ‘postint’ phase has been renamed to
‘post-install’. Also, I assume many texlive-bin inputs aren’t needed for
texlive-kpathsea, causing unnecessary work when building
texlive-libkpathsea and packages depending on it such as evince.

In addition, if it were a separate package then texlive-bin could be made
to use it, rather than shipping its own copy.

Toggle quote (5 lines)
> + (name "texlive-libkpathsea")
> + (source
> + (origin
> + (inherit (package-source texlive-bin))

Perhaps a ‘texlive-source-src’ variable analogous to ‘texlive-extra-src’
and ‘texlive-texmf-src’ would be useful?

Toggle quote (27 lines)
> + (snippet
> + `(begin
> + ,(origin-snippet (package-source texlive-bin))
> + (with-directory-excursion "texk"
> + (let ((preserved-directories '("." ".." "kpathsea")))
> + (for-each
> + delete-file-recursively
> + (scandir "."
> + (lambda (file)
> + (and (not (member file
> preserved-directories)) + (eq? 'directory
> (stat:type (stat file))))))))))))) + (arguments
> + (substitute-keyword-arguments (package-arguments texlive-bin)
> + ((#:configure-flags flags)
> + `(cons* "--disable-all-pkgs" "--enable-kpathsea"
> + "--enable-shared" ,flags))
> + ((#:phases phases)
> + `(modify-phases ,phases
> + (delete 'configure-ghostscript-executable)
> + (delete 'use-code-for-new-poppler)
> + (delete 'patch-dvisvgm-build-files)
> + (delete 'disable-failing-test)
> + (replace 'postint
> + (lambda* (#:key inputs outputs #:allow-other-keys)
> + (with-directory-excursion "texk/kpathsea"
> + (invoke "make" "install"))))))))))

If you decide to continue inheriting from texlive-bin, you’d also need to
change the synopsis and description.

--
Thanks,
Thiago


L
L
Leo Prikler wrote on 13 Jul 2021 09:56
[PATCH v2 2/2] gnu: evince: Build with libkpathsea.
(address . 48443@debbugs.gnu.org)(address . bauermann@kolabnow.com)
20210713075608.12929-2-leo.prikler@student.tugraz.at
* gnu/packages/gnome.scm (evince)[inputs]: Add libkpathsea.
---
gnu/packages/gnome.scm | 4 +---
1 file changed, 1 insertion(+), 3 deletions(-)

Toggle diff (17 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index f3133c98ae..82ad709f98 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2606,9 +2606,7 @@ forgotten when the session ends.")
("ghostscript" ,ghostscript)
("poppler" ,poppler)
("libtiff" ,libtiff)
- ;; TODO:
- ;; Build libkpathsea as a shared library for DVI support.
- ;; ("libkpathsea" ,texlive-bin)
+ ("libkpathsea" ,texlive-libkpathsea)
("gnome-desktop" ,gnome-desktop)
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
("gspell" ,gspell)
--
2.32.0
L
L
Leo Prikler wrote on 13 Jul 2021 09:56
[PATCH v2 1/2] gnu: Add texlive-libkpathsea.
(address . 48443@debbugs.gnu.org)(address . bauermann@kolabnow.com)
20210713075608.12929-1-leo.prikler@student.tugraz.at
* gnu/packages/tex.scm (texlive-libkpathsea): New variable.
---
gnu/packages/tex.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 8d86264209..9256f56842 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -460,6 +460,38 @@ This package contains the binaries.")
(license (license:fsf-free "https://www.tug.org/texlive/copying.html"))
(home-page "https://www.tug.org/texlive/")))
+(define-public texlive-libkpathsea
+ (package/inherit texlive-bin
+ (name "texlive-libkpathsea")
+ (source
+ (origin
+ (inherit (package-source texlive-bin))
+ (snippet
+ `(begin
+ ,(origin-snippet (package-source texlive-bin))
+ (with-directory-excursion "texk"
+ (let ((preserved-directories '("." ".." "kpathsea")))
+ (for-each
+ delete-file-recursively
+ (scandir "."
+ (lambda (file)
+ (and (not (member file preserved-directories))
+ (eq? 'directory (stat:type (stat file)))))))))))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments texlive-bin)
+ ((#:configure-flags flags)
+ `(cons* "--disable-all-pkgs" "--enable-kpathsea"
+ "--enable-shared" ,flags))
+ ((#:phases phases)
+ `(modify-phases %standard-phases
+ (add-after 'install 'post-install
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (with-directory-excursion "texk/kpathsea"
+ (invoke "make" "install"))))))))
+ (synopsis "Path searching library")
+ (description "kpathsea is a library, whose purpose is to return a filename
+from a list of user-specified directories similar to how shells look up
+executables. It is maintained as a part of TeX Live.")))
(define texlive-docstrip
(package
--
2.32.0
L
L
Leo Prikler wrote on 13 Jul 2021 09:58
Re: [bug#48443] [PATCH 1/2] gnu: Add texlive-libkpathsea.
(name . Thiago Jung Bauermann)(address . bauermann@kolabnow.com)(address . 48443@debbugs.gnu.org)
a612b229a3d608833fd735b3a0835776642779cd.camel@student.tugraz.at
Hello Thiago,

Am Montag, den 12.07.2021, 21:32 -0300 schrieb Thiago Jung Bauermann:
Toggle quote (12 lines)
> [...]
> > +(define-public texlive-libkpathsea
> > + (package/inherit texlive-bin
>
> According to a recent message from Ludo¹, ‘package/inherit’ is meant
> to be
> used in specific situations, and IIUC it doesn’t apply here:
>
> > It should also be (package (inherit …) …) rather than
> > (package/inherit …). The latter is only useful when defining
> > variants of a package (same version, same code) where the same
> > security updates would apply.
I'm a little confused here, as that is exactly the rationale I'm
applying. When texlive-bin gets grafted due to kpathsea, the graft
also applies to texlive-libkpathsea. Granted, there is a large room
for false positives, that would result in gratuitous grafts for
texlive-libkpathsea, but I prefer erring on the side of security rather
than graftlessness here.

Toggle quote (8 lines)
> I also wonder whether inheriting from texlive-bin is the best option.
> One disadvantage is that it makes this package too sensitive to
> changes in texlive-bin. As an example, it doesn’t work anymore with
> the version in core-updates because in the branch, the ‘postint’
> phase has been renamed to ‘post-install’. Also, I assume many
> texlive-bin inputs aren’t needed for texlive-kpathsea, causing
> unnecessary work when building texlive-libkpathsea and packages
> depending on it such as evince.
The postinst thing was my mistake – instead of inheriting from
%standard-phases as I should, I naïvely inherited texlive-bin's phases
instead. It turns out, I actually don't need any of those (and if I
did they'd be trivially copyable).

On the part of inputs, sure, we could make libkpathsea smaller, but I
have little experience with TeX Live and its build system, so I decided
not to change its inputs for now. If you have suggestions on how a
better closure could be achieved, please do bring them forth.

Toggle quote (3 lines)
> In addition, if it were a separate package then texlive-bin could be
> made to use it, rather than shipping its own copy.

Perhaps that's an idea worth entertaining, but given the TeX Live build
system I fear it's not an overwhelmingly practical one.

Toggle quote (8 lines)
> > + (name "texlive-libkpathsea")
> > + (source
> > + (origin
> > + (inherit (package-source texlive-bin))
>
> Perhaps a ‘texlive-source-src’ variable analogous to ‘texlive-extra-
> src’ and ‘texlive-texmf-src’ would be useful?

I'm… not too sure on this one. What would texlive-source-src capture?
Just the upstream source? Then we'd have to carefully apply all the
fitting patches. The same as (package-source texlive-bin)? What's the
point then?

Toggle quote (30 lines)
> > + (snippet
> > + `(begin
> > + ,(origin-snippet (package-source texlive-bin))
> > + (with-directory-excursion "texk"
> > + (let ((preserved-directories '("." ".." "kpathsea")))
> > + (for-each
> > + delete-file-recursively
> > + (scandir "."
> > + (lambda (file)
> > + (and (not (member file
> > preserved-directories)) + (eq?
> > 'directory
> > (stat:type (stat file))))))))))))) + (arguments
> > + (substitute-keyword-arguments (package-arguments texlive-bin)
> > + ((#:configure-flags flags)
> > + `(cons* "--disable-all-pkgs" "--enable-kpathsea"
> > + "--enable-shared" ,flags))
> > + ((#:phases phases)
> > + `(modify-phases ,phases
> > + (delete 'configure-ghostscript-executable)
> > + (delete 'use-code-for-new-poppler)
> > + (delete 'patch-dvisvgm-build-files)
> > + (delete 'disable-failing-test)
> > + (replace 'postint
> > + (lambda* (#:key inputs outputs #:allow-other-keys)
> > + (with-directory-excursion "texk/kpathsea"
> > + (invoke "make" "install"))))))))))
>
> If you decide to continue inheriting from texlive-bin, you’d also
> need to change the synopsis and description.
Fair enough, that's on me. I've sent a v2 applying some of your
suggestions. Please feel free to point out anything I've missed or you
noticed in addition to what's already discussed.

Regards,
Leo
T
T
Thiago Jung Bauermann wrote on 14 Jul 2021 03:48
(name . Leo Prikler)(address . leo.prikler@student.tugraz.at)(address . 48443@debbugs.gnu.org)
2781292.7Eo9FbQQbZ@popigai
Hi Leo,

Thank you for your response and your new version of the patches.

Em terça-feira, 13 de julho de 2021, às 04:58:22 -03, Leo Prikler escreveu:
Toggle quote (24 lines)
> Hello Thiago,
>
> Am Montag, den 12.07.2021, 21:32 -0300 schrieb Thiago Jung Bauermann:
> > [...]
> >
> > > +(define-public texlive-libkpathsea
> > > + (package/inherit texlive-bin
> >
> > According to a recent message from Ludo¹, ‘package/inherit’ is meant
> > to be
> >
> > used in specific situations, and IIUC it doesn’t apply here:
> > > It should also be (package (inherit …) …) rather than
> > > (package/inherit …). The latter is only useful when defining
> > > variants of a package (same version, same code) where the same
> > > security updates would apply.
>
> I'm a little confused here, as that is exactly the rationale I'm
> applying. When texlive-bin gets grafted due to kpathsea, the graft
> also applies to texlive-libkpathsea. Granted, there is a large room
> for false positives, that would result in gratuitous grafts for
> texlive-libkpathsea, but I prefer erring on the side of security rather
> than graftlessness here.

My reasoning was that libkpathsea is just a small part of texlive-bin, so
in principle a minority of texlive-bin security updates would apply to it.
But you are right, there may well be some which would apply.

Toggle quote (14 lines)
> > I also wonder whether inheriting from texlive-bin is the best option.
> > One disadvantage is that it makes this package too sensitive to
> > changes in texlive-bin. As an example, it doesn’t work anymore with
> > the version in core-updates because in the branch, the ‘postint’
> > phase has been renamed to ‘post-install’. Also, I assume many
> > texlive-bin inputs aren’t needed for texlive-kpathsea, causing
> > unnecessary work when building texlive-libkpathsea and packages
> > depending on it such as evince.
>
> The postinst thing was my mistake – instead of inheriting from
> %standard-phases as I should, I naïvely inherited texlive-bin's phases
> instead. It turns out, I actually don't need any of those (and if I
> did they'd be trivially copyable).

That is nice solution.

Toggle quote (5 lines)
> On the part of inputs, sure, we could make libkpathsea smaller, but I
> have little experience with TeX Live and its build system, so I decided
> not to change its inputs for now. If you have suggestions on how a
> better closure could be achieved, please do bring them forth.

I was able to build the package with an empty input list. I compared a
texlive-libkpathsea built with your unchanged patches and one with the
empty input list and they are identical, except for the hash of the
/gnu/store directory. Even the binary files, which I compared using
hexdump. So my suggestion is to use an empty input list. :-)

Toggle quote (6 lines)
> > In addition, if it were a separate package then texlive-bin could be
> > made to use it, rather than shipping its own copy.
>
> Perhaps that's an idea worth entertaining, but given the TeX Live build
> system I fear it's not an overwhelmingly practical one.

I can look into that separately, after your patches go in.

Toggle quote (13 lines)
> > > + (name "texlive-libkpathsea")
> > > + (source
> > > + (origin
> > > + (inherit (package-source texlive-bin))
> >
> > Perhaps a ‘texlive-source-src’ variable analogous to ‘texlive-extra-
> > src’ and ‘texlive-texmf-src’ would be useful?
>
> I'm… not too sure on this one. What would texlive-source-src capture?
> Just the upstream source? Then we'd have to carefully apply all the
> fitting patches. The same as (package-source texlive-bin)? What's the
> point then?

Yes, the point would be just to not duplicate the origin information. There
would indeed be more work sorting out which security updates apply.

Toggle quote (35 lines)
> > > + (snippet
> > > + `(begin
> > > + ,(origin-snippet (package-source texlive-bin))
> > > + (with-directory-excursion "texk"
> > > + (let ((preserved-directories '("." ".." "kpathsea")))
> > > + (for-each
> > > + delete-file-recursively
> > > + (scandir "."
> > > + (lambda (file)
> > > + (and (not (member file
> > > preserved-directories)) + (eq?
> > > 'directory
> > > (stat:type (stat file))))))))))))) + (arguments
> > > + (substitute-keyword-arguments (package-arguments texlive-bin)
> > > + ((#:configure-flags flags)
> > > + `(cons* "--disable-all-pkgs" "--enable-kpathsea"
> > > + "--enable-shared" ,flags))
> > > + ((#:phases phases)
> > > + `(modify-phases ,phases
> > > + (delete 'configure-ghostscript-executable)
> > > + (delete 'use-code-for-new-poppler)
> > > + (delete 'patch-dvisvgm-build-files)
> > > + (delete 'disable-failing-test)
> > > + (replace 'postint
> > > + (lambda* (#:key inputs outputs #:allow-other-keys)
> > > + (with-directory-excursion "texk/kpathsea"
> > > + (invoke "make" "install"))))))))))
> >
> > If you decide to continue inheriting from texlive-bin, you’d also
> > need to change the synopsis and description.
>
> Fair enough, that's on me. I've sent a v2 applying some of your
> suggestions. Please feel free to point out anything I've missed or you
> noticed in addition to what's already discussed.

Thanks!

--
Thanks,
Thiago
L
L
Leo Prikler wrote on 14 Jul 2021 10:50
[PATCH v3 2/2] gnu: evince: Build with libkpathsea.
(address . 48443@debbugs.gnu.org)(address . bauermann@kolabnow.com)
20210714085006.3781-2-leo.prikler@student.tugraz.at
* gnu/packages/gnome.scm (evince)[inputs]: Add libkpathsea.
---
gnu/packages/gnome.scm | 4 +---
1 file changed, 1 insertion(+), 3 deletions(-)

Toggle diff (17 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index f3133c98ae..39102dc798 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2606,9 +2606,7 @@ forgotten when the session ends.")
("ghostscript" ,ghostscript)
("poppler" ,poppler)
("libtiff" ,libtiff)
- ;; TODO:
- ;; Build libkpathsea as a shared library for DVI support.
- ;; ("libkpathsea" ,texlive-bin)
+ ("texlive-libkpathsea" ,texlive-libkpathsea) ; for DVI support
("gnome-desktop" ,gnome-desktop)
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
("gspell" ,gspell)
--
2.32.0
L
L
Leo Prikler wrote on 14 Jul 2021 10:50
[PATCH v3 1/2] gnu: Add texlive-libkpathsea.
(address . 48443@debbugs.gnu.org)(address . bauermann@kolabnow.com)
20210714085006.3781-1-leo.prikler@student.tugraz.at
* gnu/packages/tex.scm (texlive-libkpathsea): New variable.
---
gnu/packages/tex.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 8d86264209..b404ca8ff1 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -460,6 +460,39 @@ This package contains the binaries.")
(license (license:fsf-free "https://www.tug.org/texlive/copying.html"))
(home-page "https://www.tug.org/texlive/")))
+(define-public texlive-libkpathsea
+ (package/inherit texlive-bin
+ (name "texlive-libkpathsea")
+ (source
+ (origin
+ (inherit (package-source texlive-bin))
+ (snippet
+ `(begin
+ ,(origin-snippet (package-source texlive-bin))
+ (with-directory-excursion "texk"
+ (let ((preserved-directories '("." ".." "kpathsea")))
+ (for-each
+ delete-file-recursively
+ (scandir "."
+ (lambda (file)
+ (and (not (member file preserved-directories))
+ (eq? 'directory (stat:type (stat file)))))))))))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments texlive-bin)
+ ((#:configure-flags flags)
+ `(cons* "--disable-all-pkgs" "--enable-kpathsea"
+ "--enable-shared" ,flags))
+ ((#:phases phases)
+ `(modify-phases %standard-phases
+ (add-after 'install 'post-install
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (with-directory-excursion "texk/kpathsea"
+ (invoke "make" "install"))))))))
+ (inputs '())
+ (synopsis "Path searching library")
+ (description "kpathsea is a library, whose purpose is to return a filename
+from a list of user-specified directories similar to how shells look up
+executables. It is maintained as a part of TeX Live.")))
(define texlive-docstrip
(package
--
2.32.0
L
L
Leo Prikler wrote on 14 Jul 2021 10:55
Re: [bug#48443] [PATCH 1/2] gnu: Add texlive-libkpathsea.
(name . Thiago Jung Bauermann)(address . bauermann@kolabnow.com)(address . 48443@debbugs.gnu.org)
969b22ea43c5975192e99570d6ad79ebe26efd04.camel@student.tugraz.at
Hi Thiago,

Am Dienstag, den 13.07.2021, 22:48 -0300 schrieb Thiago Jung Bauermann:
Toggle quote (14 lines)
> [...]
>
> > On the part of inputs, sure, we could make libkpathsea smaller, but
> > I
> > have little experience with TeX Live and its build system, so I
> > decided
> > not to change its inputs for now. If you have suggestions on how a
> > better closure could be achieved, please do bring them forth.
>
> I was able to build the package with an empty input list. I compared
> a texlive-libkpathsea built with your unchanged patches and one with
> the empty input list and they are identical, except for the hash of
> the /gnu/store directory. Even the binary files, which I compared
> using hexdump. So my suggestion is to use an empty input list. :-)
Thanks for checking, v3 now uses an empty input list.

Toggle quote (9 lines)
> > > In addition, if it were a separate package then texlive-bin could
> > > be
> > > made to use it, rather than shipping its own copy.
> >
> > Perhaps that's an idea worth entertaining, but given the TeX Live
> > build
> > system I fear it's not an overwhelmingly practical one.
>
> I can look into that separately, after your patches go in.
Fair enough.

Toggle quote (20 lines)
> > > > + (name "texlive-libkpathsea")
> > > > + (source
> > > > + (origin
> > > > + (inherit (package-source texlive-bin))
> > >
> > > Perhaps a ‘texlive-source-src’ variable analogous to ‘texlive-
> > > extra-
> > > src’ and ‘texlive-texmf-src’ would be useful?
> >
> > I'm… not too sure on this one. What would texlive-source-src
> > capture?
> > Just the upstream source? Then we'd have to carefully apply all
> > the
> > fitting patches. The same as (package-source texlive-bin)? What's
> > the
> > point then?
>
> Yes, the point would be just to not duplicate the origin information.
> There would indeed be more work sorting out which security updates
> apply.
I'm not really convince that would help us. texlive-libkpathsea still
needs to inherit from the origin so as to strip away all the others
sources. So would every other part of texlive if built on its own.
Perhaps one could instead do computed origins, but that increases
complexity rather than reducing it. Therefore I'm not convinced
extracting this origin into its own variable is beneficial.

Regards,
Leo
T
T
Thiago Jung Bauermann wrote on 14 Jul 2021 18:23
(name . Leo Prikler)(address . leo.prikler@student.tugraz.at)(address . 48443@debbugs.gnu.org)
10314452.DzVqUJa3KR@popigai
Hi Leo,

Em quarta-feira, 14 de julho de 2021, às 05:55:55 -03, Leo Prikler
escreveu:
Toggle quote (18 lines)
> Am Dienstag, den 13.07.2021, 22:48 -0300 schrieb Thiago Jung Bauermann:
> > [...]
> >
> > > On the part of inputs, sure, we could make libkpathsea smaller, but
> > > I
> > > have little experience with TeX Live and its build system, so I
> > > decided
> > > not to change its inputs for now. If you have suggestions on how a
> > > better closure could be achieved, please do bring them forth.
> >
> > I was able to build the package with an empty input list. I compared
> > a texlive-libkpathsea built with your unchanged patches and one with
> > the empty input list and they are identical, except for the hash of
> > the /gnu/store directory. Even the binary files, which I compared
> > using hexdump. So my suggestion is to use an empty input list. :-)
>
> Thanks for checking, v3 now uses an empty input list.

Thanks! v3 looks great to me.
Toggle quote (28 lines)
> > > > > + (name "texlive-libkpathsea")
> > > > > + (source
> > > > > + (origin
> > > > > + (inherit (package-source texlive-bin))
> > > >
> > > > Perhaps a ‘texlive-source-src’ variable analogous to ‘texlive-
> > > > extra-
> > > > src’ and ‘texlive-texmf-src’ would be useful?
> > >
> > > I'm… not too sure on this one. What would texlive-source-src
> > > capture?
> > > Just the upstream source? Then we'd have to carefully apply all
> > > the
> > > fitting patches. The same as (package-source texlive-bin)? What's
> > > the
> > > point then?
> >
> > Yes, the point would be just to not duplicate the origin information.
> > There would indeed be more work sorting out which security updates
> > apply.
>
> I'm not really convince that would help us. texlive-libkpathsea still
> needs to inherit from the origin so as to strip away all the others
> sources. So would every other part of texlive if built on its own.
> Perhaps one could instead do computed origins, but that increases
> complexity rather than reducing it. Therefore I'm not convinced
> extracting this origin into its own variable is beneficial.

Yes, that is true. In my previous message I was agreeing with you that the
origin idea didn’t bring much benefit. Sorry for not being clear.

--
Thanks,
Thiago
L
L
Leo Prikler wrote on 15 Jul 2021 13:44
(name . Thiago Jung Bauermann)(address . bauermann@kolabnow.com)(address . 48443-done@debbugs.gnu.org)
cfc95fbb3894380918fcebbcbaf5c5f7e40ef75e.camel@student.tugraz.at
Am Mittwoch, den 14.07.2021, 13:23 -0300 schrieb Thiago Jung Bauermann:
Toggle quote (4 lines)
> [...]
> Yes, that is true. In my previous message I was agreeing with you
> that the origin idea didn’t bring much benefit. Sorry for not being
> clear.
No problem. I've pushed this now, thanks for your review!
Closed
?