[PATCH 5/5] gnu: Add python-multiplex.

  • Open
  • quality assurance status badge
Details
2 participants
  • Vinicius Monego
  • Stefan Reichör
Owner
unassigned
Submitted by
Stefan Reichör
Severity
normal
S
S
Stefan Reichör wrote on 14 May 2021 23:17
(address . guix-patches@gnu.org)(name . Stefan Reichör)(address . stefan@xsteve.at)
20210514211746.143145-5-stefan@xsteve.at
* gnu/packages/python-xyz.scm (python-multiplex): New variable.
---
gnu/packages/python-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 431f2aa85d..ff2ce6ad32 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -24983,6 +24983,34 @@ applications with variable CPU loads).")
(define-public python2-parallel
(package-with-python2 python-parallel))
+(define-public python-multiplex
+ (package
+ (name "python-multiplex")
+ (version "0.5.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "multiplex" version))
+ (sha256
+ (base32
+ "1g01xwx5z0m1dvp5d69ndj8hz80d2z5xzasixa7c0k6ny93f9qhg"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-aiofiles" ,python-aiofiles-0.5.0)
+ ("python-aiostream" ,python-aiostream)
+ ("python-click" ,python-click)
+ ("python-easy-ansi" ,python-easy-ansi)
+ ("python-pyte" ,python-pyte)))
+ (home-page
+ "https://github.com/dankilman/multiplex")
+ (synopsis
+ "View output of multiple processes, in parallel, in the console, with an
+interactive TUI")
+ (description
+ "Can be used as cli tool or as python library to view output of parallel
+running processes")
+ (license license:expat)))
+
(define-public python-djvulibre
(package
(name "python-djvulibre")
--
2.25.1
S
S
Stefan Reichör wrote on 29 May 2021 23:10
[PATCH] gnu: Add python-multiplex.
(address . 48430@debbugs.gnu.org)(name . Stefan Reichör)(address . stefan@xsteve.at)
20210529211041.185234-1-stefan@xsteve.at
* gnu/packages/python-xyz.scm (python-multiplex): New variable.
---
I was not able to switch the source url to github since the poetry
build system is required there. I have no idea how to use poetry from within guix

gnu/packages/python-xyz.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f208a7d153..d68e237830 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -25062,6 +25062,32 @@ applications with variable CPU loads).")
(define-public python2-parallel
(package-with-python2 python-parallel))
+(define-public python-multiplex
+ (package
+ (name "python-multiplex")
+ (version "0.5.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "multiplex" version))
+ (sha256
+ (base32
+ "1g01xwx5z0m1dvp5d69ndj8hz80d2z5xzasixa7c0k6ny93f9qhg"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-aiofiles" ,python-aiofiles-0.5.0)
+ ("python-aiostream" ,python-aiostream)
+ ("python-click" ,python-click)
+ ("python-easy-ansi" ,python-easy-ansi)
+ ("python-pyte" ,python-pyte)))
+ (home-page "https://github.com/dankilman/multiplex")
+ (synopsis "View output of multiple processes, in parallel, in the console,
+with an interactive TUI")
+ (description
+ "Can be used as cli tool or as python library to view output of parallel
+running processes")
+ (license license:expat)))
+
(define-public python-djvulibre
(package
(name "python-djvulibre")
--
2.25.1
V
V
Vinicius Monego wrote on 11 Nov 2021 05:52
3555e2c85027f9b560e7583ead618cd1db0ef587.camel@posteo.net
Em sáb, 2021-05-29 às 23:10 +0200, Stefan Reichör escreveu:
Toggle quote (7 lines)
> * gnu/packages/python-xyz.scm (python-multiplex): New variable.
> ---
> I was not able to switch the source url to github since the poetry
> build system is required there. I have no idea how to use poetry from
> within guix
>

Hi,

I was taking a look at this series again.

Toggle quote (19 lines)
> gnu/packages/python-xyz.scm | 26 ++++++++++++++++++++++++++
>  1 file changed, 26 insertions(+)
>
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-
> xyz.scm
> index f208a7d153..d68e237830 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -25062,6 +25062,32 @@ applications with variable CPU loads).")
>  (define-public python2-parallel
>    (package-with-python2 python-parallel))
>  
> +(define-public python-multiplex
> +  (package
> +    (name "python-multiplex")
> +    (version "0.5.1")
> +    (source
> +      (origin

Indentation is 1 space below source. If you're using Emacs it can fix
indentation with M-x indent-sexp (C-M-q) with the cursor on the
beginning of the expression.

Toggle quote (8 lines)
> +        (method url-fetch)
> +        (uri (pypi-uri "multiplex" version))
> +        (sha256
> +          (base32
> +           
> "1g01xwx5z0m1dvp5d69ndj8hz80d2z5xzasixa7c0k6ny93f9qhg"))))
> +    (build-system python-build-system)

I'd suggest to add something like

Toggle quote (3 lines)
> (arguments
> `(#:tests? #f)) ; no tests in PyPI and no setup.py in github

in this place.

Toggle quote (3 lines)
> +    (propagated-inputs
> +      `(("python-aiofiles" ,python-aiofiles-0.5.0)

If multiplex must match aiofiles version, issue 48429 can be skipped
since multiplex is now at 0.6.0 and we have aiofiles 0.6.0.

Toggle quote (9 lines)
> +        ("python-aiostream" ,python-aiostream)
> +        ("python-click" ,python-click)
> +        ("python-easy-ansi" ,python-easy-ansi)
> +        ("python-pyte" ,python-pyte)))
> +    (home-page "https://github.com/dankilman/multiplex")
> +    (synopsis "View output of multiple processes, in parallel, in
> the console,
> +with an interactive TUI")

Please keep synopsis under 78 columns. I'd suggest something like "View
output of multiple process with an interactive TUI".

Toggle quote (5 lines)
> +    (description
> +      "Can be used as cli tool or as python library to view output
> of parallel
> +running processes")

Description must be a full sentence. For instance: "Multiplex is a CLI
tool and a Python library to view output of running processes in
parallel.", or something alone these lines.

Toggle quote (6 lines)
> +    (license license:expat)))
> +
>  (define-public python-djvulibre
>    (package
>      (name "python-djvulibre")

Your patch 2 was already merged.

Can you send a series of patches 1, 3 and 5 with -v2 to
48428@debbugs.gnu.org (the first patch)? When merged, that and 48427,
48429 and 48430 can be closed.

Vinicius
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 48430@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 48430
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch