(address . guix-patches@gnu.org)(name . Stefan Reichör)(address . stefan@xsteve.at)
* gnu/packages/python-xyz.scm (python-multiplex): New variable.
---
gnu/packages/python-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)
Toggle diff (41 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 431f2aa85d..ff2ce6ad32 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -24983,6 +24983,34 @@ applications with variable CPU loads).")
(define-public python2-parallel
(package-with-python2 python-parallel))
+(define-public python-multiplex
+ (package
+ (name "python-multiplex")
+ (version "0.5.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "multiplex" version))
+ (sha256
+ (base32
+ "1g01xwx5z0m1dvp5d69ndj8hz80d2z5xzasixa7c0k6ny93f9qhg"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-aiofiles" ,python-aiofiles-0.5.0)
+ ("python-aiostream" ,python-aiostream)
+ ("python-click" ,python-click)
+ ("python-easy-ansi" ,python-easy-ansi)
+ ("python-pyte" ,python-pyte)))
+ (home-page
+ "https://github.com/dankilman/multiplex")
+ (synopsis
+ "View output of multiple processes, in parallel, in the console, with an
+interactive TUI")
+ (description
+ "Can be used as cli tool or as python library to view output of parallel
+running processes")
+ (license license:expat)))
+
(define-public python-djvulibre
(package
(name "python-djvulibre")
--
2.25.1