[PATCH 0/4] Add nodejs 16.1.0

  • Done
  • quality assurance status badge
Details
3 participants
  • Jelle Licht
  • Maxime Devos
  • Martin Becze
Owner
unassigned
Submitted by
Martin Becze
Severity
normal
M
M
Martin Becze wrote on 13 May 2021 15:02
(address . guix-patches@gnu.org)(name . Martin Becze)(address . mjbecze@riseup.net)
20210513130211.4057-1-mjbecze@riseup.net
This patch set add nodejs 16.1.0 as well as updates some dependencies of node lts which where need for 16.1.0 to build.


Martin Becze (4):
gnu: Add llhttp-6.0.
gnu: node-lts: Updated c-ares and icu4c.
gnu: node-lts: Add phase 'delete-cluster-tests.
gnu: Added node-16.1.

gnu/packages/node.scm | 57 ++++++++++++++++++++++++++++++++++++-------
1 file changed, 48 insertions(+), 9 deletions(-)

--
2.31.1
M
M
Martin Becze wrote on 13 May 2021 15:06
[PATCH 1/4] gnu: Add llhttp-6.0.
(address . 48396@debbugs.gnu.org)(name . Martin Becze)(address . mjbecze@riseup.net)
20210513130622.4288-1-mjbecze@riseup.net
* gnu/packages/node.scm (llhttp-6.0): New variable.
---
gnu/packages/node.scm | 12 ++++++++++++
1 file changed, 12 insertions(+)

Toggle diff (32 lines)
diff --git a/gnu/packages/node.scm b/gnu/packages/node.scm
index 4e80dd4d4e..beb67734a9 100644
--- a/gnu/packages/node.scm
+++ b/gnu/packages/node.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2020 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2020 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
+;;; Copyright © 2021 Martin Becze <mjbecze@riseup.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -580,6 +581,17 @@ parser definition into a C output.")
source files.")
(license license:expat)))
+(define llhttp-6.0
+ (package
+ (inherit llhttp-bootstrap)
+ (version "6.0.0")
+ (source
+ (origin
+ (inherit (package-source llhttp-bootstrap))
+ (patches '())
+ (sha256
+ (base32 "1hyry664y3v727jcd72jpg7ilb8mr3zkffz0ag0ln8s68k5f2zka"))))))
+
(define-public node-lts
(package
(inherit node)
--
2.31.1
M
M
Martin Becze wrote on 13 May 2021 15:06
[PATCH 2/4] gnu: node-lts: Updated c-ares and icu4c.
(address . 48396@debbugs.gnu.org)(name . Martin Becze)(address . mjbecze@riseup.net)
20210513130622.4288-2-mjbecze@riseup.net
This updates two dependencies of node-lts (c-ares and icu4c). Future versions
of node depend on the new versions of these dependencies.

* gnu/packages/node.scm (node-lts): Update inputs c-ares and icu4c.
---
gnu/packages/node.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (17 lines)
diff --git a/gnu/packages/node.scm b/gnu/packages/node.scm
index beb67734a9..17f435ca39 100644
--- a/gnu/packages/node.scm
+++ b/gnu/packages/node.scm
@@ -715,8 +715,8 @@ source files.")
"deps/llhttp/include/llhttp.h"))
#t))))))
(inputs
- `(("c-ares" ,c-ares)
- ("icu4c" ,icu4c-67)
+ `(("c-ares" ,c-ares/fixed)
+ ("icu4c" ,icu4c-68)
("libuv" ,libuv-for-node)
("llhttp" ,llhttp-bootstrap)
("google-brotli" ,google-brotli)
--
2.31.1
M
M
Martin Becze wrote on 13 May 2021 15:06
[PATCH 3/4] gnu: node-lts: Add phase 'delete-cluster-tests.
(address . 48396@debbugs.gnu.org)(name . Martin Becze)(address . mjbecze@riseup.net)
20210513130622.4288-3-mjbecze@riseup.net
This adds a phases 'delete-cluster-tests which will be replaced by future
versions of node.

* gnu/packages/node.scm (node-lts): Add phase 'delete-cluster-tests.
---
gnu/packages/node.scm | 15 ++++++++-------
1 file changed, 8 insertions(+), 7 deletions(-)

Toggle diff (35 lines)
diff --git a/gnu/packages/node.scm b/gnu/packages/node.scm
index 17f435ca39..d7b46190e4 100644
--- a/gnu/packages/node.scm
+++ b/gnu/packages/node.scm
@@ -666,12 +666,6 @@ source files.")
(("'/usr/bin/env'")
(string-append "'" (which "env") "'")))
- ;; FIXME: These tests fail in the build container, but they don't
- ;; seem to be indicative of real problems in practice.
- (for-each delete-file
- '("test/parallel/test-cluster-master-error.js"
- "test/parallel/test-cluster-master-kill.js"))
-
;; These require a DNS resolver.
(for-each delete-file
'("test/parallel/test-dns.js"
@@ -713,7 +707,14 @@ source files.")
"deps/llhttp/src/http.c")
(copy-file (string-append llhttp "/include/llhttp.h")
"deps/llhttp/include/llhttp.h"))
- #t))))))
+ #t))
+ (add-after 'patch-files 'delete-cluster-tests
+ (lambda _
+ ;; FIXME: These tests fail in the build container, but they don't
+ ;; seem to be indicative of real problems in practice.
+ (for-each delete-file
+ '("test/parallel/test-cluster-master-error.js"
+ "test/parallel/test-cluster-master-kill.js"))))))))
(inputs
`(("c-ares" ,c-ares/fixed)
("icu4c" ,icu4c-68)
--
2.31.1
M
M
Martin Becze wrote on 13 May 2021 15:06
[PATCH 4/4] gnu: Added node-16.1.
(address . 48396@debbugs.gnu.org)(name . Martin Becze)(address . mjbecze@riseup.net)
20210513130622.4288-4-mjbecze@riseup.net
* gnu/packages/node.scm (node-16.1): New variable.
---
gnu/packages/node.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/node.scm b/gnu/packages/node.scm
index d7b46190e4..9d2432e97a 100644
--- a/gnu/packages/node.scm
+++ b/gnu/packages/node.scm
@@ -728,6 +728,32 @@ source files.")
(alist-replace "python" (list python-3)
(package-native-inputs node)))))
+(define-public node-16.1
+ (package
+ (inherit node-lts)
+ (version "16.1.0")
+ (source
+ (origin
+ (inherit (package-source node-lts))
+ (uri (string-append "https://nodejs.org/dist/v" version
+ "/node-v" version ".tar.xz"))
+ (sha256
+ (base32 "0z0808mw674mshgbmhgngqfkrdix3b61f77xcdz7bwf1j87j7ad0"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments node-lts)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (replace 'delete-cluster-tests
+ (lambda _
+ (for-each delete-file
+ '("test/parallel/test-http-methods.js"
+ "test/parallel/test-stdin-from-file-spawn.js"
+ "test/parallel/test-cluster-primary-error.js"
+ "test/parallel/test-cluster-primary-kill.js"))))))))
+ (inputs
+ (alist-replace "llhttp" (list llhttp-6.0)
+ (package-inputs node-lts)))))
+
(define-public libnode
(package/inherit node
(name "libnode")
--
2.31.1
M
M
Maxime Devos wrote on 25 Feb 2022 11:54
Re: [PATCH 0/4] Add nodejs 16.1.0
(address . 48396@debbugs.gnu.org)
9777211aefc5ad476e0a0b02df9aea80d70394f9.camel@telenet.be
Toggle quote (5 lines)
> +(define llhttp-6.0
> + (package
> + (inherit llhttp-bootstrap)
> + (version "6.0.0")

Instead of defining a package variant of llhttp-bootstrap, why not just
update 'llhtp-bootstrap', to keep things simple by just having the
latest version of llhttp in Guix?

Toggle quote (5 lines)
> +(define-public node-16.1
> + (package
> + (inherit node-lts)
> + (version "16.1.0")

Likewise.

(Also, how come that the LTS version in Guix (14.18.3) is newer than
the regular version '10.24.1'?)

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYhi1cBccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7jeVAQD0NvOrWFNNiHahYbhKUgBLiTb9
M+7HzLO8N0/6//yiqgEA2K1vPcq1p+AFm1l417BdhTMG3Wrg7SNXVFouq3DLGQU=
=Es7F
-----END PGP SIGNATURE-----


J
J
Jelle Licht wrote on 29 May 2023 13:14
Re: bug#48396: [PATCH 0/4] Add nodejs 16.1.0
(address . 48396-done@debbugs.gnu.org)(name . Martin Becze)(address . mjbecze@riseup.net)
87mt1no0e4.fsf@fsfe.org
Martin Becze <mjbecze@riseup.net> writes:

Toggle quote (1 lines)
> * gnu/packages/node.scm (node-16.1): New variable.
[snip]

We now have the current LTS (node@18) available on master, closing this
one.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 48396@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 48396
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch