[PATCH 1/6] gnu: yml2: Update to 2.7.0.

  • Done
  • quality assurance status badge
Details
One participant
  • Hartmut Goebel
Owner
unassigned
Submitted by
Hartmut Goebel
Severity
normal
H
H
Hartmut Goebel wrote on 12 May 2021 19:39
(address . guix-patches@gnu.org)
9f40b4002667ba7c9e83f4c9aab84b7a88e94a19.1620840984.git.h.goebel@crazy-compilers.com
* gnu/packages/pep.scm (yml2): Update to 2.7.0.
[source]: Switch to new git repo.
---
gnu/packages/pep.scm | 19 ++++++++++---------
1 file changed, 10 insertions(+), 9 deletions(-)

Toggle diff (38 lines)
diff --git a/gnu/packages/pep.scm b/gnu/packages/pep.scm
index 289796a377..6d24534f7e 100644
--- a/gnu/packages/pep.scm
+++ b/gnu/packages/pep.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2016, 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;; Copyright © 2016, 2020, 2021 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -40,15 +40,16 @@
(define-public yml2
(package
(name "yml2")
- (version "2.6.3")
- (source (origin
- (method hg-fetch)
- (uri (hg-reference
- (url "https://pep.foundation/dev/repos/yml2")
- (changeset version)))
- (file-name (string-append name "-" version "-checkout"))
+ (version "2.7.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitea.pep.foundation/fdik/yml2")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32 "10jjjyq1mz18zkzvxd62aba00h69gd9cglisqcvb81j67ml2v1bx"))))
+ (base32 "0fm1x1fv4lwcpbn59s55idzf7x173n59xpz8rlrxalmi6gvsjijr"))))
(build-system python-build-system)
(propagated-inputs
`(("python-lxml" ,python-lxml)))
--
2.21.4
H
H
Hartmut Goebel wrote on 12 May 2021 19:42
[PATCH 2/6] gnu: pep-engine: Update to 2.1.33.
46b2f04953e187f316d030a248c34fe452abe3ba.1620840984.git.h.goebel@crazy-compilers.com
* gnu/packages/pep.scm (fdik-libetpan): Update to current development
version. [source]: Switch to pep.foundation.
(pep-engine): Update to 2.1.33. [source]: Switch to new git repo.
[arguments]<make-flags>: Enable release-build.
[inputs]: Use normal sequoia.

* gnu/packages/sequoia.scm (sequoia4pEp): Remove variable.
---
gnu/packages/pep.scm | 25 +++++++-------
gnu/packages/sequoia.scm | 74 ----------------------------------------
2 files changed, 13 insertions(+), 86 deletions(-)

Toggle diff (147 lines)
diff --git a/gnu/packages/pep.scm b/gnu/packages/pep.scm
index 6d24534f7e..b0bc492f29 100644
--- a/gnu/packages/pep.scm
+++ b/gnu/packages/pep.scm
@@ -65,9 +65,9 @@ shell provides options to redirect the output into a pipe or a file.")
(define fdik-libetpan
;; pEp Engine requires libetpan with a set of patches that have not been
;; upstreamed yet.
- (let ((commit "210ba2b3b310b8b7a6ee4a4e35e50f7fa379643f") ; 2020-06-03
- (checksum "00000nij3ray7nssvq0lzb352wmnab8ffzk7dgff2c68mvjbh1l6")
- (revision "5"))
+ (let ((commit "0b80c39dd1504462ba3a39dc53db7c960c3a63f3") ; 2020-11-27
+ (checksum "0gv3ivaziadybjlf6rfpv1j5z5418243v5cvl4swlxd2njsh7gjk")
+ (revision "6"))
(package
(inherit libetpan)
(name "fdik-libetpan")
@@ -77,7 +77,7 @@ shell provides options to redirect the output into a pipe or a file.")
(inherit (package-source libetpan))
(method git-fetch)
(uri (git-reference
- (url "https://github.com/fdik/libetpan")
+ (url "https://gitea.pep.foundation/pEp.foundation/libetpan")
(commit commit)))
(file-name (string-append name "-" version))
(sha256 (base32 checksum)))))))
@@ -85,19 +85,20 @@ shell provides options to redirect the output into a pipe or a file.")
(define-public pep-engine
(package
(name "pep-engine")
- (version "2.0.6")
+ (version "2.1.33")
(source
(origin
- (method hg-fetch)
- (uri (hg-reference
- (url "https://pep.foundation/dev/repos/pEpEngine")
- (changeset "ebb62ba262dd"))) ;; r4721
- (file-name (string-append name "-" version "-checkout"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitea.pep.foundation/pEp.foundation/pEpEngine")
+ (commit (string-append "Release_" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "0ljf79j4ng7l8w6pbdcrfzb4yk51zslypvq0n72ib1d7grqvnagi"))))
+ (base32 "1nhrdal4yl9kmwfsxg13p5694n7dnb926h3fvcvg6q6ka2zmlrgd"))))
(build-system gnu-build-system)
(arguments
'(#:parallel-build? #f
+ #:make-flags '("NDEBUG=1") ; release build
#:phases
(modify-phases %standard-phases
(replace 'configure
@@ -132,7 +133,7 @@ OPENPGP=SEQUOIA
("libiconv" ,libiconv)
("nettle" ,nettle)
("openssl" ,openssl)
- ("sequoia" ,sequoia4pEp)
+ ("sequoia" ,sequoia)
("sqlite3" ,sqlite)
("util-linux" ,util-linux "lib"))) ;; uuid.h
(home-page "https://pep.foundation/")
diff --git a/gnu/packages/sequoia.scm b/gnu/packages/sequoia.scm
index cb1e2a4872..2c68f43e36 100644
--- a/gnu/packages/sequoia.scm
+++ b/gnu/packages/sequoia.scm
@@ -218,77 +218,3 @@
several crates, providing both a low-level and a high-level API for dealing
with OpenPGP data.")
(license license:gpl2+)))
-
-(define-public sequoia4pEp
- ;; Currently pEp Engine requires sequoia in not-so-current version
- (package/inherit sequoia
- (name "sequoia")
- (version "0.15.0-pEp")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://gitlab.com/sequoia-pgp/sequoia.git")
- (commit "0eb1b6cd846ea8c36b3dfdf01ec88383fc64f2fe")))
- (sha256
- (base32 "06dqs9whwp9lfibwp8dqm0aw4nm3s3v4jp2n4fz51zcvsld40nfh"))
- (file-name (git-file-name name version))))
- (arguments
- (substitute-keyword-arguments (package-arguments sequoia)
- ((#:cargo-inputs _)
- `(("rust-anyhow" ,rust-anyhow-1)
- ("rust-base64" ,rust-base64-0.11)
- ("rust-bzip2" ,rust-bzip2-0.3)
- ("rust-capnp" ,rust-capnp-0.10)
- ("rust-capnp-rpc" ,rust-capnp-rpc-0.10)
- ("rust-chrono" ,rust-chrono-0.4)
- ("rust-clap" ,rust-clap-2)
- ("rust-crossterm" ,rust-crossterm-0.13)
- ("rust-dirs" ,rust-dirs-2)
- ("rust-flate2" ,rust-flate2-1)
- ("rust-fs2" ,rust-fs2-0.4)
- ("rust-futures" ,rust-futures-0.1)
- ("rust-http" ,rust-http-0.1)
- ("rust-hyper" ,rust-hyper-0.12)
- ("rust-hyper-tls" ,rust-hyper-tls-0.3)
- ("rust-idna" ,rust-idna-0.2)
- ("rust-itertools" ,rust-itertools-0.8)
- ("rust-lalrpop" ,rust-lalrpop-0.17)
- ("rust-lalrpop-util" ,rust-lalrpop-util-0.17)
- ("rust-lazy-static" ,rust-lazy-static-1)
- ("rust-libc" ,rust-libc-0.2)
- ("rust-memsec" ,rust-memsec-0.5)
- ("rust-native-tls" ,rust-native-tls-0.2)
- ("rust-nettle" ,rust-nettle-7)
- ("rust-percent-encoding" ,rust-percent-encoding-2)
- ("rust-prettytable-rs" ,rust-prettytable-rs-0.8)
- ("rust-proc-macro2" ,rust-proc-macro2-1)
- ("rust-quickcheck" ,rust-quickcheck-0.9)
- ("rust-quote" ,rust-quote-1)
- ("rust-rand" ,rust-rand-0.7)
- ("rust-regex" ,rust-regex-1)
- ("rust-rpassword" ,rust-rpassword-4)
- ("rust-rusqlite" ,rust-rusqlite-0.19)
- ("rust-sha2" ,rust-sha2-0.8)
- ("rust-syn" ,rust-syn-1)
- ("rust-tempfile" ,rust-tempfile-3)
- ("rust-thiserror" ,rust-thiserror-1)
- ("rust-tokio" ,rust-tokio-0.1)
- ("rust-tokio-core" ,rust-tokio-core-0.1)
- ("rust-tokio-io" ,rust-tokio-io-0.1)
- ("rust-unicode-normalization" ,rust-unicode-normalization-0.1)
- ("rust-url" ,rust-url-2)
- ("rust-zbase32" ,rust-zbase32-0.1)))
- ((#:cargo-development-inputs _)
- `(("rust-assert-cli" ,rust-assert-cli-0.6)
- ("rust-colored" ,rust-colored-1)
- ("rust-filetime" ,rust-filetime-0.2)))
- ((#:phases phases)
- `(modify-phases ,phases
- (replace 'unpin-deps
- (lambda _
- (substitute* (find-files "." "Cargo.toml")
- (("= \"<") "= \"")
- (("= \"=") "= \""))
- #t))))))
- (properties `((hidden? . #t)))))
--
2.21.4
H
H
Hartmut Goebel wrote on 12 May 2021 19:42
[PATCH 3/6] gnu: libpEpAdapter: Update to 2.1.21.
c7778b8588e657d7038379deee043bbc1d9ca71b.1620840984.git.h.goebel@crazy-compilers.com
* gnu/packages/pep.scm (libpEpAdapter): Update to 2.1.21.
[source]: Swicht to new git repo.
[arguments]<make-flags>: Enable release-build.
---
gnu/packages/pep.scm | 15 ++++++++-------
1 file changed, 8 insertions(+), 7 deletions(-)

Toggle diff (35 lines)
diff --git a/gnu/packages/pep.scm b/gnu/packages/pep.scm
index b0bc492f29..e10c05ca68 100644
--- a/gnu/packages/pep.scm
+++ b/gnu/packages/pep.scm
@@ -147,20 +147,21 @@ privacy).")
(define-public libpepadapter
(package
(name "libpepadapter")
- (version "2.0.2")
+ (version "2.1.21")
(source
(origin
- (method hg-fetch)
- (uri (hg-reference
- (url "https://pep.foundation/dev/repos/libpEpAdapter")
- (changeset "e8fe371c870a"))) ;; r168
- (file-name (string-append name "-" version "-checkout"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitea.pep.foundation/pEp.foundation/libpEpAdapter")
+ (commit (string-append "Release_" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "1mlpavjbnmslvmr5jxcvpjgb2x40nhmxjb10hza3kn4qzj0k1pjz"))))
+ (base32 "09ljj3x09y99wc47n063hpn62zi8cdvdha82rnaypvirrlga6a5w"))))
(build-system gnu-build-system)
(arguments
'(#:test-target "test"
#:tests? #f ;; building the tests fails
+ #:make-flags '("NDEBUG=1") ; release build
#:phases
(modify-phases %standard-phases
(replace 'configure
--
2.21.4
H
H
Hartmut Goebel wrote on 12 May 2021 19:42
[PATCH 4/6] gnu: python-pep-adapter: Update to 2.1.3.
f62e5d491ca1558051f809ef367f8486c3249cd9.1620840984.git.h.goebel@crazy-compilers.com
* gnu/packages/pep.scm (python-pep-adapter): Update to 2.1.3.
[source]: Switch to new git repo.
[arguments]<phases>{remove-wheel-requirement}: New phase.
[native-inputs]: Add python-pytest and python-pytest-forked.
[inputs]: Remove asn1c, add python-setuptools-scm. util-linux.
---
gnu/packages/pep.scm | 34 ++++++++++++++++++++++++----------
1 file changed, 24 insertions(+), 10 deletions(-)

Toggle diff (73 lines)
diff --git a/gnu/packages/pep.scm b/gnu/packages/pep.scm
index e10c05ca68..04e7bedf13 100644
--- a/gnu/packages/pep.scm
+++ b/gnu/packages/pep.scm
@@ -26,12 +26,14 @@
#:use-module (gnu packages)
#:use-module (gnu packages base)
#:use-module (gnu packages boost)
+ #:use-module (gnu packages check)
#:use-module (gnu packages documentation)
#:use-module (gnu packages java)
#:use-module (gnu packages linux)
#:use-module (gnu packages mail) ; for libetpan
#:use-module (gnu packages nettle)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages python-xyz)
#:use-module (gnu packages sequoia)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages tls)
@@ -189,16 +191,16 @@ ENGINE_INC_PATH=~a/include
(define-public python-pep-adapter
(package
(name "python-pep-adapter")
- (version "2.0.5")
+ (version "2.1.3")
(source
(origin
- (method hg-fetch)
- (uri (hg-reference
- (url "https://pep.foundation/dev/repos/pEpPythonAdapter")
- (changeset "66df0e5b9405"))) ;; r374
- (file-name (string-append name "-" version "-checkout"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitea.pep.foundation/pEp.foundation/pEpPythonAdapter")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32 "107i1s8jf8gyhpmqcs64q9csxa3fwc8g7s57iyccqb4czw8gph6d"))))
+ (base32 "0ssz21p1k7xx3snmd4g3ggzq565rlzdmp90l2mph6yfp1y65p39s"))))
(build-system python-build-system)
(arguments
`(;; Adding configure-flags does not work, running `build_ext`
@@ -226,12 +228,24 @@ ENGINE_INC_PATH=~a/include
(string-append a "os.getenv('LIBRARY_PATH', '').split(os.pathsep)\n"))
(("^(\\s+SYS_SHARES = )\\['/usr.*" _ a)
(string-append a "['" (assoc-ref %build-inputs "asn1c") "/share']\n")))
+ #t))
+ (add-before 'build 'remove-wheel-requirement
+ ;; we dont't build a wheel
+ (lambda _
+ (substitute* "setup.cfg"
+ ((" wheel *>= [0-9.]*") ""))
+ (substitute* "pyproject.toml"
+ (("\"wheel *>=.*\"") ""))
#t)))))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-pytest-forked" ,python-pytest-forked)))
(inputs
- `(("asn1c" ,asn1c)
- ("boost-python" ,boost-with-python3)
+ `(("boost-python" ,boost-with-python3)
("libpepadapter" ,libpepadapter)
- ("pep-engine" ,pep-engine)))
+ ("pep-engine" ,pep-engine)
+ ("python-setuptools-scm" ,python-setuptools-scm/next)
+ ("util-linux" ,util-linux "lib"))) ;; uuid.h
(home-page "https://pep.foundation/")
(synopsis "Python adapter for p≡p (pretty Easy Privacy)")
(description "The p≡p Python adapter is an adaptor interface to the p≡p
--
2.21.4
H
H
Hartmut Goebel wrote on 12 May 2021 19:42
[PATCH 5/6] gnu: java-pep-adapter 2.1.23.
6d85b23c4d60c2062e3afdd64e83305be92a15f4.1620840984.git.h.goebel@crazy-compilers.com
* gnu/packages/pep.scm (java-pep-adapter): Update to 2.1.23.
[source]: Switch to new git repo.
[arguments]<make-flags>: Enable release-build, use new target names.
[arguments]<phases>{fix-includes}: Remove phase.
{pin-shared-lib-path}: Update file paths.
{build-codegen}: New phase.
{install}: Use "(install)".
[native-inputs]: Add graphviz.
[inputs]: Fix input util-linux.
---
gnu/packages/pep.scm | 44 +++++++++++++++++++-------------------------
1 file changed, 19 insertions(+), 25 deletions(-)

Toggle diff (107 lines)
diff --git a/gnu/packages/pep.scm b/gnu/packages/pep.scm
index 04e7bedf13..b4158a2ead 100644
--- a/gnu/packages/pep.scm
+++ b/gnu/packages/pep.scm
@@ -20,7 +20,6 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix git-download)
- #:use-module (guix hg-download)
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
#:use-module (gnu packages)
@@ -28,6 +27,7 @@
#:use-module (gnu packages boost)
#:use-module (gnu packages check)
#:use-module (gnu packages documentation)
+ #:use-module (gnu packages graphviz)
#:use-module (gnu packages java)
#:use-module (gnu packages linux)
#:use-module (gnu packages mail) ; for libetpan
@@ -255,35 +255,26 @@ ENGINE_INC_PATH=~a/include
(define-public java-pep-adapter
(package
(name "java-pep-adapter")
- (version "2.0.5")
+ (version "2.1.23")
(source
(origin
- (method hg-fetch)
- (uri (hg-reference
- (url "https://pep.foundation/dev/repos/pEpJNIAdapter")
- (changeset "534537c9cd50"))) ;; r763
- (file-name (string-append name "-" version "-checkout"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitea.pep.foundation/pEp.foundation/pEpJNIAdapter")
+ (commit (string-append "Release_" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "107ldpssc80bq8kndn2n000000gphj4lqagaiv3fddlfph4vji48"))))
+ (base32 "1sw3a5ggxcrkghvpp0a6h2lz461x55ldgfw5y4pw7c3gk5wynvjk"))))
(build-system gnu-build-system)
(outputs '("out" "doc"))
(arguments
`(#:test-target "test"
- #:make-flags (list "doxy-all")
+ #:make-flags '("NDEBUG=1" "all" "doc") ; release build
#:phases
(modify-phases %standard-phases
- (add-before 'configure 'fix-includes
- (lambda _
- (substitute* "src/jniutils.hh"
- (("#pragma once\n" line)
- (string-append line
- "#include <mutex>\n"
- "#include <cassert>\n"
- "#include <cstring>\n")))
- #t))
(add-before 'configure 'pin-shared-lib-path
(lambda* (#:key outputs #:allow-other-keys)
- (substitute* "src/foundation/pEp/jniadapter/AbstractEngine.java"
+ (substitute* "src/java/foundation/pEp/jniadapter/AbstractEngine.java"
(("System.loadLibrary\\(\"pEpJNI\"\\);")
(string-append "System.load(\""
(assoc-ref outputs "out")
@@ -313,16 +304,18 @@ JAVA_HOME=~a
(substitute* "src/Makefile" ;; suppress some warnings
(("^\\s+OLD_JAVA=") " xxx_OLD_JAVA="))
#t)))
+ (add-before 'build 'build-codegen
+ ;; run codegen first to allow parallel build of other parts
+ (lambda _
+ (invoke "make" "-C" "src" "create-dirs" "codegen")))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(libout (string-append out "/lib/"))
(javaout (string-append out "/share/java/")))
- (mkdir-p libout)
- (mkdir-p javaout)
- (copy-file "src/libpEpJNI.so"
- (string-append libout "/libpEpJNI.so"))
- (copy-file "src/pEp.jar" (string-append javaout "/pEp.jar"))
+ (install-file "dist/libpEpJNI.a" libout)
+ (install-file "dist/libpEpJNI.so" libout)
+ (install-file "dist/pEp.jar" javaout)
#t)))
(add-after 'install 'install-docs
(lambda* (#:key outputs #:allow-other-keys)
@@ -337,13 +330,14 @@ JAVA_HOME=~a
#t))))))
(native-inputs
`(("doxygen" ,doxygen)
+ ("graphviz" ,graphviz)
("openjdk" ,openjdk9 "jdk")
("which" ,which)
("yml2" ,yml2)))
(inputs
`(("libpepadapter" ,libpepadapter)
("pep-engine" ,pep-engine)
- ("util-linux" ,util-linux))) ;; uuid.h
+ ("util-linux" ,util-linux "lib"))) ;; uuid.h
(home-page "https://pep.foundation/")
(synopsis "Java adapter for p≡p (pretty Easy Privacy)")
(description "The p≡p JNI adapter is a Java adapter interface to the p≡p
--
2.21.4
H
H
Hartmut Goebel wrote on 31 May 2021 10:47
Re: bug#48382: Acknowledgement ([PATCH 1/6] gnu: yml2: Update to 2.7.0.)
(address . 48382-close@debbugs.gnu.org)
e67baf14-10db-181e-c3cb-17956c07c30c@crazy-compilers.com
Pushed as c85edf2ca47a10634faba15848cca7b4558a82ab

--
Regards
Hartmut Goebel

| Hartmut Goebel | h.goebel@crazy-compilers.com |
| www.crazy-compilers.com | compilers which you thought are impossible |
?