(address . guix-patches@gnu.org)(name . Stefan Reichör)(address . stefan@xsteve.at)
* gnu/packages/admin.scm (rset): New variable.
---
gnu/packages/admin.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)
Toggle diff (48 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index fdcbf28a6a..c17609c442 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -3371,6 +3371,41 @@ Intel DRM Driver.")
(supported-systems '("i686-linux" "x86_64-linux"))
(license license:expat)))
+(define-public rset
+ (package
+ (name "rset")
+ (version "2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/eradman/rset/")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "150my3lvql3m6jn1c12x81jx990nqh5g02v6r9a5j51ds39shr39"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (invoke "./configure"))))
+ #:make-flags
+ (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ ,(string-append "CC=" (cc-for-target)))
+ #:tests? #f)) ; TODO: test target requires ruby, curl, uname
+ (home-page "http://scriptedconfiguration.org")
+ (synopsis "Configure systems using any scripting language")
+ (description
+ "rset(1) operates by staging files on a remote system, then executing
+instructions embedded in the pln(5) files. Any interpreter capable of running
+scripts read over a pipe may be specified. The bundled utilities rinstall(1)
+and rsub(1) provide an easy means of installing and modifying configuration
+files, and capabilities are added by writing utility scripts which are sent
+along with configuration data.")
+ (license license:isc)))
+
(define-public fabric
(package
(name "fabric")
--
2.25.1