Haskell cabal new-build fails

  • Open
  • quality assurance status badge
Details
2 participants
  • Bone Baboon
  • zimoun
Owner
unassigned
Submitted by
Bone Baboon
Severity
normal
B
B
Bone Baboon wrote on 11 May 2021 16:23
(address . bug-guix@gnu.org)
87cztxfix7.fsf@disroot.org
I am experiencing an error when I try to compile a Haskell program with
Cabal a Haskell build tool.

Previously I had Cabal working and was able to compile Haskell
programs.

Now when I try to build a Haskell program with `cabal new-build` I get
an error.

`guix describe` outputs:

```
Generation 14 May 11 2021 08:06:01 (current)
guix bddad00
branch: master
commit: bddad00bffc5837e89942756fa5b7234f63f1f47
```

The error message:

```
Build profile: -w ghc-8.6.5 -O1
In order, the following will be built (use -v for more details):
- <program>-0.1.0.0 (exe:<program>) (first run)
Preprocessing executable '<program>' for <program>-0.1.0.0..
Building executable '<program>' for <program>-0.1.0.0..
Linking <program-source-code-directory>/dist-newstyle/build/x86_64-linux/ghc-8.6.5/<program>-0.1.0.0/x/<program>/build/<program>/<program> ...

In file included from /gnu/store/fa6wj5bxkj5ll1d7292a70knmyl7a0cr-glibc-2.31/include/errno.h:28:0: error:
0,
from /gnu/store/5i95kk1qdfvl6ld3hf6a4q7kxw6sgpkv-ghc-8.6.5/lib/ghc-8.6.5/include/rts/OSThreads.h:28,
from /gnu/store/5i95kk1qdfvl6ld3hf6a4q7kxw6sgpkv-ghc-8.6.5/lib/ghc-8.6.5/include/Rts.h:168,
from /tmp/ghc8802_0/ghc_1.c:1:

/gnu/store/fa6wj5bxkj5ll1d7292a70knmyl7a0cr-glibc-2.31/include/bits/errno.h:26:11: error:
fatal error: linux/errno.h: No such file or directory
# include <linux/errno.h>
^~~~~~~~~~~~~~~
|
26 | # include <linux/errno.h>
| ^
compilation terminated.
`gcc' failed in phase `C Compiler'. (Exit code: 1)
```
Z
Z
zimoun wrote on 10 Jun 2021 13:10
(name . Bone Baboon)(address . bone.baboon@disroot.org)(address . 48352@debbugs.gnu.org)
86czsuj7px.fsf@gmail.com
Hi,

On Tue, 11 May 2021 at 10:23, Bone Baboon <bone.baboon@disroot.org> wrote:
Toggle quote (10 lines)
> I am experiencing an error when I try to compile a Haskell program with
> Cabal a Haskell build tool.
>
> Previously I had Cabal working and was able to compile Haskell
> programs.
> https://lists.gnu.org/archive/html/help-guix/2021-04/msg00096.html
>
> Now when I try to build a Haskell program with `cabal new-build` I get
> an error.

Does the John’s message fix the issue?


All the best,
simon
Z
Z
zimoun wrote on 2 Jul 2021 18:38
control message for bug #48352
(address . control@debbugs.gnu.org)
878s2on02b.fsf@gmail.com
tags 48352 + moreinfo
quit
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 48352@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 48352
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch