[PATCH] gnu: Add emacs-packed.

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Prikler
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Leo Prikler
Severity
normal
L
L
Leo Prikler wrote on 11 May 2021 13:23
(address . guix-patches@gnu.org)
20210511112344.15843-1-leo.prikler@student.tugraz.at
* gnu/packages/emacs-xyz.scm (emacs-packed): New variable.
---
gnu/packages/emacs-xyz.scm | 31 ++++++++++++++++++++++++++++++-
1 file changed, 30 insertions(+), 1 deletion(-)

Toggle diff (51 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 869f8c3c7b..22d22df0b8 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -55,7 +55,7 @@
;;; Copyright © 2019 Jelle Licht <jlicht@fsfe.org>
;;; Copyright © 2019 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
;;; Copyright © 2019 Stephen Webber <montokapro@gmail.com>
-;;; Copyright © 2019 Leo Prikler <leo.prikler@student.tugraz.at>
+;;; Copyright © 2019, 2021 Leo Prikler <leo.prikler@student.tugraz.at>
;;; Copyright © 2019 David Wilson <david@daviwil.com>
;;; Copyright © 2020 Paul Garlick <pgarlick@tourbillion-technology.com>
;;; Copyright © 2020 Robert Smith <robertsmith@posteo.net>
@@ -19877,6 +19877,35 @@ e.g. the package dependencies it requires. See function
file.")
(license license:gpl3+))))
+(define-public emacs-packed
+ (package
+ (name "emacs-packed")
+ (version "3.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://stable.melpa.org/packages/packed-"
+ version ".el"))
+ (sha256
+ (base32
+ "0rd6svls19qskn03pa54rx5qfvxzgs639cdycix4bkf5ayzypj5h"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/emacscollective/packed")
+ (synopsis "Package manager agnostic Emacs Lisp package utilities")
+ (description
+ "Packed provides some package manager agnostic utilities to work
+with Emacs Lisp packages. As far as Packed is concerned packages
+are collections of Emacs Lisp libraries that are stored in a
+dedicated directory such as a Git repository. And libraries are
+Emacs Lisp files that provide the correct feature (matching the
+filename).
+
+Where a package manager might depend on metadata, Packed instead
+uses some heuristics to get the same information — that is slower
+and might also fail at times but makes it unnecessary to maintain
+package recipes.")
+ (license license:gpl3+)))
+
(define-public emacs-picpocket
(let ((version "40")
(commit "6fd88b8711c4370662c0f9c462170187d092a046"))
--
2.31.1
N
N
Nicolas Goaziou wrote on 21 May 2021 17:54
(name . Leo Prikler)(address . leo.prikler@student.tugraz.at)(address . 48345@debbugs.gnu.org)
87r1i0w08m.fsf@nicolasgoaziou.fr
Hello,

Leo Prikler <leo.prikler@student.tugraz.at> writes:

Toggle quote (3 lines)
> + version ".el"))

Is it really stable? Wouldn't it be simpler to use git-fetch from
upstream directly?

Toggle quote (3 lines)
> +Where a package manager might depend on metadata, Packed instead
> +uses some heuristics to get the same information — that is slower

Nitpick: I think usual typography is like

same information---that is slower...

Otherwise LGTM.

Regards,
--
Nicolas Goaziou
L
L
Leo Prikler wrote on 21 May 2021 18:52
[PATCH] gnu: Add emacs-packed.
(address . 48345@debbugs.gnu.org)(address . mail@nicolasgoaziou.fr)
20210521165250.9903-1-leo.prikler@student.tugraz.at
* gnu/packages/emacs-xyz.scm (emacs-packed): New variable.
---
gnu/packages/emacs-xyz.scm | 32 +++++++++++++++++++++++++++++++-
1 file changed, 31 insertions(+), 1 deletion(-)

Toggle diff (52 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 7656c32b2e..2b46fea951 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -55,7 +55,7 @@
;;; Copyright © 2019 Jelle Licht <jlicht@fsfe.org>
;;; Copyright © 2019 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
;;; Copyright © 2019 Stephen Webber <montokapro@gmail.com>
-;;; Copyright © 2019 Leo Prikler <leo.prikler@student.tugraz.at>
+;;; Copyright © 2019, 2021 Leo Prikler <leo.prikler@student.tugraz.at>
;;; Copyright © 2019 David Wilson <david@daviwil.com>
;;; Copyright © 2020 Paul Garlick <pgarlick@tourbillion-technology.com>
;;; Copyright © 2020 Robert Smith <robertsmith@posteo.net>
@@ -20019,6 +20019,36 @@ e.g. the package dependencies it requires. See function
file.")
(license license:gpl3+))))
+(define-public emacs-packed
+ (package
+ (name "emacs-packed")
+ (version "3.0.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emacscollective/packed")
+ (commit version)))
+ (sha256
+ (base32
+ "06blk8parnpq3qi6y5628q3v59c8dyi41glb289a0l16248qwphk"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/emacscollective/packed")
+ (synopsis "Package manager agnostic Emacs Lisp package utilities")
+ (description
+ "Packed provides some package manager agnostic utilities to work
+with Emacs Lisp packages. As far as Packed is concerned packages
+are collections of Emacs Lisp libraries that are stored in a
+dedicated directory such as a Git repository. And libraries are
+Emacs Lisp files that provide the correct feature (matching the
+filename).
+
+Where a package manager might depend on metadata, Packed instead
+uses some heuristics to get the same information---that is slower
+and might also fail at times but makes it unnecessary to maintain
+package recipes.")
+ (license license:gpl3+)))
+
(define-public emacs-picpocket
(let ((version "41")
(commit "fa3a49f011b5ae139728548fec7375743f61c7c7"))
--
2.31.1
L
L
Leo Prikler wrote on 22 Jun 2021 18:39
Pushing old patches
(address . control@debbugs.gnu.org)
1355396ba740a2b74f7c0e7e6dcb9733a9120891.camel@student.tugraz.at
close 47268 b994ff128bc33091db256bc40906aa5d4e670aa1
close 48345 6f58ca5fb3c0abff168b2faa0a4edb8bde30f7a3
close 48746 f356c71ade3f3d45c806d3a84eecefbfbecd526f
thanks
?