Attempt to fix missing dependencies for python-oslo.i18n failed with "too many heap sections"

  • Done
  • quality assurance status badge
Details
One participant
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal
S
S
Sharlatan Hellseher wrote on 10 May 2021 23:34
(address . guix-patches@gnu.org)
CAO+9K5pOhtMNyTUkADa6F5_mW1wZyzCbWTKocWTn8PJqR1jkAw@mail.gmail.com
Hi Guix team!

Package python-oslo.i18n is broken to build in upstream

Toggle snippet (34 lines)
starting phase `check'
running "python setup.py" with command "test" and parameters ()
running test
Searching for bandit>=1.1.0
Reading https://pypi.org/simple/bandit/
/gnu/store/9w9jvy3bgjg4qaqmrij01nbppiccqr7c-python-3.8.2/lib/python3.8/site-packages/setuptools/dist.py:45:
DistDeprecationWarning: Do not call this function
warnings.warn("Do not call this function", DistDeprecationWarning)
Download error on https://pypi.org/simple/bandit/: [Errno -2] Name or
service not known -- Some packages may not be found!
Couldn't find index page for 'bandit' (maybe misspelled?)
Scanning index of all packages (this may take a while)
Reading https://pypi.org/simple/
Download error on https://pypi.org/simple/: [Errno -2] Name or service
not known -- Some packages may not be found!
No local packages or working download links found for bandit>=1.1.0
error: Could not find suitable distribution for
Requirement.parse('bandit>=1.1.0')
command "python" "-c" "import setuptools,
tokenize;__file__='setup.py';f=getattr(tokenize, 'open',
open)(__file__);code=f.read().replace('\\r\\n',
'\\n');f.close();exec(compile(code, __file__, 'exec'))" "test" failed
with status 1
builder for `/gnu/store/ld9s5i13f8ja235nmr05fh7z837f51kw-python-oslo.i18n-3.20.0.drv'
failed with exit code 1
build of /gnu/store/ld9s5i13f8ja235nmr05fh7z837f51kw-python-oslo.i18n-3.20.0.drv
failed
View build log at
'/var/log/guix/drvs/ld/9s5i13f8ja235nmr05fh7z837f51kw-python-oslo.i18n-3.20.0.drv.bz2'.
guix build: error: build of
`/gnu/store/ld9s5i13f8ja235nmr05fh7z837f51kw-python-oslo.i18n-3.20.0.drv'
failed

My attempt to updte the package and add missing test dependencies was
failed with other issue:

Toggle snippet (3 lines)
Too many heap sections: Increase MAXHINCR or MAX_HEAP_SECTS Aborted

I tried to apply this changes

--
… ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
From 0cf4299c07138b0c5d6003a2d4dd459d6361aac1 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Mon, 10 May 2021 22:32:20 +0100
Subject: [PATCH] oslo.i18n

---
gnu/packages/openstack.scm | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
index 54df08863e..a0193c2787 100644
--- a/gnu/packages/openstack.scm
+++ b/gnu/packages/openstack.scm
@@ -457,14 +457,14 @@ pipeline and used by various modules such as logging.")
(define-public python-oslo.i18n
(package
(name "python-oslo.i18n")
- (version "3.20.0")
+ (version "5.0.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "oslo.i18n" version))
(sha256
(base32
- "0kjcdw4bk3mi4vqmqwhhq053kxbbbj05si6nwxd1pzx33z067ky3"))))
+ "0nq3dr2kbrawqvp9q9i8i44z9jliq98i2b9h4dsl6p7p60gbg11l"))))
(build-system python-build-system)
(propagated-inputs
`(("python-babel" ,python-babel)
@@ -474,7 +474,9 @@ pipeline and used by various modules such as logging.")
;; Tests
("python-mock" ,python-mock)
("python-mox3" ,python-mox3)
+ ("python-bandit" ,python-bandit)
("python-oslotest" ,python-oslotest)
+ ("python-oslo.config" ,python-oslo.config)
("python-testscenarios" ,python-testscenarios)))
(home-page "https://launchpad.net/oslo")
(synopsis "Oslo internationalization (i18n) library")
--
2.31.1
S
S
Sharlatan Hellseher wrote on 8 Feb 19:32 +0100
(address . 48339-done@debbugs.gnu.org)
8734u2vmcd.fsf@gmail.com
Closing as never applied and not actual.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmXFHiIACgkQdtcnv/Ys
0rUM2Q//UfRzpJnTNK1iqSkNEy/B0epMWpiPvL6JPf3F4IvEBI2dkQm6a4mtLTI6
fT0B4EpkLwBJteciD8h1m8sRFwByrlZHFRaiGLMwNGvOeMvh+m+GVynKl6LyGvUh
0vYULdL6ZevjxPeMwhIuGo0KrJXCCTQwKgGyaMa3Y/TKUENIJl/vKCxbrrGxcLnb
J5iiOMDbg6LZAu0Opglcny8Ox3XNKsCNvyvp24MDUTG5ghxRipR4qFMRqcSDnMpB
Kf+VNmD24rKIUA70MhxN0mkVbFWMJMPnMQj0eO2A815mWFdmP1EFoMKoVzNX+dpo
CmRkn1tpikBpJGS2kNtqG9ppc9RTf9EJvl3FkKHK6NaWWDymvAN+j9+MueKGITdN
h+qmaW0rlQrPGHXk79pI/V5OfLwTMYzfx6pGzO7RLx4KVCNt21010VOgZALcrr0y
oa8j0ybNC1LDVQOKxktDJlcesx5dvTHfLJfhVqZGTCeCbi3fwfoCVtOXMvKz781Z
x030uwfsFx7iWHTHPdVkXSWhvEYpzyUdmG0d6KyYKEn5vvd65j340oVpwkfL7J49
WZ29tqN+0ZrYbacKWY7kgyZ5354JR9eVQOHfv4beMYxYy2dNgjdervRieLxS62Yy
Ww1mi7hXarKaX71Rjukkx3jKCvwFjsvU50PfT0TkjveHgkYxJdY=
=ds8S
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 48339@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 48339
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch